How to solve no POST/ Boot issue of Dell Inspiron 15z 5523

Dell Genuine refurbished inspiron 15z i...
November 1, 2016 at 22:01:47
Specs: Windows 10, 8
I have solved the problem of no POST, or booting and black screen on Dell Inspiron 15z 5523 (this may apply to other laptops of the same series). Sometimes, you may hear different beeps - which is not consistent. I know it's very late, but wants to help people who would read this after having the same problem.

This problem started after I upgraded to Windows 10 and updated BIOS. This also happens when I tried to boot from external HDD.

When this happens, if you try to force shut down (holding the power button for 6 seconds and leaving) and restart continuously, you can make the PC start. You may have to try this 10s of time - every time after reseating and pressing reset button (this button is visible when you open the RAM compartment - read the manual). If this does not work, remove the BIOS battery (refer manual how to disassemble the laptop) and wait for 15 minutes and replace, then try. You may have to do this several times.

Before trying the above mentioned restart procedure make sure to create a bootable DOS USB flash disk and download and save a new BOIS firmware (this can be freely downloaded from Dell website) on the disk. If you already have the latest BIOS firmware, download a lower version of the firmware.

When the laptop boots (by chance as explained above) make sure your USB flash disk is already inserted on the laptop. Keep pressing F12 (in quick succession) before even you see anything on the screen. This will land you on the boot screen. Now choose the USB drive that you have inserted as the boot device - this will bring you to the DOS prompt.

Now type: DIR and press enter.

You will now see a list of files in the USB drive. Type the name of the file exectly as it appears on the list. Press enter.

If it says that your firware version is lower than the existing version, type the name of the file with /forceit swtich (eg: 5523A05.EXE /forceit)

This will start the updating process and ask you for confirmation - press Y.

Once this completes, the problem with your laptop will be solved. The problem may come back if you try to boot again from an external hard disk.

The problem is not with the motherboard but with the BIOS. Enjoy.


See More: How to solve no POST/ Boot issue of Dell Inspiron 15z 5523

Report •

#1
November 1, 2016 at 22:06:10
Thank you for your information. It might help others at some future time.

message edited by trvlr


Report •

#2
November 2, 2016 at 00:17:19
It sounds like you're saying the updated bios is buggy and the solution is to revert back to an earlier version.

Report •

#3
November 2, 2016 at 00:36:58
Yes, kind of. But I had the same problem even after downgrading the BIOS. Unfortunately now I can't downgrade the BIOS. Is there any generic/ modded BIOS I can use on this system?

Report •

Related Solutions

#4
November 3, 2016 at 01:05:18
The only update(s) you should try would be on the support page for that Dell model. Anything else would likely not install or would wreck the laptop if you got it installed. You may want to contact Dell and tell them you think that particular bios upgrade is bad.

Report •

Ask Question