How to recover data from a RAID 0 array?

December 14, 2010 at 17:38:31
Specs: Windows 7
Hi everyone, this is my first post here :)

I have read through a lot of the existing threads regarding this problem but haven't found a solution. I think this one is actually simpler than what others are posting about. I guess we will see. Here is the situation:

I have a Dell XPS 630i machine. It has Vista Home Premium 64 installed. It has 8GB RAM wooohooo! and 2 500GB HD's in a RAID 0 array. I stupidly ran Malwarebytes (I love this program but it kills 64 bit machines). Anyhow I ran Malwarebytes in safe mode, removed a couple trojans, and rebooted the machine. I have not been able to get to the desktop since. It starts up, passes POST, gives me the Starting Windows splash screen, then the cursor comes up and thats it.

I cannot open the task manager.
I cannot get into safe mode.
All of the hardware is good.
The RAID 0 array is healthy.

All I want to do is back up the data on the hard drives the wipe it out and install Windows 7.

So my question is... how do I get that data backed up?

I would really appreciate any help anyone has to offer.

Thank you!


See More: How to recover data from a RAID 0 array?

December 14, 2010 at 17:49:44
Hopefully you can boot up a Live CD such as one of the linux distros or maybe even Ultimate Boot CD. If the Raid Array is healthy you may be able to recover your files and back them up to an external destination.

My other suggestion is to dismantle the RAID 0. What an absolutely pointless and high risk configuration to employ. Who needs a partition 1TB in size?

You do know that RAID 0 spreads your data over both physical disks and if either encounters a problem you lose the lot. I can understand using a RAID 1 mirrored array as a safety backup procedure, but with the advent of large capacity drives RAID 0 has been rendered obsolete and the risks associated with it far outweigh any perceived speed benefit you think you might gain.

Goin' Fishin' (Some day)

Report •

December 14, 2010 at 18:04:05
Thanks for the speedy and good advice Richard.

I have tried booting to all of my favorite tools but got the BSOD every time. Then a little light bulb turned on.... use a 64 bit linux distro, not the 32 I have used in the past.

Bingo! I just booted to Ubuntu 64 and all is right in the world. I can back up from here and reinstall tonight.

Again, thanks for the feedback. This site rocks!


Report •

December 14, 2010 at 18:06:25
Oh, and I agree with you 100% about the RAID 0 being useless. This time around I am going with a dual boot Windows 7 and Ubuntu on disk 0 and Data on disk 1. This will be good :)

Report •

Related Solutions

December 14, 2010 at 18:30:30
If a live linux cd isn't usable then you may also be able to make a bartsPE or UBCD4win disk or VistaPE to access the data. May need to add in array drivers to be able to access the array. If you have higher end hardware raid it may be a live Opensuse may be best. It has some of the better raid array support.

Why did it take me over a year to phone in a problem to ATT?

Report •

December 15, 2010 at 10:33:29
Thanks for the suggestions jefro. I did manage to gain access with Ubuntu 64, but ran into some problems when copying the data to an external drive. I will have to check that error again tonight... by the time I saw there was a problem I was done for the night.

I think I will make a UBCD4win and BartsPE today and test them tonight.

Thanks again!

Report •

December 15, 2010 at 12:30:32
If you have access then it is 99% fixed. That was the hard part.

Why did it take me over a year to phone in a problem to ATT?

Report •

Ask Question