how to rapair undetected Hard Disk

Wd Western digital 20gb 7200rpm 3.5-inch...
October 24, 2010 at 02:52:06
Specs: Windows XP, P 4
I am Trying Boot My Pc With Western Digital WD 200 But It Just Gives ME A Beep Like Sound and At times Getting Heated...And To add To fuel to it is not getting detected....
I have tried Using It As A Master As Well As slave Device But Found No result//
So PLs If Any 1 know it hw to solve this let me know on

See More: how to rapair undetected Hard Disk

Report •

October 24, 2010 at 03:16:03
If the drive is not detected in bios and is heating up when power is applied to it then I suspect it is toast. Recovery options are limited. You can try to replace the circuitboard but the replacement would have to come from an identical drive from the same manufacturing series, or you can send it to a data recovery company at great expense. Replacing the circuitboard may not work if the problem is in the drive motor or read head. It may be mechanically damaged.

Goin' Fishin' (Some day)

Report •

October 24, 2010 at 07:53:25
I know abt this option..BTW thanx For ur Kind Reply....
But Is There any option to get back the drive it doesnt matter if the Data Is lost....

Report •

October 24, 2010 at 12:13:03
Is the hard drive an IDE type connection or a SATA type? If IDE you may have jumpers set incorrectly. Most Western Digital IDE drives have two Master jumper settings. One for Master alone, and one if there is another drive connected to the same cable.

When using two drives on the same cable one must be set as master and the other as slave. Or, both must be set to CS.

The power or data cables may not be connected correctly or cables can go bad,

What is the full model number of the hard drive.

Watch the POST screens at start up to see if the drives are being properly by both model and FULL capacity.

Report •

Related Solutions

May 15, 2011 at 03:54:40
hi I'm facing the very same problem can't get my samsung 320 gb external hard drive detected,on any computer any,since one night i busy running downloads via Bitcomet on the computer at work that usually had trouble detecting it. then after about 30 minutes it just popped a Bitcomet stopped working message.I tried unplugging it then plugged it back in in again, then it said computer is not well maintained ,how's that possible on a computer that is 24 hrs connected to the internet with Kaspersky v6 workstation.

then i took it home and tried it again nothing seems to work even tried a different cable but still no detection.

Before this Windows warned me that the drive needed some formatting, but i didn't format it since i had my whole computer files on it.

Can somebody please HELP....... PLS.


Report •

May 15, 2011 at 06:11:47

Your problem is NOT the same. Even if it were, you still need to start your own thread here. Post in this hardware forum and provide hardware/ OS details and what led up to your problem and what you have tried so far to fix it.

Report •

Ask Question