Solved how to manage Synology NAS on file explorer in win 10

June 8, 2019 at 03:54:56
Specs: Windows 10, AMD Ryzen 3 1200
Have connected my Synology NAS and installed it. Now I want to manage it/save and load files with windows explorer. But Windows explorer is in win 10 called file explorer and does not have the possibility to map an external drive any more. Is there an alternative way to do this ?

I have thought of downloading the windows explorer for windos 7. Is that possible or do you have another suggestion ?

Thanks fort any help. As a NAS is a type of H?/SDD contraption I cose harddrives as the sucategory.

message edited by willem1933


See More: how to manage Synology NAS on file explorer in win 10

Report •

#1
June 8, 2019 at 05:32:21
✔ Best Answer
Click on "This PC" in File Explorer. Then Select the "Computer" tab. Mapping a network drive is one of the options on this tab.

(You can also do it via the command line or via the "Network" item in File Explorer.)


Report •

#2
June 8, 2019 at 06:35:49
Did that, chose a drive letter. Result: "Windows cannot access \\synology". As it suggeted a network problem, I ran the "Windows Network Diagnostyics". Result "no problems found".

The Synology NAS diskstation has its own interface and a working drag and drop feature, but ....... that is very slow and I want to centralize what I have collected and sent over the years on different external HDDs. I've tried the drag and drop wit the same file name but with different content. Only the last show up in the NAS.

Why does the Synology NAS show up in file explorer and does Win 10 not accept the drive letter ? Something to do with mounting the drive ?


Report •

#3
June 8, 2019 at 08:24:36
Have you turned on network discovery?

https://www.laptopmag.com/articles/...

I use a Synology NAS with Windows 10 and it works just fine.


Report •

Related Solutions

#4
June 9, 2019 at 01:47:17
have you setup the sinology first?
enter the NAS IP address with port 5000 (192.168.x.x:5000)
You will have to activate the SMB and create accounts for the ussers who have access to your Syology
Also define shared folders etc.
https://www.howtogeek.com/318018/ho...

Report •

#5
June 9, 2019 at 04:40:51
I fully set up my NAS before trying to map the drive. Read the advices in #3 and #4 above, but the situation persists. When I use mapping the drive with "\\synology" or with the IP address, the outcome is the same. Can my Bitdefender Total Security 2019 or my NordVPN have anything to do with this ?

Report •

#6
June 9, 2019 at 05:44:43
That is useful additional information.

Bitdefender is blocking access to the NAS. Google "Bitdefender Total Security Cannot Access NAS" for a number of links explaing what you need to do.


Report •

#7
June 13, 2019 at 04:25:37
Luckily I can report that eventually I succeeded to map my Synology drive folders, where mapping the whole Synology device was not possible. I now have the documents and my music folders in Synology mapped in Win 10 file explorer. So you cannot map the device, but only folders in the device.

An additional finding is that streaming music files to the VLC programme is very disappointing in quality, which I presume has to do with the network speed, especially if you are doing other things on your PC


Report •

Ask Question