How do I reset a USB Root Hub from high to

June 4, 2014 at 12:15:09
Specs: Windows 7
My ASUS eee 1015PX netbook with Windows 7 Starter keeps prompting me to improve the performance of one of my USB Root Hubs called 27CC. The Device Manager says this hub is running correctly but I notice that it is running on "high power" while the other 4 USB Root Hubs are running on "full power". So I try to "Reset Hub" (button under Properties/Advanced) but nothing happens (it's not greyed out). So what am I supposed to do please?

LATER EDIT: Problem seems solved - even though it looked like nothing happened when I hit the Reset Hub button, it seems something did. Hub 27CC is now an "Enhanced" Hub, USB2 and the annoying message to upgrade the hub has stopped. So I don't need any responses thanks.

message edited by tony0

See More: How do I reset a USB Root Hub from high to

Report •

June 5, 2014 at 00:14:08
Glad you fixed it.

Report •

June 9, 2014 at 02:00:46
I spoke too soon. The message disappeared for a few days but is now back. It is very strange: Windows says all devices are working correctly but I get this message. There is of course a difference between working correctly and "could be improved" but the "composite device" that the message complains about is apparently working as a USB2 hub (according to Windows). The message tells me move the "composite device" to another hub in a list which includes the "composite device" itself. Does anyone have any idea what is going on here, please?

Report •
Related Solutions

Ask Question