Solved Hitachi external HDD cant assign letter & can't access files

June 4, 2012 at 20:26:49
Specs: Windows XP
when i plug in my hitachi lifestudio hard drive the computer says its good & ready to use but then when i want to open files or locate the drive , i can't find it ! its not located under my computer also i noticed when i went to disk management the hitachi doesn't have a letter assigned & i tried assigning it but when i right clicked the " change letter or partition" wasnt highlighted? i've tried uninstalling the hard drive , connecting to different usb ports & turning it off & on but still no luck? can someone please help me access the data on the drive? or at least try to fix this? please & thank you

See More: Hitachi external HDD cant assign letter & cant access files

Report •

June 5, 2012 at 04:05:14
You first should test the drive to see if it has failed, because if it has there is no way to access it's data other than to take it to data recovery service who use special equipment (and charge a small fortune).

As it's an external USB drive, you'll need to test it with Windows software since DOS software can't detect USB drives.

Test it with Seagate SeaTools for Windows. Click "Downloads" on this page:

Report •

June 6, 2012 at 07:38:49
✔ Best Answer
Check the device manager to see if the mass storage device has an ! on it. You might also want to uninstall the driver and reinstall with the disk. Ocassionally windows will install the windows version of the mass storage device when it should be the mfg's version. Attempt to install the program/driver with the mfg cd (if available, or download from their website) BEFORE you plug in the drive to ensure windows doesn't get there first.

After you do that, if it still doesn't work, reboot then;
In disk management (you've been there) see if "Mark active partition" is available. This might be necessary.

After you do that, if it still doesn't work, reboot then;
After it is plugged in, check to see if the drive is good with a smart device. (works on usb too)

After you do that, if it still doesn't work, reboot then;
You need to get a program like easeus home partition manager (or similar). Find the one that works with USB drives by searching their site, and through that program do a disk check or see if the drive needs to be marked as active..

Please follow up with your progress or results.

The Computer Dr
Chris Robertson

Report •

June 6, 2012 at 18:08:53
thank you so much (: although i had to reboot it & it lost the data, im happy that my computer can access the drive & i can access it ! im not really mad about the data because i know i can get it back !(: but thank you so much for helping me really appreciate it !

Report •

Related Solutions

June 6, 2012 at 19:22:12
See response 2 regarding how you use Safely Remove Hardware:

See response 2 regarding examples of which programs you could try to use to repair the data damage:

Report •

Ask Question