Hey guys, CD-ROM troubles.

March 25, 2011 at 18:16:39
Specs: Windows Vista, 2.44/2.00 gigs ram
My fiance's CD-ROM will not open on her Vista machine. There is not a disk in it, however the green light is constantly on. When I press the eject button manually, nothing happens; the light won't even blink.

I tried using device manager to update the driver, but it says that everything is up to date and the device is working properly. I have manually opened the tray while the machine was off to make sure it was empty, and to see if maybe that would make it realize the drive was empty, to no avail. When I try to right click on the drive in explorer, explorer crashes.

I have tried disabling the device and re-enabling it to see if that helps, to no avail. In typical fiance fashion "I don't know what happened, it was working fine and now it is not." so I don't know of anything that she may have done or changed to cause this, however she assured me she didn't bump in to it, use it as a cup holder, or a donut warmer.

My next step is going to be to break open the case and unplug it, restart the machine so it sees that it is gone, and then plugging it back in to try and have it recognize it for the first time and reinstall a fresh driver, I will let you know if this helps...

Any ideas other than replacing the drive? Thanks in advance for all the help! For further info, I just reinstalled a clean version of windows to fix a problem she was having where windows failed to start, hoping that it would fix this issue as well; however this problem is persisting.

See More: Hey guys, CD-ROM troubles.

Report •

March 25, 2011 at 18:22:46
Also, while installing her Windows it is showing that the SM bus has no driver, but I have read elsewhere that this can be fixed once I have all of her updates installed on the machine, but I'm not sure if it could be related as the SM bus doesn't seem to be a controller for the CD-ROM.

Report •

March 25, 2011 at 18:51:47
The SM Bus driver is installed when the main chipset drivers for the mboard are installed.

Whenever you load Windows from a regular Windows CD (or DVD) from scratch, after Setup is finished you must load the drivers for the mboard, particularly the main chipset drivers, in order for Windows to have the proper drivers for and information about your mboard hardware, including it's AGP or PCI-E, ACPI, USB 2.0 if it has it, and hard drive controller support. If you have a generic system and have the CD that came with the mboard, all the necessary drivers are on it. If you load drivers from the web, brand name system builders and mboard makers often DO NOT have the main chipset drivers listed in the downloads for your model - in that case you must go to the maker of the main chipset's web site, get the drivers, and load them.

In any case, the CD drive is probably fried.

- all that is needed for the tray to open and close when you push the button on the front of it is for it to have it's power plugged in and for the computer to be running

- the led should never be on all the time.

If this is on a desktop computer there may be a problem with the data cable for it, you could try unplugging it, but I doubt that will cure your problem.

Report •

March 25, 2011 at 19:10:47
Wow thanks for the quick response! Sounds like I was on the right track as it is. Try to unplug it, and if not it's fried. But they are a dime a dozen I just was hoping to not have to wait for the mail, I'm an impatient man.

The only other thing I had read said that it was possible that the CD Drive was being recognized as an SPCI (or spsci?) device, but I have no idea what that means, or how to change it.

Appreciate the info on the SM bus too, I will look at the motherboard to get all the info when I pull the case apart, and get all of those things downloaded after these updates finish installing.

Again, thanks a lot for the promptness!

Report •

Related Solutions

March 25, 2011 at 20:43:43
"The only other thing I had read said that it was possible that the CD Drive was being recognized as an SPCI (or spsci?) device, but I have no idea what that means, or how to change it."

That's SCSI - Small Computer System Interface - pronounced "Skuzzy" - there used to be some SCSI (CD only) optical drives long ago but they required a SCSI drive controller, usually provided by means of a card you installed in a ISA or PCI mboard slot, a few mboards had it built in, but I don't think anyone is making the SCSI optical drives anymore.

Microsoft chose to use Window's long time built in SCSI support to support SATA drive controllers rather than coming up with something new.

Report •

March 26, 2011 at 00:50:51
Again more awesome info! As an update, the problem is solved. I took the ATA cable off of the CD rom and just plugged in the power cable, and the drive opened and closed perfectly. When I put the cable back on I used a different ATA port (was on 2, now on 3) and it worked like a charm.

The plus side, now that the CD rom was working, I was able to use the utilities cd that came with her machine to install the Bus controller driver.

Now whether that means the port is bad, or it just needed to be unplugged and plugged back in, I won't worry about, I don't see us needing an extra port.

Long story short, everything is as it should be and right with the world. Thank you so much for your help! While I'm a clever guy, sometimes I just press ahead with more confidence than I should have that something will work, and while that works on cars and the ladies, it doesn't sit so well with computer repair.

I will recommend this to anyone I know who has any PC trouble! Great site, and great help!

Report •

March 26, 2011 at 06:34:23
Thanks for the thank you.

What you're referring to as an ATA port, that's probably a SATA (data cable) header.
Where you connect data cables are usually called headers rather that ports.

I've never heard of a SATA header's circuits being damaged and producing your symptoms, but that's possible.

More common is a poor connection....

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

....or possibly a damaged data cable itself but that's not likely for a SATA data cable.

Report •

Ask Question