Hex edited partition table Trouble

Samsung / Hd321hj
December 30, 2009 at 18:23:44
Specs: Windows XP sp2, dual core/2 gb
I have two hard disks. One has xp and the other is used just to keep data. This is in reference to the second data disk on which there is no os.
I was experimenting with partition tables and just to see what happens changed the system id in an empty partition at adress 0x01c2 from 0x00 to 0x07(basic disk) and since then i have not been able to access it with any method.
since then i have it physically disconnected. Some observations:
1. Whenever i connect it, the os stops loading and shows the blue screen.
2. I tries using bart pe with a sector editor plugin to try to change it back but BartPE while loading shows the blue scree.
3. I tried using fdisk: my partitions are ntfs but even then it should have shown them as "non-dos". it doesnt even show my drive.
4. i tried to use xp recovery console but at the point at which it says "loading windows" it hangs and shows the blue screen.

i know for sure that my second disk is causing this as i have double checked all these steps after removing the corrupted disk and each step works fluently.
i know that disk is ok and just after the moment i changed the disk id it stopped responding but is shown in bios.
if any of u could give any suggestions i would be thankful.

See More: Hex edited partition table Trouble

Report •

December 30, 2009 at 19:10:45
Do have a live linux or a floppy drive ?
If floppy go to page below -bottom and see note #3.

I have messed with partition table many times but never tried your test.

Report •

December 31, 2009 at 16:58:33
thanks for the reply...
sorry i wrongly stated that it was unaccessible under fdisk. it is after changing the selected disk(option 5 in fdisk) which i kind of missed last time.
ubuntu could recognize my disk. i deleted the partition and opened it up in xp and then i could access it.
i wonder why the XP is unable to load under these conditions .
In xp i had a copy of its old mbr and so i updated it just to again try it.
1. If i kept disk id to 42(dynamic disk) and 00 at other empty partitions, it was accessible via xp
2. If i kept disk id to 42(dynamic disk) and 07 at the next empty partition(just one other ),it was accessible via xp but if i write 07(so total 3) to all the others too then it is UNaccessible not even via fdisk.
3. if i kept disk id to 07(basic disk) and 00 at other empty partitions, it was accessible via xp
4. if i kept disk id to 07(basic disk) and 07 at just one other empty partition, it is accessible but if i do it to all the 3 then it is inaccessible(as in xp doesnt boot) but surprisingly accessible via fdisk!!!)
now i want to know why so.

Report •

Related Solutions

Ask Question