Help - epson tm-t88iv receipt printer not available

February 24, 2016 at 02:15:55
Specs: Windows 7
Hey guys. I am having a similar problem with my printer epson tm-t88iv receipt printer not available.The printer has been working fine until yesterday. Now unable to use my POS to generate reciepts. I viewed a post showing resolved a few years back but the link given bto show directions is no longer available. Pleeeease help......Se below post quoted.....

Well I was able to get beyond the Not Avaialble issue. I installed new drivers by following the directions @ this llink

See More: Help - epson tm-t88iv receipt printer not available

Report •

February 24, 2016 at 06:10:43
Don't know what similar problem you mean without a link to it.

The best place to get drivers from is Epson. It shouldn't be necessary to upgrade them but they might have been corrupted. As it was only yesterday you could always try Windows System Restore to before the problem came along - it keeps your own stuff. If restore doesn't fix it then most likely it is a fault with the printer itself.

The driver link you gave didn't work for me.

Always pop back and let us know the outcome - thanks

Report •

February 24, 2016 at 16:41:28
Sometimes going to Devices and Printers and removing the printer (right click menu) and then adding back the printer with the existing drivers does the trick when nothing else appears to work.
Sometimes just restarting the computer and the printer is enough to fix it.

You have to be a little bit crazy to keep you from going insane.

Report •

February 24, 2016 at 22:54:10
Derick...i tried re-installing the drivers with the old and newer drivers no luck....system restore worked for me the first time around but a week later the same issue was back....

Fingers...I have tried the three options restarting the comp, printer and also removing the printer and adding it using both existing and already installed drivers.....none seem to work...

Report •

Related Solutions

February 25, 2016 at 08:03:27
The link in your original post is still not working.

First unplug all cables and plug them in firmly again, also try other USB sockets on the computer.

Assuming this doesn't help go here:

Select Windows Printer Driver.

I would be inclined to run all three of these in the order given, restarting the computer and trying the printer at each stage:

EPSON Advanced Printer Driver Delete Temp Tool Ver.1.00

You then select "EPSON Advanced Printer Driver for TM Series Ver", choosing the
one that matches your series number (not given). Read the information to ensure the download is right for your device and country.

EPSON Advanced Printer Driver Update Tool.

The first and last effectively do a bit of rubbish clearing, so might help.

How old is the printer?

Always pop back and let us know the outcome - thanks

Report •

February 25, 2016 at 08:23:15
I should have said, go to Control Panel, find Java and check that it's working as it is apparently used for your device. Might as well make sure it is up to date while you are there.

Always pop back and let us know the outcome - thanks

Report •

Ask Question