HDD problem on Sony laptop

July 26, 2020 at 22:33:22
Specs: Windows 7
Hi

I have a Sony Vaio laptop (Model PCG – 61813M) (4GB RAM) running Windows 7 Home that I am trying to repair for my young granddaughter (schoolwork etc). It was going so slow accessing programmes that it became impossible for her to use. For example, click on a programme and it could take 10 minutes or more before it finally ran (that’s if it did run). I tried all sorts of things to fix it but nothing worked. Too much too explain here.

After saving all the files that were important (I used a Hiren’s CD to access the HDD) I decided to use Vaio recover. It took a long time but it went ok. On one of the re-boots though, during the recovery process, it did start check disk and found some entry errors. There were no reports of bad sectors. Eventually, it did boot into Windows OK.

I then did all sorts of things like installing Chrome and an anti-virus programme etc. It went ok. No problem. Ran quite good actually. Then I started to copy back all the important stuff I had saved. That was OK to start with but after a short while it said, on a black screen, “Cannot find Operating System”.

Since then I have not been able to access the HDD. When I press the power button I get a screen saying “Start Windows normally” or “Launch Start up repair”. If I opt for the former I get the “Starting Windows” splash screen with the Windows logo but it eventually returns to the options screen. If I opt for “repair” it goes into the all blue Vaio rescue screen but goes no further. If I use the “Assist” button (Vaio care Rescue) it says ‘Starting Windows” (with the animated Windows logo) but then says on the next screen “Please wait while Vaio Care Rescue is starting” but it goes no further (no matter how long I wait).

I have tried the Hiren’s CD again (which worked perfectly previously) but now it cannot find the HDD. I have also tried using a Windows XP boot up disk (which certainly works OK) but it too fails to find the HDD. I get quite a lot of coded info etc (too much to type here), including an error 2200 code.

I assume from the above that the HDD is physically working ok, but that there are problems with the Boot Up sectors (or something like that).

BTW, I removed the HDD. Powered up. BIOS reported no HDD. Put it back in again. This time the BIOS recognised it correctly.

Can anyone give me any advice – or is it something that is beyond repair? Any help appreciated. Thank you.

Terry


See More: HDD problem on Sony laptop


#1
July 27, 2020 at 00:54:00
It sounds like the hard drive is failing. Go to the support site of the hard drive manufacturer and look for a 'drive fitness test' (or words to that effect). You'll want one that works in a dos environment since your windows isn't working. Follow their instructions but you'll be booting from a dos disk and then running the fitness program. See what the results say.

Reply ↓  Report •

#2
July 27, 2020 at 01:03:03
Thank you DAVEINCAPS

What I cannot understand is how would it boot into "Starting Windows" (which it does) and go no further.  I have tried a couple of the programmes in Hiren's Cd, this morning, also from an ISO, and each time it says "Drive not ready". Does that provide any clues?


Reply ↓  Report •

#3
July 27, 2020 at 01:54:22
Drives start to fail in various ways; sometimes they seem to be ok and then the next minute not so.

DinC’s suggestion is something to try, as it may provide more definite information re’ the state of the drive.

If it is failing, then a a 1Tb drives (Western blue) is not very expensive. But if the pennies allow I’d go for an SSD. Crucial are my preferred brand and although SSD cost more they do make a positive difference in a computer’s performance. At least look at a 500Gig one.


Reply ↓  Report •

Related Solutions

#4
July 27, 2020 at 04:12:19
The only Toshiba diagnostics tool I can find for DOS is FJDT.exe. I cannot see how I can get that on the laptop to run it. I have boot up CD's (Win 98 and XP and Win 7) but I cannot burn the diagnostics tool on to the disk because it says it is write protected. If the laptop had a floppy drive it would be simple but I only have the optical drive. I cannot see how to do it.

The other strange thing is that the Win 7 CD loads up the files but all that I get in the end is a beautiful blue screen that looks like rays of sunshine, yet when I put it into my desktop, It brought up the Boot manager with all sorts of info. The laptop did not even get that far. Could the boot manager be something to do with it or is it just a case of the BM not being able to access the drive
?


Reply ↓  Report •

#5
July 27, 2020 at 06:06:10
The situation you describe, certainly the test you ran with a win-CD... has me wondering a little if you've actually got a RAM problem. RAM has often been overlooked in installation problems; and even when systems intermittently boot OK.

RAM can fail in a very erratic manner; RAM contacts can also be a cause of apparent failure.

Try this routine:

Power off and remove battery (and ensure the mains adapter isn't connected either).

Remove RAM sticks.

Clean the edge connectors with a soft pencil style eraser; and wipe the edges afterwards with a soft lintless cloth (even a "soft" tissue).

Insert a stick into its slot firmly; then remove and wipe its edge connectors again. Re-insert firmly again, and then remove and again and wipe edge connectors. Re-insert firmly. Repeat a third time. Then with one stick installed, restore the battery etc. and power up the system. If things are OK... fine. If there is a second RAM stick clean it as above; and then with power removed, replace the installed stick with the second one.- again inserting, removing, inserting etc at least twice if not three times. Then restore power and see how things fare?

Why inserting/removing and wiping the RAM edge connectors two/three times? To clean the internal connections on the RAM sockets. RAM connectors can get oxidised over time and produce all manner of apparent boot up/installation errors. Equally RAM can become slightly dislodge over time and produce similar effects. The remove/clean routine as above eliminates both those issues.

If one stick installed on its own is OK - the system boots OK (and the test with the CD is OK too..?). and the other stick (inserted on its own) doesn't show improvements... then the stick that doesn't seem to work OK is possibly suspect... If each stick, installed on its own, produces the same end result (system boots etc. OK or not) then unlikely it's RAM issue.

If you have two sticks - when you install the second stick, repeat the insert/remove routine as above for the second RAM slot - to ensure its contacts are as clean as can be.

As regards running a HDD diagnostics utility. It may be possible if you boot up the Sony using a Linux on a CD/DVD approach. Booting with a Linux CD/DVD doesn't need to install to the hard drive (unless you tell it to - which in this case "don't:"); the OS is installed into RAM only. The hard disk is then merely a resource for the Linux OS. Once the Sony is up on Linux... you can run the disk utility.

The Linux boot this way also gives a pretty decent hardware check - RAM, HD - when accessed via the Linux desktop and/or other utilities; and also the rest of the system.

There are many variants of Linux about. I've usually suggested ubuntu; but several Linux aficionados here often suggest something like Puppy Linux and other less complex versions. Whichever variant - one downloads the ISO and burns to a DVD; then boots with that DVD.

message edited by trvlr


Reply ↓  Report •

#6
July 27, 2020 at 06:36:40
That FJDT.exe may not be adequate for your system. What is the model number of the hard drive and we can check to see if they show any accompanying diagnostic downloads?

To test your ram you can use memtest:

https://www.memtest86.com/download.htm

Under most conditions it's usage is free. You may want to use the older V4 version 'Image for creating bootable CD'.


Reply ↓  Report •

#7
July 27, 2020 at 09:10:49
I've never found memtest reliable - preferring (if possible) to try a new known good stick to test a system in that regard. But I accept that many do find it worth running and effective.

The cleaning routine at least removes the possibility of it being something relatively simple - oxidised contacts; or even just RAM that has worked itself a little out of the socket(s).

If RAM is an issue and sometimes things seem ok and then not (or visa versa) at boot up - and/or following a restart... it can be that data is trying to load into a section that is duff; and the next time you try it by-passes that and goes into a good one and visa-versa. Equally volts applied and then re-applied can also affect any given segment; especially if it's starting to fail. One minute it's OK then the next not so and visa-versa. An intermittent effect starts to prevail which is why I prefer substitution (if possible)..

message edited by trvlr


Reply ↓  Report •

#8
July 27, 2020 at 09:31:23
Thanks both of you. i am running Memtest now.

HDD = Toshiba MK3259GSXP

HDD2J54 S QG01 T


Reply ↓  Report •

#9
July 27, 2020 at 12:20:07
That's a sata drive so any software that only checks older SCSI or PATA/IDE drives wouldn't work. I couldn't find any Toshiba-specific downloads for that but I think this will work:

https://www.techspot.com/downloads/...

and maybe seatools:

https://www.seagate.com/support/dow...

A lot of this stuff assumes you can boot a thumb drive from a USB port. Likely you can with your computer but you may need to change the boot order in bios setup.


Reply ↓  Report •

#10
July 27, 2020 at 16:06:57
The memory test was OK. No errors, but the HDD programmes said no disk was present. It appears they were looking for the PCI IDE controller but could not find any. That's what it appeared to be anyway. The strange thing is that a couple of programmes on Hiren's CD identified the HDD correctly and scanned it with no problems.. The thing I noticed though that the entire programme was very slow (hanging up). I hate giving up bit I think it is time t call it the end of the day on this one. I cannot understand though why it can find the HDD to start Windows, and in other places. not see a HDD there. I did take out the HDD and boot up. It said no OS found. I then put it back in and it started Windows. ??????

Thank you both for all your help. It was much appreciated. If I get time tomorrow I will see about the memory sticks. It may make a difference. I will let you know if it does.
..


Reply ↓  Report •

#11
July 27, 2020 at 23:00:06
If it is the hard drive failing it could be that in those instances where it works then the diagnostic software sees it OK but when it doesn't work then it can't find it.

There's usually a S.M.A.R.T function in bios that detects some of the hard drive problems indicating impending failure. You didn't mention seeing that message when you booted up so I assumed you weren't getting one, although you might check in your bios setup to make sure it's enabled.

You say you have a windows 7 CD. Is that the regular windows 7 installation DVD? If so it shouldn't be a problem reinstalling it if you have to get a new drive. You won't have some of the Sony-specific software the laptop originally came with but that's no great loss. Also the laptop should be upgradeable to windows 10 if you decide to go that route.

If you do decide to reinstall on a new drive you might start a new thread. I used to do reinstalls with older OS versions but not with windows 7, 8, and 10. Others here may offer better advice on that.


Reply ↓  Report •

#12
July 28, 2020 at 01:33:41
Well, that surprised me.

trvir - I did what you said with the RAM (1 stick 4GB). Made no difference. During the process though, when meaning to press the 'Assist' button to start Vaio to boot up the computer, I accidentally pressed the WEB button. That took me through a series of set up stages (which I assumed was coming off the HDD) which within a minute put me on the Internet. I then could access anything on the web. What was interesting was that when I went on Youtube, it said the browser needed updating but when I tried to download Chrome (which was my first thought) I tried to save the d/load file but it said there was nowhere to save it.

I downloaded Linux from Mint. It runs OK but I could not find any diagnostic programmes. What was amazing though was it had in its menu my C: drive. Everything was there - including all the 'stuff' I had put back on it after the re-install before this trouble began. I could access everything - and I ran the family videos I had saved and the JPG's etc etc. So where do I go from there?.What have we proven?

BTW, no S.M.A.R.T in BIOS

message edited by Terryx


Reply ↓  Report •

Ask Question