Solved HDD disappears from BIOS after trying to boot it

August 7, 2018 at 02:12:06
Specs: Linux x86_64, AMD FX(tm)-4300 Quad-Core@4.0GHz / 8 GB RAM
After an improper shutdown my main HDD has been unbootable from BIOS. In the BIOS boot order menu it always appears behind another disk I have, which should be unbootable but has an ancient version of GRUB installed (0.97 or 0.98) that somehow survived formatting. If I switch the boot order the main HDD will not boot, the ancient GRUB shell will show up and the main HDD will be entirely undetected by BIOS for several power-off cycles. I'm not sure what exactly triggers it to show back up, but it's always done so after a few resets. Often it will only be undetected once, but recently it took 3 resets to get it to reappear.

I've never had the main HDD disappear from BIOS unless I try to boot it from BIOS. If it is detected then it can be booted from my Super GRUB2 Disk. Unfortunately the ancient GRUB on my data HDD isn't able to boot my main HDD because it doesn't seem to be able to read the filesystem on it (it is detected as ext2, but is in fact an ext4 filesystem. Any attempt to read a file gives the error "14 : "Filesystem compatibility error, can\'t read whole file"")

The main HDD itself appears to be completely fine, it boots from the Super GRUB2 disk without any problems (the GRUB2 disk even detects the GRUB2 on the HDD and can boot entries from it) and all SMART diagnostics look fine.

Removing the second disk doesn't help, on boot what I assume to be the PCI controller boots (it's the last entry in the BIOS' boot order menu) and the only thing to do is restart the PC.

I have also switched SATA and power cables between the main and data HDDs which had no discernible effect.

The main HDD in question is:
Model Family: Seagate Barracuda 7200.14 (AF)
Device Model: ST1000DM003-1ER162
Firmware Version: CC45

The data HDD is:
Model Family: Seagate Barracuda 7200.10
Device Model: ST3320620AS
Firmware Version: 3.AAE

Here's my BIOS information from dmidecode:
Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: American Megatrends Inc.
Version: V10.3
Release Date: 03/28/2013
Address: 0xF0000
Runtime Size: 64 kB
ROM Size: 8192 kB
Characteristics:
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
BIOS ROM is socketed
EDD is supported
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
Print screen service is supported (int 5h)
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
ACPI is supported
USB legacy is supported
BIOS boot specification is supported
Targeted content distribution is supported
UEFI is supported
BIOS Revision: 4.6

The BIOS interface I see is fairly graphical (It's not a curses-style solid-blue background kind of interface) which I believe is branded MSI and has overclocking options and such (which I don't use). So I'm not sure what that is exactly.

I have a legacy MBR partition table on my main HDD, first a 100 MB NTFS partition that Windows 7 made for itself, an NTFS partition for Windows, then an ext4 partiton with Fedora Linux and a Linux swap partition.

message edited by densetense


See More: HDD disappears from BIOS after trying to boot it

Reply ↓  Report •

#1
August 7, 2018 at 04:32:12
Sounds to me like the Seagate drive is failing. Try running a compatible version of Seatools on it. See the link below.

https://www.google.com/search?q=sea...


Reply ↓  Report •

#2
August 7, 2018 at 09:25:29
I booted into Windows to run Seatools (since they don't seem to offer an up-to-date Linux version) and passed the short DST (drive self test). The drive in question has also passed short and extended SMART self-diagnostic tests I ran with smartmontools under Linux. There are no errors or warnings in any case.

Reply ↓  Report •

#3
August 7, 2018 at 15:24:12
✔ Best Answer
The tools may only check for bad sectors on the drive but not for intermittently failing electronics, bad solder joints, etc. which is why it has passed the test.

Reply ↓  Report •
Related Solutions


Ask Question