Hardware not detected

February 2, 2009 at 04:41:03
Specs: Windows 2000, AthlonXP, 512MB
I have moved my working Creative Audigy 2 ZS sound card (SB350) from my old PC to my new PC, but after downloading a driver via Driver Detective, I got the message "No Creative Audigy Device found". Since then, I have pulled it out of the PCI slot and reinstalled it, but it still does not detect. In Device Manager it appears with a yellow exclamation mark. In Driver Detective the card is identified correctly, as the correct driver appears to be downloaded. The driver software installs but finds no sound card! It appears that some software can identify the card but the system can't. I have had the same problem with my Plustek USB scanner, the correct driver was installed but the Utility program cannot find the scanner. These peripherals were both identified correctly by the Driver Detective software, but not by the system. My PCI SATA card, however, appears to be working perfectly, so it doesn't appear to be a faulty PCI bus...?

See More: Hardware not detected

Report •

February 2, 2009 at 05:33:24
I've never used "driver detective" & really don't understand why it's even necessary. If you need drivers & know the make/model of your device, why not just be your own detective & go to the manufacturer's website & download them?



Report •

February 2, 2009 at 05:48:11
Thanks, I looked at the Creative site, but it's not really helping me to get my Audigy Z2 card working; I now have two driver packages downloaded, but neither of them can detect an Audigy Card on my system! I have uninstalled the on-board sound controller (unknown type) so there will not be any conflicts, and also unistalled my Creative Audigy, prior to attempting a reinstall of the Creative driver package. It doesn't seem to make any difference what I do, it cannot detect my creative Audigy sound card, it says it is not found. Every time I boot up the computer it says New Hardware found (sound controller), and attempts to install drivers. I do not use this method, preferring instead to use the appropriate Creative installer package for my sound card.

I have verified that the PCI slot is working, by swapping slots with my working network card.

Report •

February 2, 2009 at 07:16:32
"Every time I boot up the computer it says New Hardware found (sound controller), and attempts to install drivers. I do not use this method"

Why not? It sounds like that's what the problem is...it's obviously detecting the sound, unless it's finding the onboard & not the card? Did you disable in the onboard sound in the BIOS?

Report •

Related Solutions

February 2, 2009 at 07:23:42
jam is on the right track. The integrated sound most likely uses the same resources. While possible to configure TWO sound devices it usually won't happen automatically. Disable the integrated sound in the BIOS screens. Then remove any enties in Device Manager related to sound and reboot. Then you should be able to get the Audigy configured.

Report •

February 2, 2009 at 10:33:33
OK that was a good suggestion as I had not previously thought of going into the BIOS. I have now disabled the onboard sound controller but I still get the same error on trying to set up my Audigy card. Regardless of which driver package I use, I inevitably get the same message... No Creative Sound Blaster products found on this system.

I have tested my PCI bus by swapping cards around from one slot to another, but this has not changed the results.

All I can assume is that I have somehow wrecked my Audigy card when I removed it from the earlier PC, in which it worked perfectly.

Report •

February 2, 2009 at 10:44:39
Did you remove or install the card while the computer was plugged in?

Report •

February 2, 2009 at 11:11:21
I can't remember exactly, but it is quite likely that it was plugged in, at least to maintain an Earth while I removed the various peripherals.

My scanner will also not detect, but that is a USB item. Again, it worked perfectly on the old PC.

Report •

February 2, 2009 at 11:32:18
You may have damaged the motherboard or card if you moved it with the plug in.

If you had the plug in but had the power supply switched of on the back then that is the same as unplugged. Otherwise there is always power to an ATX motherboard.

Did YOU install WinXP on this new computer?

If so, did you install the motherboard chip set drivers?

What service pack is installed?

Report •

February 2, 2009 at 13:10:47
That's a good point. I could not be certain that the power supply was switched off when I pulled the sound card out, but it was definitely plugged in.

I installed Windows 2000 Professional with Service Pack 4 and the latest rollup pack, but I have not installed (or looked for) any chipset drivers. I feel that the chipset cannot be the problem, as it would most likely prevent any of the other PCI peripherals from working too.

My USB bus is in working order, as I had my mouse plugged in there, but the USB scanner doesn't work even though Driver Detective says it knows what kind of scanner it is. It is a very strange fault, peripherals are recognised but not detected! Sounds paradoxical...

Report •

February 2, 2009 at 13:43:41
What does Device Manager show as far as the scanner and sound card?

Report •

February 2, 2009 at 15:05:17
The aforementioned items had a small yellow exclamation mark, regardless of all my attempts to install drivers, until I finally uninstalled the Audigy sound card. Now the card shows up in Device Mangler with a big yellow question mark. Despite several attempts to rectify the driver situation, the yellow question mark has persisted.

Report •

February 2, 2009 at 15:32:33
You need to try updating the drivers. The file needed should end in the file extension .inf.

If you have difficulty with that process then try this instead.

Remove the device listing from within Device manager and without rebooting use the add new hardware option in Control panel. If still no joy you can try one other trick that usually works.

Remove the device listing from Device Manager and reboot. Be ready to tap the ESC key as soon as you see any sign that Windows has found new hardware. You may need to do that several times. Then try installing the drivers you downloaded.

If you have the sound card in the first PCI slot at the top of the board I suggest you move it as far away from the Graphics slot as possible.

Report •

February 2, 2009 at 16:52:09
OK I've tried all that, but I still get "Setup has not found any Creative Audigy device on your system". It seems the card is wrecked... that's the only explanation I can come up with.

As for my scanner however, that is a USB item and should work. It did before I swapped computers. Now if I click on the scanner icon it says "Could not establish a connection with the Plustek USB scanner, please run the appropriate utility or configuration program". When I start the Utility, it says "This program cannot work on this scanner!" Again, I've tried detecting the drivers and redownloading / installing, but the results are the same every time. The power supply is warm, so there is power to it, unless the wire inside the cable has been broken.

Well, it's nearly 1AM here in the UK so I'm off to bed.

Report •

February 2, 2009 at 17:24:04
`Try installing the chipset drivers.

Report •

February 3, 2009 at 11:57:30
Just out of interest, does your motherboard have a jumper to disable the onboard sound capability? Check the manual (download it if necessary) and download and install the latest motherboard driver set.


Report •

February 3, 2009 at 13:02:44
At last I've got both items working! I took it down to my old IT Training Centre to get help there, and after an hour or so we got it working. We had to install a legacy driver for the Creative sound card then upgrade from that! It took a long time and a lot of searching, but it was worth it in the end. The scanner was sorted with the addition of a DLL file. I can't help wondering why it didn't come up with a missing-DLL error. But all's well that ends well!

Thank you to all of you who have tried your best along with me.

Report •

February 3, 2009 at 16:16:45
That is just ONE of the reasons I haven't bought anything with the name Creative on it in about ten years.

Report •

Ask Question