Solved harddrive reading wrong configuration

June 24, 2012 at 11:51:26
Specs: Windows XP, XP/2600-1024/133
harddrive issue, reading wrong at times and when this happen windows will not boot. I have ran the Maxtor burn in test and it has passed it 6 times straight. the wrong reading that keeps showing up is 46,081MB, 22,058 cyl, it should be 122GB, 58,853 cyl, when it reads this all will work and windows will boot.
Is it in the BIOS , the connector or the harddrive which keeps passing the burn-in test.

See More: harddrive reading wrong configuration

Report •

June 24, 2012 at 11:56:35
Tell us the make and model of your brand name system, or if you have a generic desktop system, the make and model of the mboard.

The model, sometimes the make, of a mboard in a generic desktop system is usually printed on the mboard's surface in obvious larger characters, often between the slots.

The specific model of a brand name system is often shown on a label on the outside of the case somewhere, or it can often be determined by going to the brand name's web site and loading a program they have available, if Windows is still working, on the subject computer

What do you mean when you say "reading wrong at times ".

We need the details about that.

Is it an internallly installed hard drive, or an external hard drive ?

Report •

June 24, 2012 at 12:28:10
✔ Best Answer
Okay, so you've added to the info in the first post since I made response 1.

(46.081 mb, binary size = 45.001 gb, binary size.

If your computer's bios is ALWAYS seeing that size AFTER you have checked out the data cables [see below], and the size of the drive is actually 122 gb binary size, if you have cloned the contents of a brand name system drive of 45 gb capacity (= ~ 48 gb manufacturer's size) or smaller to a larger drive, I can tell you how to fix that problem.)

A 122 gb drive can be either an EIDE (PATA) or a SATA drive.

The hard drive manufacturer's size is always a bogus decimal size. E.g. 1 gb = 1,000,000,000 bytes.

The mboard's bios and the operating system detect the size of the drive as it's binary size. E.g. 1 gb = 1,073,741,824 bytes

A ~ 131 gb manufacturer's size = ~ 122 gb binary size.

If the bios SOMETIMES isn't detecting the binary size of the drive properly, the operating system can't detect it's binary size properly either

The most likely thing is the hard drive's data cable has a poor connection, or the data cable is damaged.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittent, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

80 wire data cables must have the proper end connector connected to the mboard IDE header - usually that's blue, but in any case it's the one farther from the middle connector on a 3 connector data cable.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

If that doesn't help, the drive's circuit board is probably defective. In many cases, when it IS defective, some of the chips on it get really HOT after the drive has been running a while - too HOT to keep your fingertip on it for any length of time.

NOTE that more recent hard drives always have a temp sensor built into their circuit board. When you run the Dos SeaTools tests (see below) it will tell you if the drive has been over temp before you actually run the tests. However, that may not be accurate if it's NOT a Seagate drive, and/or if it's an older Maxtor hard drive model.
It also shows the current temp while running the tests - if that's much higher than the board temp is actually getting, or if that's high initially when the drive has had a chance to cool to room temp, of if it doesn't ever go higher than it was initially, ignore that.

Maxtor ceased to exist as it's own company years ago. Seagate bought out Maxtor then and has supported Maxtor hard drives since then.

If you're using an old Maxtor program for the burn in test, it may not work with a newer Maxtor drive properly. In any case, the burn in test may pass even when the size of the hard drive is not being detected properly.

Seagate's SeaTools is the proper thing to test a Maxtor hard drive with.

Seagate's Seatools will test (almost) any brand of hard drive.
Do the long test.

The bootable Dos versions of SeaTools can be used even if Windows is not working properly, or when the hard drive has no data on it.

If the hard drive itself tests okay, any data problems found can be fixed, one way or another.

Report •

June 24, 2012 at 18:12:56
Thank You, this seems like a good starting point because since last week my drive is going into PIO mode instead of staying in Ultra mode, this by itself is not a big issue but it deems the drive to work at 60% performance. I will pull out the cable tomorrow and install a new one. we will see but that strikes to me as a starting point for now. It is like I said, this computer is exactly 10.5 years old and it has always had the same programs and with the exceptions of updates and upgrades, the only thing that I have changed and it was over 2 years ago was the processor which was a T-Bird 1200, the board is PC Chips M810L version 7.1a. It has worked well to date or rather till last week. Thank You, I will keep you posted
This computer has an AMD XP2600/266 Proccessor, 1024 of SDRAM and the mother board is a PC Chip Motherboard (M810L v7.1a)
Hardware 1 DVD/RW Rom and 1 DVD/R Ram

Report •

Related Solutions

June 24, 2012 at 18:28:30
If any of the tests that S.M.A.R.T. detects are to far out of spec the drive may drop into PIO mode.

Run a hard drive fitness test. Back up your personal data first though.

Get Seatools from the link below.

Report •

June 24, 2012 at 19:38:00
"....since last week my drive is going into PIO mode instead of staying in Ultra mode, this by itself is not a big issue but it deems the drive to work at 60% performance."

That commonly happens when you have a data cable connection problem or a damaged data cable, however, that can also happen in the beginning stages of the hard drive starting to fail.
When it's in PIO mode, it's max burst data transfer speed is severly limited.

Once you have checked out and have possibly replaced the data cable - it must be an 80 wire data cable - test the hard drive.

Seagate's Seatools will test (almost) any brand of hard drive.

Report •

June 25, 2012 at 02:46:05
Hello Tubesandwire, It is weird that you bring up the Seagate Tool (Maxtor), I have tested the drive a total of 6 times and each time it states that the drive passed on all accounts, they claim that if it pass's the burn in test, then the drive is certifiable good. that is how I or we came up with 3 possible conclusions and they are
(1) the drive on it's way out
(2) the cable itself and worse.
(3) the motherboard or BIOS problem.
This is all crazy because once it boots to windows, it works OK with the exception of staying on PIO Mode of course. It is like I said I will go out and purchase a new cable this morning. I can say this for sure you and anyone else that has let me on a path to the solution has been and will be greatly appreciated, thank you.
I will keep you posted.

Report •

June 25, 2012 at 06:24:13
Thanks for the thank you.

The SeaTools program will test whatever size of drive the bios detects, even if it isn't being seen as it's full size.

If the bios EVER sees the drive as it's correct size, there's nothing wrong with the bios, and the least likely thing is there's something wrong with the mboard.

Report •

June 25, 2012 at 09:38:22
Hello Fellow helpers, I am back again but the problem is still there, here is what I have done so far.
(1) I ran for the seventh time the Seatools and again it passed all test (??????).
(2) I changed the hard-drive ribbon, not expensive but did not solve anything.
Below is what it states after booting the BIOS
A disk read error occurrred
Press Control+Alt+Delete
Harddrive reading Pri-Master at: LBA, ATA, 133, 46,081mb
Fails to boot to Windows.
If you start the Maxtor Installation CD and then remove it after you get to the language selection (from boot) then you can start the full boot and windows will boot and it will read all the correct configurations, strange enough but true to the fact. I have already zero'd out the drive twice and reinstalled all my programs which seem to be working OK.

Report •

June 25, 2012 at 13:08:04
Check the BIOS (setup) to see if SMART is enabled.

To clarify the problem, did this happen all of a sudden or something else.

Why do you think the correct size of your drive/partition is 122MB?

Do you know the model number of the maxtor drive?

If you have normal boot enabled you should see the model number of your hard drive on screen when starting up. Post that number.

There were several versions of that board. Look at the board for a ver. # and post it here. See the link below.

If your system is over 10 years old the BIOS may not be 48 bit LBA compliant. Instead, it may only be 28 bit. If that is the case and your hard drive is actually larger than 122GB then your files may be corrupted.

Do you know the model number of the maxtor drive?

Report •

June 25, 2012 at 17:06:42
Hi Otherhill, the answer to your question is yes, the harddrive is a Maxtor (6B120P0) and yes it is a 120Gig. This drive has been on this computer for the past 11 years and it has always read 114gig with 96 gigs of free space at least till last week on Sunday (8 days to be exact). yes this was all of a sudden.
It has always worked just fine and yes it also ran in Ultra DMA 5 for years except now. There are no current newer BIOS and yes I cleared the bios by pulling the crossover pin out and moving to clear, I also reverted to the old BIOS (2001) that did not work so I installed the new one again. It is not the cable because I bought a new ribbon, I honestly thought that this might have been the problem. so there are only 2 things left, the drive or the motherboard but this does not make sense also, once it boots to Windows with the help of the Maxtor Installation CD, once this happens all is good with the exception of not running at peak performance which is UDMA 5 and not PIO mode. I hope that this answers some of your questions but I honestly think even though it passes the seagate test the hard drive has issues. this is expected after 11 years of use. The model is as I stated above (Maxtor Model # 6B120P0, Serial # B40523VH, Firmware is BAH419Z0.
I do appreciate all of you guys help. It may be that my computer might have seen it's last days.
Currently I am using the computer but who knows when it is going to go out completely.

Report •

June 25, 2012 at 20:11:20
From your first post "it should be 122GB, 58,853 cyl". Why did you post that information then?

Are you testing the hard drive using Seatools for DOS? That is what you should be using.

Pay attention to what the reported capacity is in Seatools for DOS.

Read the information on what Seatools for DOS can do. It can reset the capacity of a drive.

You want to first verify the drive is healthy.

Have you backed up your data?

Is the hard drive setting in the BIOS set to auto detect the drive?

Hit F3 while you are in the Standard CMOS setup screen to auto detect the drive.

If that doesn't correct the issue then try manually entering the parameters off the label on the drive.

Report •

June 26, 2012 at 08:39:25
"Maxtor Model # 6B120P0, Serial # B40523VH, Firmware is BAH419Z0."

Data on the Maxtor 6B120P0 Model of Storage Devices Having the BAH41BM0 Firmware


Capacity 114.4 GB

114.4 binary gb X 1.073741824 decimal gb per binary gb = ~ 122.84 gb manufacturer's decimal size

Obviously you were getting that 122 gb size from the label on the drive.

114.4 was probably rounded up from what it actually is, if the label says 122 gb.

Hard drive manufacturers always state a bogus decimal size, e.g. 1 gb = 1,000,000,000 bytes.
The mboard's bios and the operating system always see the size of the drive as it's binary size, e.g. 1 gb = 1,073,741,824 bytes.

E.g. ~ 122 gb decimal size = ~ 114.4 gb binary size.
The total number of bytes is the same in either case.

I suspect that either
- you do not have the bios Setup set to Auto detect the drive by the Auto or LBA method - e.g. it's using parameters for a 45 gb manufacturer's size drive (46,081 mb binary size).
- or - I've only seen this for a bios version on a Shuttle XPC barebones system - you have disabled a setting in the bios that should be enabled and is enabled by default that updates the DMI info every time the computer is booted.

Either problem is easily fixed in most cases by loading bios defaults in the bios Setup, Save bios settings.

I'm assuming you have only one hard drive. If so, Windows should load fine after loading bios defaults.
If you have more than one hard drive connected to the mboard, if a bootable operating system is not found after loading bios defaults, you need to be informed about what you need to do about that.

If you had any necessary custom bios settings you had set yourself, you need to change those after loading bios defaults.
E.g. If the mboard has a parallel port and you're using a parallel port connected printer or scanner, the printer port mode in the bios must be set to EPP, ECP, or EPP / ECP mode - it may be set to otherwise by default.

Another possibility ?

PCChips is the retail brand name of mboards made by the Hsing Tech wholesale mboard maker.
Hsing Tech also sells their mboards to other vendors, and in the past there were many other vendors that sold Hsing Tech mboards under their own brand name and model number.
E.g. Many older ECS mboards are actually Hsing Tech mboards.

Hsing Tech / PCChips has a reputation of having used the absolute cheapest components they could have when they made the mboard.
One is bios flash chips that tend to be more likely to physically fail while flashing the bios - It's NOT a good idea to flash the bios of a PCChips mboard for that reason.

Another is sometimes they installed electrolytic capacitors that were improperly made that fail eventually, because they were cheaper at the time they made the mboard.

Some mboards develop this problem - electrolytic capacitors were installed on them that were not properly made, and they fail eventually - the mboard manufacturer didn't know they were improperly made at the time the mboard was made.

Open up your case and examine the mboard to see if you have bad capacitors, and/or other findable signs of mboard damage .

What to look for, mboard symptoms, example pictures:
Home page that site
- what the problem is caused by
- he says there are STILL bad capacitors on more recent mboards.

Pictures of blown capacitors, other components, power supplies, fried Athlon cpus, etc.:


Report •

June 26, 2012 at 16:36:41
The answer to your question guys is yes to the following 3 subjects.
(1) I have the Auto check for all drives including the CD Rom.
(2) I only have 1 harddrive and it is a 120Gig which of course Windows report 114.4 gigs of course I have 94gigs of free space.
(3) I have reset the BIOS, which was my first thought, the second was the drive ribbon.
The reason I said 122 gigs is simple, that is what it has always reported in the BIOS before Windows Boot, after Windows Boots it reports what it has reported for the last 11 years and that is 114.4 gigs which is normal and according to what I just saw above, that is correct.
At this point the computer is booting to Windows, at least the last 4 times but I can't get it to go back to Ultra DMA which is selected in the BIOS along with the burst enabled.
At the sound of repeating myself and no disrespect entended, I have had this computer going on 11 years and it has run the following for the past 6 years.
(A) Windows XP (since 2002)
(B) Microsoft Office (Office 2007 since 2007)
(C) Nero 6 (since 2002)
Again this started 9 days ago and all the BIOS settings have been the same since day 1, all functioned correctly.
The reason I noticed wa that it got slower than usual and then of course the misread error.
Again all worked great since July 2001 till June 17th of this year.
I do have a copy of the BIOS settings which I loaded to a floppy 5 years ago when I updated the BIOS to PCChips 030808S, there are no newer versions.
After almost 11 years of running consistently with no snags, this computer has ran good, again right up to last week.
I have deleted, formated the drive 2 times and re-installed my original programs along with all it's updates, fix's and drivers which I also kept o n a disk.
It is plain to see, something changed, what is true to the case I don't know, but I can say this with all honesty, I AM GLAD THAT THERE ARE PEOPLE like you guys out there offering help, thank you, all of you.

Report •

June 26, 2012 at 16:47:14
Read the information off the drive label and try to enter it manually in the BIOS.

If that doesn't work then read the link I provided in #4 above about " how to reset hard drive capacity". Find it in the DOS version on the Seagate site.

Hard drives always come with spare sectors so that when a few fail the drive can automatically which to good ones. It is possible those unused sectors were showing. That might account for the high reading. That or the BIOS has always been screwed up.

See the link below.

You never said if Seatools also identifies the drive with the small capacity.

Report •

July 15, 2012 at 11:39:27
For all you guys that tried to help, this is what happened after all was said and done and to this day I don't know what happened and how it corrected itself.
I deleted partition, reformated, ran a diagnostic that showed nothing wrong with the seagate tool and than re-installed Windows (XP-SP3), Windows Office, Nero 6 and the 4 other programs that where originally on my backup CD's and then updated through Windows update and updated my drivers that where also on my backup. All is back as it was now and it has been 3 weeks with no snags. What corrected itself I don't know and that will be a mistery because the problem came unexpected and left unexpected. Thank You

Report •

Ask Question