Hard drive Unable to boot up

May 19, 2010 at 05:52:36
Specs: Windows XP
I have a new computer (second hand). Because I wanted to change the partitions I installed Partition Magic 8. When starting this program for the first time it produced an error message (don't remember which one exactly) and asked whether I wanted to fix it. I answered yes (big mistake!) and it said it fixed it and needed to reboot.

Since then the pc won't start up anymore. When turning the computer on, it asks about starting a RAID utility (there were 2 hard drives and about 10 partitions). Then I have the option to start WinXP from the c-drive or the d-drive (I know WinXP is installed on both drives). It doesn't matter which I choose, I subsequently get the Windows start-up screen and that screen remains there for 7 or 8 minutes after which it automatically resets.

The PC won’t boot up either from the WinXP cd-rom, WinXP start-up floppy disk, nor from a Win98 start-up floppy disk. It only starts up using the start-up floppy disks that I made when installing Partition Magic 8. Partition Magic 8 states about the hard drive (the one on which WinXP is installed): "partition table error #120 found". It also refuses to format the hard drive (is states the drive is BAD and gives the error “Error #4 Bad argument/parameter” and “BADMBR, Primary volume, 238472.7 MB on Disk1“. http://www.computing.net/answers/ha... seems to describe something similar but I’m unable to understand what is written there.

With regard to the specifications of the PC (which is custom-build): Information I see on the screen when turning the PC on:
- Asus A8N-SLI Premium
- SIL 3114 SATARaid
- LBA Sata 2, 250gb & LBA Sata 2, 750gb.
- In the bios I read:
Primary IDE Master: None
Primary IDE Slave: HL-DT-STDVD-ROM
Secondary IDE Master: TSSTCorpCD/DVDW
Secondary IDE Slave: None
First SATA Master: WDC WD2500KS-00M
Second SATA Master: Samsung HD753LJ
HDD Smart monitoring: enabled
- 2.5Ghz, 1GB ram

How to fix this? Partition Magic seems to have done something that has made the hard drive defective.

The problem seems similar to one described at a German forum: http://www.nickles.de/forum/festpla...
Do you think it would be an idea to boot up with the floppy disks of Partition Magic and then, as I think the German forum is suggesting, run killmbr.exe (http://www.wintotal.de/softwarearchiv/?rb=53&id=1874)? This program deletes the first sector of the specified disk. (I have no idea what this means, but I guess you do) Do you think it would be an idea just to try this?

I can also boot up using the Partition Magic floppy disks and then run FDISK. Could I use this program to fix the problem? FDISK states:
Partitions on 1st hard disk (8024.6 mb, 1023 cylinders):
No Drive Start End MB Status Type
1 -- 0 1023 16002.2 A NTFS/HPFS
2 -- 1023 1023 222470.4 N VFAT LBA (2)

See More: Hard drive Unable to boot up

May 19, 2010 at 16:11:15
I hope you did a backup. You could try to repair the Master Boot Record (MBR) by booting Windows in Recover Console and running FixMBR...


Chances are this alone will not do it because it sounds like you rebuilt your Partition Tables with Partition Magic. If that is the case now you are looking at data recover and reinstall Windows.

Report •

May 19, 2010 at 18:20:37
"The PC won’t boot up either from the WinXP cd-rom, WinXP start-up floppy disk, nor from a Win98 start-up floppy disk. It only starts up using the start-up floppy disks that I made when installing Partition Magic 8. "
nothing you have done to the HD caused this. disconect the HD power jack and try booting from a live cd.

download the HD manufacturer's test utility and see if the HD passes.


Report •

May 20, 2010 at 03:08:02
I believe the Partition Magic error 120 is a partition table error.
The error is invalid partition boundaries. I think this was caused
by system cloning software used in creating the image during
the system disk. I have had this error on several systems. I cure
it copying each partitions to another drive then reformatting the
hard drive. Partition Magic is very strict in creating partition. If's
fix moved the relative position of the boot sector and files.

Report •

Related Solutions

May 20, 2010 at 06:26:19
Thank you very very much for your suggestions. I must admit being non-English and knowing little about computers doesn’t help in understanding it all. However, I have tried to follow your suggestions:

- With regard to response 1: Because the PC only boots using the Partition Magic floppy disks, I couldn’t boot Windows in Recover Console

- With regard to response 2: I don’t feel very confident to “disconnect the HD power jack”. I’m not sure which cable to disconnect. Also, I’m not sure what you mean with “booting from a live cd”. Do you mean the WinXP cd-rom? I know the hard disk is a “WDC WD2500KS-00M”. After some while, I finally found its webpage: http://support.wdc.com/product/down... I wasn’t sure which software to download and chose “Data Lifeguard Diagnostic for DOS (Floppy)” (I choose DOS because Windows doesn’t start up). However, the zip-file as well as the exe-file are too large to fit on a floppy disk, so that I cannot run them. By the way, I cannot run chkdsk either (it doesn’t recognize c:, d: etc.). I do can run fdisk, if that would be helpful?

- With regard to response 3: I too have the idea Partition Magic has done something bad to the partition lay out. Because I cannot reach the hard disks I cannot copy the data. However, by now I’ve accepted that the data is lost (so be it). All I want is to make the pc work again. If I understand you correctly then the next step would be to format the partition? Partition Magic refuses to format, as I wrote in my previous message. Would it perhaps be an idea if I formatted the hard disk using fdisk? How can I do this?

Any ideas how to move forward?

Report •

May 20, 2010 at 08:05:50
There are only a couple reason you would not be able to boot from your Windows Systems Disk...

1) Bad Disk or Damaged
2) You have your BIOS setup to not boot from external drives.
3) Drive controller has gone bad or is having conflict.

I think Larry is going on reason 3 and thinks your hard drive is causing a conflict which is preventing your Windows Disk from booting. He wants you to disconnect the drive to see if you can boot from your Windows Disk because if we can't get you booted from your Windows Disk then you are sunk.

Report •

May 20, 2010 at 08:30:54
Ok thanks! What should I look for in the bios to check for 2) You have your BIOS setup to not boot from external drives?

I've tried to disconnect the hard disk. There are two cables going into the hard disk, similar to SATA on: http://www.wdc.com/wdproducts/updat...

No problem plugging out the small cable from the hard disk. The larger cable (labeled P7) seems to be pretty stuck though. Should I be able to just "jam it out"? It seems to be part of the hard disk... From this P7-cable there a cable going to the second hard disk and a cable going somewhere else (I guest to the motherboard). However, it is impossible to see where exactly it is going. Any feedback on how to get the P7-cable out of the hard disk?

Report •

May 20, 2010 at 08:38:16
Great! I just successfully plugged out both cables and booted up with the WinXP cd-rom. This worked! I got the Windows Setup screen.

What should I do next? I cannot run the “Data Lifeguard Diagnostic for DOS (Floppy)” that tests the hard disk because it doesn't fit on a floppy disk (and the hard disk is disconnected). Should I select "Repair" from the Windows Setup screen (and with the hard disk connected or disconnected?)?

Report •

May 20, 2010 at 18:39:34
most of these HD test utilities can be run from a cd, you have to choose the correct download. Here is an example(not yours):

if you can create the bootable cd, I would try it with the drive still disconnected. If it boots, shut it down, reconnect the drive and try to boot again.
"Should I select "Repair" from the Windows Setup screen (and with the hard disk connected or disconnected?)?"
you cant do a repair or anything else to the drive if it is not connected.


Report •

May 21, 2010 at 04:07:16
Thanks! I’ve burned the iso file of “Data Lifeguard Diagnostic for DOS (CD)” (http://support.wdc.com/product/download.asp?groupid=606&sid=30&lang=en) on a cd-rom.

Then, I booted the PC up with this diagnostic cd-rom and with the hard drive disconnected. It booted up and produced the error message that no western digital drives were found (since the hard disk was disconnected).

So I shut down, reconnected the hard disk, and again booted up using the diagnostic cd-rom. Similar to the previous time I booted up it stated:
1. FD 1.44 MB System type- (00)
Starting Caldera DR-DOS…
However, this is how the screen remained. It didn’t progress to the menu. So, it seems to be unable to boot up using the diagnostic cd-rom while the hard disk is connected.

After like 15 minutes I shut down and booted up using the Partition Magic floppy-disks and with the hard disk still connected. I was hoping I could access the diagnostic cd-rom (the the diagnostic file doesn’t fit on a floppy disk). However, unfortunately, I was only able to access a: and no other drives (and thus also not the cd-rom).

Any ideas?

Report •

May 22, 2010 at 05:42:02
The problem has been solved by deleting the partitions using fdisk (unfortunately, data was lossed).

Report •

Ask Question