Hard drive not working.

Seagate Seagate 1tb freeagent desk usb e...
January 31, 2010 at 16:31:09
Specs: Windows Vista 64bit and Ubuntu 9.10 Karmic Koala
So I got this 1TB Seagate FreeAgent USB
hard drive. I put a bunch of music and videos
on it and it worked for a couple weeks in both
Vista and Ubuntu Karmic. Then it said it was
corrupted and unreadable. I fixed this with
chkdsk D: /f and it worked fine again.

Then after another week, or so, it stopped
working in Vista, but kept working in Ubuntu.
Then a couple days later it stopped showing
up in Ubuntu.

chkdsk claims its NTFS and working perfectly
fine, but disk management says it' RAW. and
it's not working.

any solutions?

See More: Hard drive not working.

Report •

January 31, 2010 at 18:58:41
If the partition shows as RAW, it means that the DBR of this partition is corrupted, you need to repair this partition or recover files from it, after that reformat this partition to use.
You'd better insert this external hard drive to the USB interface that is back of the box. The front USB interface power is insufficient

Report •

February 1, 2010 at 01:54:06
Thanks for the reply.

Now I'm even more confused. I plugged it into a friend's
computer today to see if it would work with his computer, and
it did without any problems.

So the hard drive should be fine, just something wrong with
my computer??

Also, I have no front/back USB ports, since I'm using a

Report •

February 19, 2010 at 02:58:44
This is the exact same problem im having with my 1TB Seagate FreeAgent USB hard drive..have only had it about 2months!

Thanks Mike for posting, nice to know im not alone!

Would really appreciate any suggestions on what to do, thanks :)

Report •
Related Solutions

Ask Question