Hard Drive Not Detected When Cold Booting

Seagate 1tb st31000333as sata300 7200rpm...
August 13, 2010 at 19:44:07
Specs: Windows 7, AMD Athlon 3000+/2 GB DDR
I recently swapped a Seagate Barracuda ST31000333AS 1TB from another computer into the one that I am currently using.

Both computers involved are relatively old. The oldest computer was a P4 running on a P4P800 motherboard. When the hard drive was in the P4 computer, it worked flawlessly. However, once I installed it into the slightly newer AMD based computer which has a A8N5X motherboard, the AMD machine developed an issue which it did not have before.

Every time I cold boot the computer, I get an error message that says "Disk Boot Failure, Insert System Disk and Press Enter". I can get the hard drive to boot by entering the bios and exiting it, I can also alt+ctrl+del at the error message and the computer will then boot normally.

This problem only occurs with this hard drive. I tried unplugging the problematic hard drive and plugging in an older hard drive (Maxtor 250GB) and the computer booted fine. I used the same SATA cable and port when I switched hard drives as well. I have also upgraded my bios twice, the first time I used the latest official bios and then I tried a beta bios, this obviously didn't fix it.

I have tried disabling quick boot and it appears to fix the problem but this particular motherboard does a very thorough memory test when quick boot is disabled. It takes 2-3 minutes for the memory test to complete and then another 30 seconds to boot. This makes boot up feel like an eternity. Therefore I do not count this as a solution. BTW, there is no hard drive delay option in my bios.

In case you're wondering if this is a power supply issue, I have a 500 watt Antec Power supply. Also, this is not a boot order problem as I have tried making my hard drive boot first with no luck. I have even tried unplugging my dvd-rw and I should also note that my computer doesn't have a floppy drive.
Hopefully someone here can come up with an answer to this annoying problem. Thanks in advance.

See More: Hard Drive Not Detected When Cold Booting

August 13, 2010 at 20:19:28
"I recently swapped a Seagate Barracuda ST31000333AS 1TB from another computer into the one that I am currently using"

Did you reinstall Windows after the swap?

Report •

August 13, 2010 at 20:24:03
Indeed, I am now running 64 bit Windows 7.

Report •

August 14, 2010 at 09:10:27
I'll take a guess. The hard drive is not quite up o speed when the Bios is ready to read the hard drive. Some BIOS's may have a wait for the drive to be ready. If you have a large boot partition that could also be a problem in reading the FAT and directory in a timely manner.

Report •

Related Solutions

August 14, 2010 at 13:20:04
Thanks for the reply but my boot partition is only 100GB so I guess I'm just stuck with this issue. I realized earlier that I don't have to sit through the entire ram test when quick boot is disabled, I can just press escape and then my pc will boot fine. So I guess I can live with that. Thanks anyways.

Report •

Ask Question