Hard Drive No longer says eject

Toshiba 500 gb external hard drive - liq...
August 9, 2011 at 12:03:02
Specs: Windows 7
I have had this hard drive for a couple of years and have had no problems. But a couple of days ago, after I was done with my work at school, I tried to go and say "eject" - but there was no such thing. There was no icon for the drive to click on and when I went to my computer and right clicked on the drive - it also no longer says eject.

AND it made no difference if I used a different computer - I tried several at school

See More: Hard Drive No longer says eject

Report •

August 9, 2011 at 14:05:26
I can see a cd being ejected, but not a hard drive. The hard drive is screwed into brackets inside of the computer.

Are you talking about a flash drive?

Report •

August 9, 2011 at 14:30:37
sounds like an external HD to me...the poster should maybe read this:
That may help clear up some confusion

Some HELP in posting on Computing.net plus free progs and instructions Cheers

Report •

August 9, 2011 at 20:42:11
Instead of 'eject' was there a 'it is now safe to remove. . .' option?

Report •
Related Solutions

Ask Question