Hard disk not detected

Seagate Barracuda ata iv 80gb hard drive
October 22, 2009 at 20:38:04
Specs: Windows XP
I built a PC for myself a couple of years ago. (The Motherboard is P5N32 Sli Plus), I had 2 SATA hard disks. Then I put in another IDE hard disk (Seagate ATA 80Gb), I got some data on this IDE disk. They all worked fine (the OS is located on a SATA disk).
Few months later, I took the IDE hard disk out because my brother wanted to borrow it. As he got a new hard disk, he didn't want it. So I put it back. The problem is that winXP did not detect it anymore, even though it's detected in BIOS. It's weird!
Did I do something wrong? Shoud I set the jumper to SLAVE or CABLE SELECT? Should I enable LBA in BIOS? (phew! I can't find it in BIOS). Something wrong with IDE cable? Blue connector to the motherboard and the other black end to the hard disk, yeah? I did that.

Please help

See More: Hard disk not detected

Report •

October 23, 2009 at 08:36:54
"Shoud I set the jumper to SLAVE or CABLE SELECT?"

How many IDE drives do you have? If only ONE then yes there is you problem. Reset the jumper and you should be good.

Report •

October 26, 2009 at 04:54:13
I have 2 SATA hard disks and only 1 IDE hard disk. I tried all jumper postions but still failed.

Report •

October 26, 2009 at 05:49:12
Modern IDE controllers should configure the IDE drive no matter what the jumper setting if it is the only drive on the cable.

What type is you CD drive?

Look in Disk Management for the errant drive.

Report •

Related Solutions

October 27, 2009 at 04:07:11
It's DVD RW, using IDE2 slot on the motherboard. Basically, IDE 1 for IDE hard disk and IDE 2 for CD/DVD.

I can't find any errant drive in Disk Management. If I did, I 'd assign it a letter.

Report •

October 27, 2009 at 11:53:20
Watch the POST screens at start up to verify the BIOS is properly identifying the drive by both model and full capacity.

Boot into the BIOS (setup) screens and verify the IDE channels are enabled there.

Report •

October 27, 2009 at 19:04:18
Yeah, it's detected in BIOS and IDE channels are enabled. Windows Explorer does not detect it. It's weird.

Report •

Ask Question