genius trio racing wheel

November 10, 2019 at 04:22:52
Specs: Windows 7
my windows 7 reads my genius trio racing wheel drivers as a generic hub. please help
all pc drivers updated, downloaded drivers from genius, corresponded with genius directly, answers supplied does not help.

See More: genius trio racing wheel

Reply ↓  Report •

#1
November 10, 2019 at 07:08:18
Download the driver from Genius & unzip. Open the folder & select the appropriate setup file, either 32-bit or 64-bit. Right click on it & select "Run as Administrator". A copy of the manual is also in the the unzipped folder, maybe that will be helpful. Here's a couple of notes from that manual:

"Note: Do not connect the steering wheel to a USB hub. It only works when it is connected directly to the USB port of the PC."

"Driver installation
①. The wheel has to be connected to the PC first."


Reply ↓  Report •

#2
November 11, 2019 at 07:47:00
Hi,

Thanks for the response. Unfortunately that did not solve the issue. I have updated all drivers, USB root hub , everything and tried all USB ports to no avail. I have plugged it into 2 other PCs one windows 7 and a Windows 10 PC. It only gets detected as a generic USB hub. I even installed a fresh copy of Windows and still no luck. Any help will be appreciated.


Reply ↓  Report •
Related Solutions


Ask Question