General USB Port question

January 30, 2011 at 01:37:42
Specs: Windows 7

Can someone explain what might be going on here please?

M/B ~ Gigabyte GA-73PVM-S2H.

I have a Belkin USB Hub which is connected to one of the rear M/B USB ports and works fine.
I also have a USB Wireless Adapter which is plugged into one of the Hub Ports and works fine.
To tidy wiring up a bit, I removed the Wireless Adapter USB plug from the Hub and plugged directly into Motherboard USB and Wireless Adaptor stops working.
Even if I plug the Wireless Adaptor into the M/B USB port which the Hub was using still does not work.
Plug the Hub into the M/B USB Port and and the Adapter into the Hub again and it works OK.

Can anyone explain why the Wireless Adaptor will not work when plugged directly into the M/B but works OK in plugged into a Hub which is plugged into the M/B?

See More: General USB Port question

Report •

January 30, 2011 at 09:23:26
At first two ideas.

One is somehow related to how usb bus is tied to nic driver. And it should not be really.

Second is that your external usb's do not support usb 1.1 and this nic is only usb 1.1. Again it should not be.

Try that nic on a different system.

"The era of big government is over," said Clinton 1996

Report •

January 30, 2011 at 09:23:55
Maybe remove it from the system and then re-install it on the motherboard.

"The era of big government is over," said Clinton 1996

Report •

January 30, 2011 at 09:36:15
Does the Computer recognize the device (Wireless Adapter) when plugged into the MB USB port or it does nothing. Check if the MB USB ports are recognizing other devices and they are working properly. If no devices are working then maybe your MB USB ports are disabled (Few ports can be disabled while others work.) Check the BIOS in this case.

If your computer is recognizing other devices and they are working properly then the issue is the driver.
Uninstall the Wireless Adapter driver then reinstall it connecting it to the MB USB port.USB devices sometimes need to install the driver again when plugged into a different USB port.
Check these steps and then reply a post.

Tek Ideas Unlimited

Report •

Related Solutions

January 31, 2011 at 05:07:23
Have tried uninstalling the Adapter Driver then connecting Adapter directly to one of the mobo ports and reinstalling the Adapter driver ~ no luck just a red cross in the Taskbar connection Icon no yellow markers in Device Manager anywhere.

This Adapter seems to only work from a powered USB Hub so looks like the answer is it needs to be connected in this way.

Have read on the 'net that some devices require more power than mobo can supply thus could this be reason why it (Alfa Network AWUS036H 1000mW Wireless G USB Adapter) will work from a powered Hub USB port?

Report •

January 31, 2011 at 08:10:04
Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

Check that out first.

Rarely, not all the ports on the back of a desktop case may be able to supply 500ma each.

(this may also apply for devices that need less current)

If you have a desktop computer, Note that I answered a Topic on this site where a guy had an external drive, which does require the full 500ma, connected to a port on the back of a desktop case - it would not work properly when a webcam was in the port next to it, but it worked fine when the webcam was unplugged. Ports on the back of a desktop case often have two ports connected to the same USB controller module that are ports one above the other - you could try connecting the cable to one of those and leaving the other un-used.

Report •

Ask Question