Gateway GT5228 won't run 4BG in dual channel

April 2, 2011 at 11:16:39
Specs: Win 7 Pro, 32-bit, Athlon 64 X2 4200+
I am trying to add some RAM to my Gateway 5228 computer. It came with 2GB of Samsung PC4200 dual channel RAM (2x 1GB). I am trying to add 2GB more of G.skill PC4200 (2x 1GB), however, I get nothing but problems when I install the RAM in dual channel mode. It will run fine in single channel mode.

Gateway GT5228
Win 7 Professional 32-bit, SP1
FIC k2bc51G/PV mobo according to CPU-Z (says k2bc51 LF on the mobo)
AMD Athlon 64 X2 4200+ CPU
Sparkle GeForce 9500GT 1GB DDR2 video card
2x1GB Samsung PC4200 DDR2 533MHz RAM (M378T2953CZ3-CD5) running at 1.8V
2x1GB G.Skill PC4200 DDR2 533MHz RAM (F2-4200PHU2-2GBNT) running at 1.8V

What is confusing me to some degree is that when I opened the case to add the new modules, the Samsung modules were in slots 1 and 2, not slots 1 and 3. CPU-Z still said it was running in dual channel mode. ( I think this is specific to mobos targeted for AMD processors?). When I put the G.Skill in slots 3 and 4, the computer gave me a black screen of death, as it wouldn't even load the OS. I got to "Loading Windows" with no microsoft symbol, and it froze. I had to use the power button to turn off the computer, and when I turned it back on, it gave an error message about hardware changing. It would not load the Windows Repair utility it recommended I run. After I switched the RAM around to have matching brands in slots 1/3 and 2/4, it booted up just fine, but CPU-Z said it was in single channel mode instead of dual channel. In addition, the computer would freeze randomly requiring a hard shut down, even during low-stress times such as typing an email. I am currently running on just the 2GB of G.Skill memory with zero problems, whether they are in slots 1/2 or in 3/4 (cpu-z says it's in dual channel). I ran memtest86+ on the G.Skill modules overnight with zero errors.

I understand that 32-bit Win 7 only recognizes 3.25GB, but is the excess RAM causing the freezing? Is the mobo just not capable of having 4GB of dual channel RAM, even though it is designed to? Would I be better off returning this RAM and just getting 2x2GB dual channel modules?

The only thing I do know is that my next computer will NOT be a Gateway. I figure I have until next tax refund to learn everything I can so I can build my own. Until then, I need to limp this old beast along. Any help that y'all can provide would be greatly appreciated.

See More: Gateway GT5228 wont run 4BG in dual channel

Report •

April 2, 2011 at 11:41:34
Not that it matters at this point, but the proper RAM to run with an Athlon X2 is PC2-6400 (DDR2-800).

Was the original RAM running in dual channel mode? states that your system doesn't support dual channel? That seems odd considering the CPU & motherboard, so they may be incorrect:

Report •

April 2, 2011 at 18:31:10
The gt5228 was made with 2 different sets of RAM. One brand was single channel, and the Samsung is dual channel. And, as you state, the CPU and the mobo both support it.

I went with the PC2-4200 because that is what was already in my system when I bought it. Not ideal, but it is what it is. I suppose I could RMA the G.Skill back to Newegg and get the G.Skill quad channel kit (4x1GB) so all of the modules will be the same, but if the mobo is the reason I can't run both banks in dual channel, then that won't help me any.

As far as I can tell, there is no mobo driver update that will help, either, although I could be wrong since I don't know all that much about motherboards. There is a driver update for the mobo that was released about 6mo. after I bought my computer that updates some things, but I'm a bit reluctant to try it if it won't help and has the risk of fragging the computer irreparably. It updates:
Ethernet Driver (v65.55) WHQL
SMBus Driver (v4.60) WHQL
Installer (v5.40)
IDE SataRAID Driver (v9.31) WHQL
IDE SataIDE Driver (v9.31) WHQL
RAIDTOOL Application (v9.31)
Display Driver (v97.54) WHQL
SMU (v1.23) WHQL

Do any of these address my issue?

Report •

April 2, 2011 at 19:33:59
"Do any of these address my issue?"

No, drivers have nothing to do with it. But it sure wouldn't hurt to upgrade them, it sounds like the ones you have are out of date. Here's the latest available for the nForce4 chipset:

"One brand was single channel, and the Samsung is dual channel"

Having a dual channel memory controller is what gives the RAM the ability to run in dual channel mode. In the case of AMD systems, the controller is built into the CPU. There is no such thing as "dual channel RAM". Any RAM can run in dual channel mode, provided the specs are similar, the motherboard supports dual channel mode & the RAM is installed in the correct memory slots. There are dual channel kits that are sold to run in boards that support dual channel mode, but all they are is matched pairs. Usually dual channel boards that have 4 RAM slots will have different colored slots to indicate the different channels. For example, 2 black (channel A) + 2 white (channel B). To enable dual channel, you'd need to install one stick in a black slot & one stick in a white slot. If both blacks slots are used (or both white), it would be single channel mode. Other board manufacturers use black + white for channel A & black + white for channel B. To enable dual channel mode with that type of setup, you'd need to put the RAM in both black slots (or both white).

I couldn't find any info stating that your board supports dual channel mode.

Report •

Related Solutions

April 2, 2011 at 21:08:55
Well, this is interesting. First my attempts to run memtest86+ on all modules installed sequentially, then I'll respond to your post.

I just tried to run memtest86+ with my Samsung in 1&2, and G.Skill in 3&4. Memtest went haywire! It started, recognized there was 4GB of RAM to test, and then gave me a multicolored display of garbled characters randomly scattered all over the screen, and locked up. I had to turn it off with the power button, take out 2GB, and then it worked fine. Loads into Win7 fine, also. Now running on the Samsung modules in slots 1&2, with cpu-z saying I'm running in dual channel mode.

OK, now on to your response:

If, as you say, my mobo does not support dual channel mode, then I am even more confused.

A) none of the memory slots are colored. All four are black.
B) This link about dual channel explains that mobos for AMD chips don't skip a socket (1&3, etc.).
"You can find motherboards targeted to AMD processors using the same method described before or enabling dual-channel by installing memory modules sequentially, not skipping one socket."
C) This place says the mobo supports dual channel DDR2.
D) CPU-Z says my memory is running in dual channel mode when I have my memory in slots 1&2 or 3&4. When I have the modules in 1&3 or 2&4, cpu-z says my memory is running in single channel. If my mobo doesn't support dual channel, then cpu-z should say that I am running in single channel mode no matter where the DIMMs are, correct?
E) If all I have available is single channel mode, then it should not matter what memory modules I stick in what slot, regardless of brand, correct? If so, then this brings me right back to my original problem:

why won't it work when I have all four modules installed in what would be considered a dual channel mode for AMD chips? Why do they work when I skip a slot, but not when I put them in sequentially, if I supposedly can only run in single channel mode? Why doesn't it just run in single channel mode when I have them installed sequentially instead of killing my computer? Why does it randomly freeze up even when I do have all 4 modules installed in alternating fashion?

I'm beginning to wonder if I'm seeing the beginning of this computer's death throes. I hope not, as I don't have enough time to learn what I need to build one (not to mention the funds aren't there right now). It needs to survive until next tax season.

Report •

Ask Question