Solved G4 won't power up after trying to add more ram..

May 6, 2012 at 02:27:52
Specs: Windows 7
Added new RAM to my G4 and now it won't power up Light and fan turn on for a couple of seconds then shuts its self down. We took out the new ram and same problem. HAVE to have the computer to finish an audiobook .. HELP

See More: G4 wont power up after trying to add more ram..

Report •

May 6, 2012 at 03:46:45
Did you take care to remove static electricity from your body (by using an earthing wrist-strap or touching bare metal of computer chassis) before touching any of the old and new RAM modules?

If not, you may have damaged the RAM modules with static electricity flowing through them. Static destroys the RAM chips on the module card.

Report •

May 6, 2012 at 18:54:03
G4 is the processor not the model name of your computer. Do you have a G4 eMac, iMac, PowerMac, iBook, PowerBook, etc....

You most likely installed incompatible ram and the the pram was changed.

Reset your PRAM, power the computer on and hold the Command, Option, P, R keys until the computer pongs twice.

If you can get into open firmware, reset your NVRAM. Hold Command, Option, O, F keys until you get into the open firmware screen



So, give that a try.

Report •

May 13, 2012 at 06:19:53
✔ Best Answer
Found out what happened for all you who have tried to help

NEVER EVER take Ram out of a computer with the computer still ON!!! My husband couldn't wait 5 minutes for me to finish dinner so he tried to do it himself with the PC on and fried the logic board. Grrrrrrrr LOL anyway G4 is dead.

Report •

Related Solutions

May 14, 2012 at 15:13:59
That's too bad, good time for an upgrade I guess.

Report •

Ask Question