From earlier posts: Epson x420 black ink doesn't print

August 22, 2018 at 18:40:27
Specs: Macintosh
Epson original cartridge installed.

I've tried everything the earlier posts (back to 2016) suggested (there's only a few things to check):
1) Cleaned (with windex) the nib on the printer that sticks into the ink cartridge
2) Turned printer on and off
3) Did head cleaning 3-4 times

Each time, the ink level for the black showed markedly less ink (only after 3 cleanings). After showing almost full when I started, by the 3rd cleaning it was almost empty. I figured that after cleaning the nib, it was more accurately reading the ink level. The cartridge seems to have lots of ink in it, by the sound of shaking it (I know there can be ink in there even when it's almost empty, but this cartridge sounds full...).

All other colors print fine. Using a windex-soaked Qtip, I get plenty of ink from the nib and the ink cartridge.

Printer displays "Black Ink Low" warning now, even though cartridge seems full...

Faulty cartridge?? Are they warranted after being used?


See More: From earlier posts: Epson x420 black ink doesnt print

Reply ↓  Report •

#1
August 22, 2018 at 22:54:10
Observations, reports, some long while back were common about Epson printers with respect to cartridges.

The cartridges were expensive, invariably “fixed” (as in designed...) to indicate that had runout of ink, even though there was still a lot in the tank. There were some comments too that Epson (inkjet) printers were very prone to problems with their built-in software such that they would behave as you are experiencing...

I may still have the links to a couple of sites which dealt with cartridge problems in general, not the least those of Epson; and how to override the software controls re’ replacement. If I can find them I’ll post them here.

Are there any other error messages?

As suggested in your previous post, check with the vendor where you bought the cartridges re’ warranty etc.?

Meanwhile, have you seen this:

https://m.youtube.com/watch?v=KorTM...

message edited by trvlr


Reply ↓  Report •

#2
August 22, 2018 at 23:53:08
thanks for the prelim response and link. Not sure if a chip resetter would cure this problem, as the nozzle check still doesn't show black ink. Whether that's an Epson fixed fraud or not, physically it seems no ink is reaching the paper.

To answer your question, no error messages other than Black Ink Low. Every time I did Head Cleaning, message said Ink Recharged, or something like that, indicating all went well.


Reply ↓  Report •

#3
August 23, 2018 at 02:55:51
Hi Ronl,

have you seen the other thread recently posted in this Forum with same Epson problem.

Maybe there is a bad batch of Cartridges.

Good Luck - Keep us posted.


Reply ↓  Report •

Related Solutions

#4
August 23, 2018 at 21:11:33
Mike,

I have searched and found some posts about Epson ink cartridge issues, along with your same reply to them. But not sure which thread you are referring to. Could not see any other solutions.


Reply ↓  Report •

#5
August 24, 2018 at 05:34:28
Hi Ronl,

the 'other' post I referred to is:

https://www.computing.net/answers/h...

No solutions, but two printers, similar model numbers, at same time could be indicative of a bad batch of Cartridges.

Regards - Mike


Reply ↓  Report •

#6
August 24, 2018 at 18:48:45
Mike,

Thanks for the link.

I've printed from the cartridge previously, but it was a long time later that I tried again. So I won't try to return it.
Contrary to the post link you sent, I haven't gotten low ink error messages. The ink just isn't coming through. I've cleaned the print nibs and they are clear, and there is fresh ink at the cartridge tip when I put a Qtip on it.

Thinking that it's now a chip issue, I looked for a resetter that works for this 9-pin printer. They cost the same as 1-2 cartridges, and since I don't trust this printer or Epson on their low-end printers (I have an Epson 3880 that I love, which, BTW, prints from 3rd party inks just fine), I have given up and am keeping the printer just for scans and non-printing uses.

Very annoying.


Reply ↓  Report •

Ask Question