fried usb on my Lenovo 3000 c300 .

Lenovo 3000 c300 desktop computer - 1 x...
April 29, 2011 at 15:54:45
Specs: Windows 7, 4gb
All six usb ports on my all-in-one desktop are not working.i have done all the software troubleshoots and its still not working. I am even trying to get a motherboard for it but cannot get one . HEEEEEEEEELP

See More: fried usb on my Lenovo 3000 c300 .

Report •

April 29, 2011 at 17:35:14
It is highly unlikely that you fried all your USB ports.

Telling us you did all the software troubleshoots means nothing. We don't know what troubleshooting you did. Tell us.

What do you see in Device manager for the USB controllers?

Did you install the motherboard chipset drivers.

Below is a link to the Lenovo site for your model.

Report •

May 5, 2011 at 16:06:43
in the device manager the usb ports all show that they are working. i have tried uninstalling and restarting but still no respone when i plug a usb device in. The power does not come to the usb anymore now, like i can't charge my ipod by connecting it to the PC.
and yes i have installed the chipset drivers for it too.

Report •

May 5, 2011 at 16:12:32
Boot into Safe mode and check Device manager again. You could delete all the USB controllers and reboot to see if that helps. If you have any external hardware connected to any USB port, remove it. Hardware that is burned out can overload the USB controller and render it dead but after that hardware is removed the controller might start working again on a reboot.

If you have a card reader, remove all media from it too.

Report •

Related Solutions

May 5, 2011 at 17:32:55
no hardware is connected since all usb slots are malfunctioning. I tried deleting the usb controllers in safe mode but unfortunately no change.

Report •

May 5, 2011 at 19:56:24
I was referring to an internal card reader.

Well, I suppose it is possible that all 6 ports (2/3 USB controllers) could be damaged but I wouldn't give even money on that bet.

You could try performing a factory restore.

Has anyone else had access to your laptop? USB access can be withheld by either permissions or registry modification. This is done all the time in the corporate world so employees can't install programs.

You might check the BIOS for a possible setting too.

Report •

May 5, 2011 at 23:10:00
there is no card reader installed and its a desktop. No one else has access to it but me.
I restored it back to factory settings using the CD and no change. I also flashed the bios sometime back.
the problem still remained.

Report •

May 6, 2011 at 05:18:35
Sorry about the laptop comment. The comments still apply.

Did ALL the ports work at one time in the past?

Well, the only other troubleshooting idea I have at the moment is to boot to a live version of Linux to see if the USB ports then work. If they don't then you are probably correct that they are all dead.

Linux puppy is fairly small. Download and burn to disk. Then boot from the disk.

Report •

May 8, 2011 at 06:12:04
I will try that and let you know. Can you assist me in finding a motherboard for my desktop?

Report •

May 8, 2011 at 07:24:53
I haven't been able to determine what form factor the motherboard is. I suspect it is a cutom unit that may be made only for Lenovo. There are other makers that make all in one computers so it is possible there are board available. I suspect they will be cost prohibitive.

I suggest that first you run Linux to verify that the USB ports are actually fried. Next, if they are fried you need to determine how they got that way. You may have a piece of defective hardware that fried the controllers. If that is the case replacing the board and trying to connect your hardware will damage another board.

Then contact a Lenovo authorized service center and find out about the board. You need to know the cost of the replacement board and the full part number.

Did you check the BIOS settings to see if there are any that could disable all the USB ports. Also, check the permissions in Windows to see if the ports are blocked there.

You never explained how when and where the USB ports quit working. Did they aver work for you? Did all stop at the same time?

List all USB devices you have ever connected to this computer. Have you successfully used all those same devices on any other computer?

Report •

May 8, 2011 at 09:33:14
the usb ports all stopped working just about 2 weeks after using the PC. I bought it brand new. the PC was on when it occurred. I had stepped out for an hour \ and when I returned I found out they were unresponsive. I can't return it for warranty cos i changed the origional OS (from vista to win 7) plus partitioned it and I boughtit from a friend who got it as a gift from the states.
All the devices i used with it, I have been using for my previous PCs (3) and no problem on them. I still use them on my netbook and there is no problem. the devices are: logitech control pad, seagate external harddisk and my mouse and pendrive.

the bios setting shows that the usb is enabled, so does the device manager. It is unresponsive if you plug a usb device in it.

I am in Ghana, West Africa and there is no Lenovo Service Center around. That is the problem.
I tried contacting Lenovo and they surprisingly couldn't hep me out with the replacement for the motherboard.

I gave it to a Tech guy here who checked it out and told me to replace the board cos the usb chipset was heating up pretty bad and that might have caused the malfunctioning.

Report •

Ask Question