Format laptop with invalid partition tablet thru USB drive

November 25, 2014 at 07:00:10
Specs: win7, intel pentium M
laptop shows invatid partition table on start-up

tried reinstalling win 7 using usb created with wintoflash/windows7 usb/dvd tool

set 1st boot priority on removable dev.

after trying to reboot with usb screen still showing invalid partition table..

1. after i reboot and go to bios with my usb plugged in should the 1st boot priority say generic usb instead of removable dev.?

when i go to hard disk drives under boot on bios 2nd drive shows generic usb

2. How do i get laptop to boot my win 7 usb?

laptop has no available cd-rom.

See More: Format laptop with invalid partition tablet thru USB drive

Report •

November 25, 2014 at 09:12:31
I'm not familiar with the app you seem to mention initially (for creating a usb - which presumably means a "bootable flash drive")...

But I would expect you would be better creating a suitable CD/DVD to the same end; although I may be somewhat out of date in this regard, as USB flash drives seem more popular for this event nowadays? Presumably your laptop is new enough to allow usb boot options

As you appear to be able to boot up at present - or at least access bios settings which is what you need in order to set boot device order...

Go into bios and move the generic usb entry to first boot device?

Typically if the first bootable device fails (as in - not found, not bootable etc.) the system will work its way down the list to find something that will boot the system.

Nowadays many people leave the hard drive as first boot device and then CD/DVDROM second, and so on. Personally (being from the stone age in terms of computers and OS various) I still prefer CD/DVDROM first and then the hard drive. And in days of olde/yore it would have ben floppy, then cd/dvd, then hard drive...

Also worth having a read of these articles for more input on your problem as posted:

Report •

November 25, 2014 at 09:21:15
the problem im having is that the laptop wont boot the bootable flash drive as a bootable flash drive.. it only sees the bootable flash drive as an alternative hard drive. i can only get the bootable flash drive to boot if i select the bootable flash drive under boot>hard drives and set it to 1st drive and have the original hard drive set to 2nd drive.

does a corrputed mbr have anything to do with bootable flash drive not being able to boot even if its set a the 1st priority boot device

message edited by clicker08

Report •

November 25, 2014 at 10:23:46
If the flash drive won't boot then possibly it's not been made to do so (properly); or the boot-files are damaged etc...?

It may well be that somewhere the process wasn't completed correctly when you made the one you have?

Perhaps have a read of the links I posted above and then remake the flash drive?

When I attempted to make a slip-streamd sp-3 XP cd a while back (sp3 into an OEM sp1-disk) it took me two attempts to make one that worked; similarly with a usb bootable flash drive...

Report •

Related Solutions

November 25, 2014 at 18:58:31
Does your laptop hard drive have a restore partition on it? If it's not affected by the 'bad partition table' you can reinstall that way. What's your laptop model number?

message edited by DAVEINCAPS

Report •

November 25, 2014 at 20:33:58
@daveinvaps - laptop has no restore partition.

Report •

November 26, 2014 at 01:38:20
@trvlr - tried the third link from the list above.. set my boot priority to boot the bootable flash drive first. same result. laptop bypassed the 1st priority went to hard drive then got the invalid partition table on a black screen? will try your other links.

Report •

November 26, 2014 at 04:17:28
im stuck... and confused.. i plugged the vebatim flash drive to another laptop and i got it to show on where i can select which boot device to boot from. but with the other laptop that im trying to reinstall windows it won't show it on the list of device that i can boot from.

anyone have ideas???

Report •

November 26, 2014 at 09:28:41
Not sure what's amiss here... Pending more input from others with possibly/probably more familiarity with usb-flashdrive boot ups... it might be an issue with the flash drive itself?

I have on occasion found that a given make won't work in one computer but is OK in another... Usually it's been a generic - "obscure" brand - item rather than a decent/well known brand - and Verbatim is well enough known.

But it might be worth a try with another flash drive - be it same make or another?

Report •

November 26, 2014 at 09:32:01
I have also tried using kingston and the results are the same.

Report •

November 26, 2014 at 11:43:56
Guess we've pretty well ruled out usb sticks various; although there"may" be a problem within the laptop itself in that regard... What make and model is this problem laptop?

How many usb ports are there; and if more than one - have you tried using each of the others?

Report •

November 26, 2014 at 18:35:09
Post #2 is exactly how it's supposed to work. The USB drive boots into the first slot as an emulated hard drive C: and moves all real hard drives to 2nd or more places. You then use drive C: (the USB drive) to wipe your real hard drives starting with drive D: End of bad partition tables because you have none any more except for the emulated on at drive C: - pooch that one and you need to re-flash your USB drive. Now Win7 will try to install from the USB device if it hasn't been pooched by all the messing around you've done - I would re-burn the USB drive with installation files from the very start of making the USB drive bootable. And read the directions on how to use it.

Using Rufus you could boot the USB drive to MS-DOS and use Bart's Disktool to erase the hard drives by writing zeros to it - this doesn't need to go to the end, you can abort the wipe at 10% and start over with fdisking the hard drives to set up valid partition tables. What I don't know is how extensive the win7 installer is as far as setting up hard drives, it may be that it only does reinstall to valid i386 folders already formatted to NTFS file system. Aefdisk under MS-DOS can set up the NTFS partitions as you like but it doesn't do NTFS format command. All I've got, sorry.


Report •

November 26, 2014 at 19:27:38
If the installer for the USB drive has all of the tools that the DVD install disk does, then you just choose Custom install and then Partition/Format. From there you can delete any remaining partitions, create a new one, and format it. Then you are ready to proceed with the install. Any additional partitions can be created later from Disk Manager within Windows 7.

You have to be a little bit crazy to keep you from going insane.

Report •

Ask Question