Floppy wont write

February 27, 2010 at 13:49:52
Specs: Windows XP
I just dug this from storage. When I try to copy a program from HDD to 3.5" diskette I get write errors. I ran diags and get errors 648 &655. Fails same on 2 different floppy drives. Are there termination jumpers somewhere? I see empty jumper pins on the HDD, but I cant find any reference about what they are for. Probably something simple but I cant figure out what! pls help

See More: Floppy wont write

Report •

February 27, 2010 at 22:22:22
Those both appear to be associated with the floppy


so the hard drive and its jumpers aren't a factor.

Floppy drives used to have jumpers for Drive Select. Newer ones are all set at DS2 and the jumpers either aren't accessable or aren't there. For the usual floppy cables with the 7-wire twist, the drive connects on the end connector AFTER the twist.

Are the drive and the disks you're using both 1.44? 1.44 disks will have two square holes in two of the corners. Those match two sensors at the front of the drive. One detects if the disk is 1.44 and the other will have a slide to cover the hole. If that hole is uncovered that makes the disk read-only.

1.44 drives will have two sensors. 720K drives will have one.

So verify the drive and disks are 1.44 and if the floppy drive has jumpers look for the DS jumper and set it for the second drive select.

Other than all that, is the drive cable in good condition? Is the floppy drive properly identified in cmos/bios setup? Also, it would probably be a good idea to reformat the disks before using them.

You're not really green until you're soylent green.

Report •

March 7, 2010 at 06:07:40
A case of ignoring the obvious..Thought it was 2 probs. ,really only 1..I was also getting 161 & 163 errors on boot-up, let me get by with PF1, ran setup, thought all was well...I guess when batt in DS1287 chip is dead, it wont store NVS either..oh well , live & learn..your last line in msg did it for me.."cmos/bios setup"..tks a lot..have a great day...

Report •

March 7, 2010 at 06:39:08
If you have not tried more than one data cable, most likely you have a data cable problem.

This is about IDE cables but the same applies to floppy data cables.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

" I guess when batt in DS1287 chip is dead..."

I have a old mboard circa 1995 (Gigabyte 586AT) that had that problem, but it had no effect on whether the floppy drive was detected properly. It just couldn't retain the time and date, or other custom bios Setup settings.

I found out that it's RTC, ODIN OEC12C887, is no longer made, but can be replaced with a Dallas DS12C887, or a DS12887, which has a Y2K problem. Dallas (Maxim actually - bought them out) says the original Award 4.51PG bios will probably not work with the DS12C887, so I obtained two DS12887 RTCs, installed one in the mboard, the other other one is still sitting around. The lithium battery inside the modules is only expected to last 5 years, and they are at least that old, however, they usually last longer than that. The mboard was recently fried by a failing power supply.

Report •
Related Solutions

Ask Question