Flash drive not detected and 0 bytes

Lacie Cookey 131049 flash drive - 8 gb
January 4, 2011 at 23:42:44
Specs: Windows 7
How can I fix my Lacie CooKey 8gb flash drive? I've tried plugging it into every USB ports in all the computers in my house.

It's not being detected in windows 7(it used to be able to detect it). However, I can see it in windows xp although it says there is 0 bytes.

In windows xp, I've tried to format it but I get "there is no disk in drive F"
I even tried to run format F: /fs:ntfs but no luck.

this is what I see in disk management (on windows 7 and it's drive E)


See More: Flash drive not detected and 0 bytes

Report •

January 5, 2011 at 09:36:37
if you can download this:

create a bootable cd and boot one of your computers with it.
plug in the drive, delete any existing partition, recreate it, then format.
CAUTION this will erase all data. Also don't accidentially erase your hard drive.
post back with the result.


Report •

January 5, 2011 at 20:50:19
It can't seem to detect the drive still so I couldn't really recreate the partition unless I did it incorrectly.

Report •

January 6, 2011 at 05:41:52
if you were able to boot a computer with the gparted cd and it can't see the drive, then considering the other machines also could not see the drive, except for the XP machine, which sees it as 0gb, then I would suggest the drive is toast.


Report •
Related Solutions

Ask Question