Flash BIOS with wrong firmware can't recover

Ecs (elitegroup computers) Ecs 945gctm/1...
April 23, 2010 at 07:39:13
Specs: Windows 7, Amd Althlon 64 X2 4400+
Ok, I have a ECS 945GCTM/1333 (V3.0) and when i went to go install a SL7Z9 Processor, It would not read it, So i thought i should flash the bios, Did it thru windows, But.... the twist is... I used the ECS 945GCT-M (V1.0)..... Completely wrong one... now i tried to get it to recover Via boot block.. but no matter what i do, It WILL NOT read from floppy, CD or USB
Can anyone help me? Should i just spend $31 for a new board? i think i will call ECS and ask them if they have any recommendations.

See More: Flash BIOS with wrong firmware cant recover

April 23, 2010 at 12:40:40
Ah, yes I remember my First Firmware bricking. They are so much fun.

Oh, sorry um yes you have bricked the device. It may support J-TAGing if the board has a factory serial connector. You might be able to flash through a serial port from a laptop if so.


but I would not hold my breath. Might have to buy a new board.

Report •

April 23, 2010 at 14:59:50
You should NEVER flash from Windows unless there is no other way. What happens when you try to boot the system now? Is there any display at all?

Report •

April 23, 2010 at 15:26:17
No, No Display, Does not try to even read from floppy.

Also about the J-TAG.... I followed that link and it just lead me to a google search Containing instructions to JTAG a 360... I have a Serial COM port built into this and a Male to male COM Cable....I also have another Desktop with windows XP and hyperterminal.... i tried this last night as to AMI's Instructions and it won't work... if you could give me a link to what i should do i can try it.

Report •

Related Solutions

April 23, 2010 at 16:10:20
There's no guarantee this will work, but it's worth a shot:

Disconnect all unnecessary devices...HDD(s), CD drive(s), remove all cards; unplug the mouse, printer, & all other external devices except for the keyboard. Hopefully the keyboard is a PS/2 rather than USB?

In the end, the only things that should be connected to the board (other than the PSU, CPU, & RAM) are the monitor, floppy drive, & keyboard.

Unplug the power cord & use the ClearCMOS jumper to reset the BIOS. Make sure the monitor is connected to the onboard graphics.

To reflash the BIOS, use the two-floppy method:

floppy 1 = WinME boot floppy
floppy 2 = BIOS ROM file (871827A1.ROM) & flash utility (AFUDOS.EXE).

Here's how it's done:

1. boot off floppy 1, select option 4 (minimal boot), then wait for the A:\> prompt to come up

2. remove floppy 1 & insert floppy 2. At the A:\> prompt, type AFUDOS & press ENTER

3. follow the on-screen instructions

Report •

April 23, 2010 at 16:24:20
I don't See how that would work... It will not display Video.... Nor read from a floppy drive.... It has both the power and hard drive light on constantly...

Report •

April 23, 2010 at 17:52:59
"I don't See how that would work..."

OK, fine. My suggestion won't cost you a penny but rather than trying what I suggested, go buy a new board. But this time, don't get one that's based on such an outdated chipset & ICH. And plan on paying a lot more than just $31.

Report •

April 23, 2010 at 19:21:01
I'd try any method of recovering a pooched BIOS flash; and have.

Of the many corrupted BIOS flashes I've seen, I was only able to not recover one of those. That one was fixed by an RMA from the manufacturer.

Yea MSI.


Report •

April 24, 2010 at 06:02:39
Contact ECS support. The Bios chip should be removable. They should send you a new chip. simply replace it. There are web sites with more info.

Report •

April 24, 2010 at 07:50:07
Try these instructions, but be sure to read all three pages before you start;


Report •

April 24, 2010 at 11:59:21
"...No Display, Does not try to even read from floppy."

One of the reasons you're NOT supposed to flash the bios unless you MUST, is the bios flash chip can physically fail while flashing, sometimes the FIRST time you try to flash.

You could try the automatic no video flash method pointed to by capt - you have an AMI bios apparently - however, I don't think it will work.
If the flash chip is still physically okay, if the boot block portion of the bios is intact, if what applies to older mboards applies to yours, you SHOULD see the floppy drive's led come on while booting when there's no disk in it, after the usual brief flash, for a longer time.

If the bios flash chip has physically failed, it must be replaced with one that has already been flashed.

The manual for your model
945gct-m/1333 v. 3.0 support

does not show where the bios flash chip is.

Picture here:

however, I don't see a bios chip in a socket, unless it's what appears to be the black chip with the 4 leads each side top and bottom near the bottom right corner.

Most recent mboards have the bios flash chip soldered into the mboard. If the bios chip is not removable, it's not an amateurs job to replace it.

In any case, if you can get another mboard for only $31, that's cheaper than it would be to replace the bios chip even if it is in a socket.

Report •

April 26, 2010 at 08:17:58
Thanks for the help, Went ahead and bought a new board off Newegg....
Its a G31 Chipset so i am happy!
Thank you all!

Report •

April 26, 2010 at 10:42:22
We're glad to hear you found a solution.

NOTE that many ECS mboards are actually made by the same parent company that makes what are sold as PCChips brand mboards, and sometimes other possible brands mboards - Hsing Tech - in that case they are identical to a PCChips model (PCChips uses different model numbers) and merely have ECS labelling on them. Often the manual is generic and mentions nothing about ECS (Elite Computer Systems) in the body of the manual in that case, the ECS model number may be on the cover page of the printed manual, but nowhere in the body of the manual, but sometimes ECS makes their own version of the generic manual . Hsing Tech has a reputation of using the absolute cheapest bios flash chips they can on the mboards they make, and for flashing the bios to fail more often than average because the el-cheapo flash chip has physically failed while flashing.

Report •

April 26, 2010 at 19:49:02
Yup, and thanks! I Found out that ECS was the same as PCChips, I have owned 2 boards from them, Fool me once, Shame on me, Fool me twice, Shame on you. Never will Buy ECS/PCChips again, Not only is the reputation bad but this particular motherboard would malfunction I.E Mouse would freak out and go haywire. Glad to be Rid of it!

Thanks Again!

Report •

April 27, 2010 at 13:08:30
If the ECS mboard has a stuck on label with it's model number on it, it was definitely made by Hsing Tech - mboards made by them usually do not have any model number printed on the surface of the mboard, but they do have the Rev or Ver of the model printed on them. If the ECS model number is printed on the mboard surface , then the mboard could have been made by ECS or another maker for ECS, or it's quite possible Hsing Tech did that special order for ECS. Hsing Tech mboards usually have at least some re-named chips - the names / models are used only by Hsing Tech - e.g. if any chip model number starts with HT the mboard was made by Hsing Tech.

"Mouse would freak out and go haywire"

That's probably got nothing to do with it being and ECS or Hsing Tech mboard.

If it's a corded mouse, it's common for one or more of the wires to get broken inside the cord after it has been used a lot, or at any time if the cord was yanked on, often near where it enters the mouse.
The mouse's cursor can behave as if it's being controlled by something or jump all over if a wire is broken but it's ends are still touching each other (intermittent or poor connection), or only move in one of up and down or sideways (broken wire, it's ends are not touching each other) . The symptoms may appear / disappear when you wiggle the cord near where it enters the mouse.
Try another mouse.
Also, make sure there are no keys such as cursor keys stuck in the down position on your keyboard when the mouse cursor behaves weirdly.

The same applies to corded keyboards.

If it's a wireless mouse,
- you must install the software for it properly - follow the mouse manufacturer's installation directions
- other wireless devices MAY interfere with the wireless mouse's wireless connection and cause it to behave weirdly
- it's transmitter / receiver that plugs into USB may not work properly if it's plugged into the front ports on a desktop case, or if it's plugged into a mutiport port USB hub that plugs into only one USB port directly connected to the mboard. It should work fine when pligged into a USB port directly connected to the mboard - one in the I/O area on the back of the case where most of the ports are on a desktop computer, or in port built into a laptop's base.

If a corded mouse is connected via USB, the same things about USB ports apply.

Report •

Ask Question