FDISK problem

March 15, 2009 at 12:10:52
Specs: Windows 2000 Prof
Hi - I've just installed a new hard drive (Hitachi Travelstar 20GB) in a Sony Vaio PCG-F807K and the BIOS (Phoenix 4.0 Release 6.0) seems to have auto-detected it OK. As all I was now getting was 'Operating System not found' on boot-up, I used a Win ME Boot Disk (Custom - no ramdrive, from www.bootdisk.com) to boot to A:\. with the aim of creating an active primary partition on the new drive. The problem is that after doing so and re-booting as instructed for changes to take effect, the partition details all disappear and I'm back to square one, with still no C:\ drive to begin formatting. I've tried it several times with the same result each time and have even reset the BIOS to factory defaults in the hope that this might cure the problem.I've a single OEM copy of Win2K to install on the new drive and even tried booting it from CD to see if it could overcome this, but it quits after trying - unsuccessfully - to format the drive. I'd be grateful for any suggestions as to what the problem is likely to be as this is driving me mad!

See More: FDISK problem

Report •

March 15, 2009 at 12:31:25
You shouldn't have to use the boot floppy at all but since you have it, you need to boot off it & run FDISK, enable large disk support, then create the partition(s). Then reboot with the floppy still in the drive, select "minimal boot", then from the A:\>, type format c: & press enter. Of course, this will format as FAT32 rather than NTFS.

Report •

March 15, 2009 at 14:34:13
Thanks Jam. I did this again just to step through and record messages at each stage - here's how it goes...
(1) Ran FDISK from A:\ and chose option 1 to create primary DOS partition, opting for 15% (2863MB) in size. Reports back 'Primary DOS partition created'
(2) Still in FDISK chose option 2 to make partition active. Reports back 'Partition 1 made active'
(3) Pressed ESC to exit FDISK back to A:\
(4) Re-booted using Ctrl+Alt+Del with floppy boot disk still in drive - boots straight to A:\ (i.e. no option presented for 'Minimal Boot')
(5) Entered 'format c:' at A:\ and got 'Invalid drive specification'
(6) Ran FDISK again and selected option 4 to view partitions and got back 'No partitions defined'

This is the crux of the problem, for I'm baffled as to why the primary DOS partition is 'lost' every time on the reboot - any ideas?

BTW is there any relevance in the fact that at stage (1) when it lists C: as the primary DOS partition it states under 'System' = UNKNOWN?

Report •

March 15, 2009 at 18:30:52
First and formost I am wrong....Ok so no argument .but I think the travestars were shipped with the jumpers set on slave.

If this is a used but new to you and it has been debaned
you may have to set the jumper to cs in order to get it to work.

If the 2k disk sees the drive but fails on format......memory or a bad sector on the hard drive can cause this.

Report •

Related Solutions

March 16, 2009 at 00:04:01
A loose or bad drive data cable can do that.

Report •

March 16, 2009 at 04:14:13
Thanks worldlibrary and DAVEINCAPS.

As far as I know the drive was brand new (ebay purchase) and came with no jumpers (i.e. four pins not linked which designated it as drive 0).

I'll have another look at the drive data cable in case this is the root cause.

Report •

March 23, 2009 at 05:12:22
Looks like the drive cable was at fault - replacing it did the trick.

Thanks again DAVEINCAPS - good call!

Report •

March 23, 2009 at 05:25:42
Why are you bothering with the boot floppy at all?

Win2000 CDs are bootable and you can prep the drive from them.

At this point you may wish to download and run Hitachi's drive fitness test to see if there is a problem with the drive.

Report •

March 23, 2009 at 06:34:03
as mentioned, it should boot straight from the windows cd. unless it is really old and has no option to boot from a cd. i once had a very old dell pc which needed doing this via the floppy as the bios had no boot from cd option

Report •

March 23, 2009 at 13:10:08
Thanks OtheHill and cliffpage.

Laptop is c9 years old but it will boot from CD. Some initial difficulty with CD-DOM led to the need for a floppy boot, but even when this was fixed the Windows CD couldn't format the drive due presumably to the fault with the drive cable.

Replacing the cable seems to have sorted the problem.

Report •

March 23, 2009 at 13:16:26
OK then, thank for getting back to us.

Report •

Ask Question