Failed to Load Detection Driver for new AMD Radeon video

August 19, 2013 at 03:43:57
Specs: Windows 7 32 Bit
I have a new AMD Radeon HD X2400 I bought that I want to install in my computer. I'm using Windows 7 32 Bit.
I downloaded the driver here: http://support.amd.com/us/gpudownlo...
When I try to install the driver, it goes to a blue screen which has an error, and then reboots. If I try to install the driver in save mode it says "failed to load detection driver". I reinstalled Windows and I get the same thing. What do I do?

See More: Failed to Load Detection Driver for new AMD Radeon video

Report •


#1
August 19, 2013 at 06:13:50
"When I try to install the driver, it goes to a blue screen which has an error"

Please post what that error says. Just saying it "has an error" is not very helpful.

Just for your information, the error you got in safe mode is quite normal. Driver installation software can't function properly in safe mode.


Report •

#2
August 19, 2013 at 07:55:38
"I have a new AMD Radeon HD X2400 I bought that I want to install in my computer"

The 1st thing you need to do is clarify which graphics card you have. I'm not aware of an HD X2400, possibly it's an HD 2400 XT? I suppose the card manufacturer may have added the "X" into the model number but AFAIK, AMD/ATI has never had an X2400. And I'm curious why you would buy an old low end card rather than something more up to date?

http://www.techpowerup.com/reviews/...

"I reinstalled Windows and I get the same thing. What do I do?"

Reinstalling Windows was a drastic move. Does the card work OK before the AMD driver is installed? You're not attempting to install the driver before the card is installed, are you? Did you install the motherboard chipset drivers before trying to install the graphics driver?

message edited by riider


Report •

#3
August 20, 2013 at 04:24:32
"Please post what that error says. Just saying it "has an error" is not very helpful."
It's hard to get what it says. My screen gets all these colorful lines over it and then goes to a blue screen. The blue screen is on for about 3 seconds and says something about an error. Then the PC reboots.

"I'm not aware of an HD X2400, possibly it's an HD 2400 XT?"
Yeah, HD 2400 XT. Sorry.

"Does the card work OK before the AMD driver is installed?"
Yeah.

"You're not attempting to install the driver before the card is installed, are you?"
No.

"Did you install the motherboard chipset drivers before trying to install the graphics driver?"
Yes.


Report •
Related Solutions


Ask Question