External hard drive doesn't initialize

Hewlett-packard / Pavillion a6657sc
March 3, 2010 at 03:44:49
Specs: Windows Vista Home Premium 64bit, SP2, AMD Phenom 8600 Triple-Core 2.30GHz/4GB RAM
I have removed a 2.5 HDD from my broken Fujitsu Siemens laptop (XP OS), Fujitsu MHT2080AT (yes, small disk) to copy data to my PC (Vista Premium x64) using a USB HDD casing. When that was done successfully, I started using it as an external backup drive. But after some time it did not show in my computer. I thought maybe the casing was broken, so I bought another one but with the same result.

In disk management it shows as “Disk 5” and needs to be initialized, but when I right click and chose initialize either MBR or GPT I get “Disk not ready”. First HDD casing was powered by double USB, and the second one has external power. I even tried to power it from the extra drive power cables inside my computer, but no luck.

I have valuable files on this disk, and I can’t find a way to retrieve them. Can anyone please help?

See More: External hard drive doesnt initialize

Report •

March 3, 2010 at 19:23:46
Your drive was probably removed improperly and the fat got
scrambled. Try disk recovery software.

Report •

March 3, 2010 at 23:59:07
Thanks, I will try this.

Do you know of any good disk recovery software that can repair a disk that is not initialized? I have tried some software earlier (on other disks), but recovery assumed that the disk was recognized by Windows.

Report •

March 4, 2010 at 00:25:37

Report •
Related Solutions

Ask Question