External Hard Disk Not Detected on My PC

February 12, 2012 at 09:18:02
Specs: Windows 7
Dear all,

I couldn't retrieve the data from my external hard disk...

At first, I got the error message "A cyclic redundancy check (CRC)" when double clicked on the E: drive (my ext harddisk). After performing the CHKDSK /R, the situation was getting worst and the E: drive disappered and never shown again in My Computer... I really want to cry now...

I used the tool testdisk and it shows "Partition: Read error" when trying to analyze the partition. Before performing the CHKDSK /R, testdisk indicated a green light on my partition... Apparently CHKDSK /R has spoilted everything! I am very regret now and I shoud not tried chkdsk on windows 7... The testdisk can't be used now to repair my ext harddisk since it can't detect the partition any longer....

Then, I came across to this thread which saying that Knoppix might help. I have burnt Knoppix.ISO into a disc and boot knoppix. However, Knoppix cannot detect my external harddisk... Knoppix works fine and managed to detect my friend's ext disk, but not mine... heartbroken...


I am really out of idea now how to recover all my data... Can you please help?


See More: External Hard Disk Not Detected on My PC

Report •

February 12, 2012 at 10:18:14
Make sure you're plugging it directing into the USB port on the motherboard, not thru the front case ports & not thru a USB hub.

Report •

February 12, 2012 at 12:28:50
Look for the external drive in Windows Disk Management. If it show up there, then post all the information listed for it.

If you don't see it in Disk Management then look in Device Manager in Universal Serial Bus Controllers. It should be listed under Mass Storage device. If it is not listed there either, then the USB connection may be bad or the external enclosure may be defective.

When working correctly you should find a USB drive listing in Device manager under hard drives in addition to the above mentioned locations.

Post back with what you find or don't find.

One reason for CRC errors can be trying to save a file larger than 4GB to a partition formatted using FAT32. Movies will usually be larger than 4GB.

Report •

February 12, 2012 at 16:00:26
Thanks OtheHill for your reply.

In Disk Management, the status of my ext disk shows as "Unknown 465.76GB Not Initialized". However, I can see my ext disk showing in Device Manager under Disk Drive and I can see the entry USB Mass Storage Device. I don't know why my ext Drive is not longer shown as E: drive in My Computer after performing the CHKDSK /R.

In short:
Before performed CHKDSK, the status of my ext hard disk is :
- My Computer: E: drive and correct name
- Device Manager under Disk Drive - shown the model name
- Disk Management - shown as NTFS
- Testdisk - green light of the partition (only one partition there)

- My Computer: disaappear
- Device Manager under Disk Drive - shown the model name
- Disk Management - shows "Unknown 465.76GB Not Initialized"
- Testdisk - shows Partition: Read Error
- Knoppix was used and it can't detect my ext disk, but it can detect my friend's ext disk and read the contents.

Can you please help further? Thanks.

Report •

Related Solutions

February 12, 2012 at 16:23:25
Try installing recuva and seeing if it can copy any files from the external drive.

You should always maintain at least 2 copies of any files you want to keep. There are many ways to lose data. You have discovered one.

Did you always use the safely remove icon in the tray before disconnecting the external? That is most likely what caused the original problem.

When you try testdisk will it let you proceed any further or just get read error and you can't go further?

Get recuva from the link below. You will need somewhere to copy your data. Do you know about how much data is on the 500GB?


Report •

February 12, 2012 at 17:51:13
Thanks again OtheHill for your help.

Most of the times I do use the safely remove icon in the tray before disconnecting my external drive. Sometimes, the system stops me from removing it directly from the tray because the system said that some programs were running and thus removing the disk is not possible (though I confirmed that I have closed all opened documents) - in this case, I just unplugged the disk, perhaps as you said, this is the cause of the original problem...

From testdisk, I got the read error when trying the analyze the partition. It still lets me to proceed by doing the Deep Search and it ran for hours and shows below:

- Disk /dev/sdb - 500 GB / 465 GB - CHS 60801 255 64
Analyse cylinder 1921/60800: 03%
Read error at 392/1/58 (lba=6297600)

Testdisk has given me the following results:

Intel/PC Partition

Partition: Read error; Quick Search? Y

Should TestDisk search for partition created under Vista or later ? [Y/N] Y
(answer Yes if unsure)

Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63
Partition Start End Size in sectors
No partition found or selected for recovery

Deeper Search? Yes

- Disk /dev/sdb - 500 GB / 465 GB - CHS 60801 255 64
Analyse cylinder 1921/60800: 03%
Read error at 392/1/58 (lba=6297600)

Since the deep analyse ran indefinitely, then I stopped it. On more note, in Advanced option (Filesystem utils), it shows "No partition available" and the repair function is no longer there.

Neverthess, as per your advice, I have installed the Recuva. However, it can't detect the external drive. In recuva, it only shows C drive, D drive (my internal harddisk drives) and the CD room drive. I tried a few options:
1. On my media card or Ipod / earch any removable drives (except CDs and floppies) for deleted files
> Result: No media card or Ipod were detected, please insert a card and press Retry
2. In a specific location
> I clicked the Browse button, but I can't locate the external E: drive.
I can't find the external drive from Recuva, Do I miss something there?

I have one question: In Disk Management, I got the message box
"You must initialize a disk before Logical Disk Manager can access it" Use the following partition style for the selected drive
May I know should I click yes to perform this? I afraid it will format my whole drive..

I cannot recall the used size of my external disk, but I think it may exceed 50GB.

Can you please help me further? Thanks.

Report •

February 12, 2012 at 19:58:59
You could try one of the file recovery programs listed below. If none of them can see anything then you have limited options. You could send the drive in for professional recovery, which is extremely expensive. I have one other idea but you need to provide some additional information first.

Hopefully you know the answers.

Below are some links.

PC Inspector (freeware)
Zero assumption Recovery
The demo is limited
It will only recover 'up to' four folders per run
But you can make multiple runs
not free

What file type was the drive formatted with? FAT32 or NTFS?

What is the make and model of the external drive?

Report •

February 12, 2012 at 21:26:21
Thanks OtheHill.

I will install the freewares and update my findings to this thread soon.. Btw, I don't know the answers, hopefully I can find the answer after sorting out with the freewares...

I think the file type is NTFS. The make and model is Samsung HM501II USB Drive (Probox Start Family).

Thanks again.

Report •

February 12, 2012 at 21:40:53
Did you format the external or did it come pre-formatted?

The part number you posted above is for a bare drive, not one in an enclosure.

We are talkingabout the external hard drive, correct?

Report •

February 14, 2012 at 16:19:59
Thanks OtheHill.

Zero assumption Recovery can detect my ext disk. It has run over 10 hours for volume analysis/disk scan but the task only completed 3%... Not sure if this is normal or should I be more patient? Nevertheless, I will wait until it completes and hopefully this task will end soon and I will post my update to this thread.

To answer your question:
Did you format the external or did it come pre-formatted?
- Yes, it come pre-formatted with NTFS. I never format it.

The part number you posted above is for a bare drive, not one in an enclosure.
- I am sorry that I don't understand the part number you indicated here. Can you please guide me further?

We are talkingabout the external hard drive, correct?
- Yes, it is external hard drive.

Report •

February 14, 2012 at 17:17:16
The number you provided is for a hard drive ONLY, not an external USB unit.

If you are sure that the drive was formatted NTFS with only one partition using all the space then you could partition and format it and then use recuva to recover or use testdisk to repair it.

If you elect to do that you use the quick format option. That will not write to most of the drive.

I don't think you can damage it any further than it is. If the recovery program you are using can recover your files then I guess you should continue with it.

Did you read the instructions. Most of those are not free and may find stuff but want you to pay before you can actually recover. Or you can only recover a fixed number of files at a time. Just read the particulars for each.

Report •

February 14, 2012 at 18:16:55
OtheHill, thanks again.

If there is no further progress from Zero assumption Recovery, I would consider to follow your instruction to partition and format my ext drive.

May I know how do I do quick format option and by using what tool to do this? Sorry if I'm asking a stupid question as I am new to IT stuffs... Thanks.

Report •

February 14, 2012 at 23:54:50
No need to apologize for your lack of knowledge. I understand that you are apprehensive right now. I am hoping for a positive outcome for you. One thing is certain, you will consider maintaining at least two copies in the future.

You can format the external when you are viewing Windows Disk Management. You probably will need to delete the existing partition and create a new partition before you can format the partition. You will be asked on the screen when you choose to format if you want to quick format or full format.

I say probably, because you have a screwy situation that you don't encounter often. The fact that no drive letter shows and most tools don't find any partition leads me to believe the only option you have is to delete the existing structure. I suggest you attempt to format it though. The option may not be available (greyed out). In that case highlight the listing and choose to delete. Then follow the process as I described above.

Right now all your files probably still exist on the drive. The partiton/file structure is so screwed up that the computer can't make it out. Quick format doesn't write zeros to the drive. I only removes the master boot record, which is already trashed.

Once you get the partition back to having some kind of structure the programs can recognize they may be able to read the files.

Even if you were to use FULL format there is still a chance to recover the files.

One additional point to make. It is best if the partitioning is performed the same way as the original was done. Windows 7 may want to actually make more than one partition even is you want only one.

Disk utilities you can download from the drive manufacturers site don't do that. Therefore it is best to do it the same way as it was done the last time.

That is why I asked you about this in a post above. If the hard drive was bought and an enclosure was bought and you assembled things yourself then most likely you partitioned and formatted it using Windows 7.

If you bought a complete assembled unit, it may have come partitioned and formatted. Possibly formatted FAT32. Windows 7 will not allow YOU to format a 500GB partition using FAT32 but 3rd party utilities will allow it. The disk structure will be totally different in each case. The chance of full file recovery is best if it is reconstructed the same as original.

Report •

February 10, 2013 at 15:53:59
hello,i have the same problem.Here is my story:
1.i have a wd external hard disc,and i cannot "see" some folders.So,i decided to have chkdsk.This showed me that there was no problem with my disc.
2.after that i had often connections and disconnections with me hd.(i used it on a netbook,windows 7 starter).
3.suddenly i had a message "You need to format the disk in drive G: before you can use it". i tried to connect it via other usb ports but i got the same.Then i tried to connect it to my macbookpro,which it did not "read" it at all.
4.then i connect it again to my netbook.it worked(flashing) but i cannot see it on my computer.
4.i open disc managment and i can see it as disc1 primary partition.
5.after that i disconnect it again and when i go to disc managment it disappeared.then i tried device manager, i can see it.
what should i do right now?
sorry for my english level

Report •

February 10, 2013 at 16:00:46

This post is quite old and piggy backing on any post is not the best way to solve your problem. I suggest you start a new thread here in the hardware forum. Supply as much information as you can about the problem.

Report •

Ask Question