January 9, 2009 at 06:13:03
Specs: Mac OS X 10.4.11, 2.16GHz Core 2 Duo, 2GB RAM
I've got an external HDD, Seagate FreeAgent 1TB. I'm using it with a late 2007 iMac.

While booted in Mac (I also have Boot Camp) the transfer rates are horrendously slow (about 10MB in a minute). However, when booted into Windows, with the exact same hard drive, USB port and computer, it pushes well up to the HDD's maximum transfer speed (about 25MB per second).

Why does this happen? It doesn't do this to my USB's or other external HDD...

Thanks in advance to any help with this.


See More: Ext. HDD WinXP=FAST Mac OS X=SLOW

Report •

January 10, 2009 at 08:25:17
There should be no difference regarding the max sustained data transfer speed the hard drive can achieve in the different operating systems, if everything is set up correctly in the operating systems.

Since your other external hard drive sounds like it is working fine (flash drives and memory cards typically have a much slower sustained max data transfer rate), there's probably nothing wrong with the way the MAC operating system is set up - something else is wrong regarding the one external hard drive.

It can be important which USB port you have the external drive,or any USB device, is plugged into - not all possible USB ports will yield the same results - or, rarely, you may have an IRQ sharing problem with your USB in your MAC operating system you don't have in the Windows operating system.
See response 3 in this:

Also - an external hard drive cannot get enough current (amperage; milliamps) through one USB port on it's own.
A 3.5" external drive must have a power adapter that came with it connected to the external case (is the power adapter working correctly?), or a 2.5" external drive must have connections to TWO USB ports on the computer end, one of which only needs to have two wires for USB power, or the USB connector on the cable with only two wires can be connected to a power adapter with a USB port that supplies 5v power with a decent current rating, such as one that can power an MP3 player.

Report •

January 12, 2009 at 00:51:28
It's a 3.5" external, and did come with a power pack, which works fine.

I've tried plugging it into all the available ports, but it still doesn't have any speed up.

I actually wanted to back up my Mac, and so used a program to back it up, while booted in Mac. This is how I realized that it had slow data transfer. I then booted into Windows (same internal HDD, external one in same port) and used a program to copy the contents of my Mac HDD to the drive. Intead of the estimate being over a day (on Mac), it only took about 1 and a half hours (on Windows).

I also noticed it was slow when trying to copy one file (a disc ISO) to the drive. I think some software in the Mac is interfering with the transfer speed, as I feel the hard drive head flicking back and forwards while transferrring in Mac, while in Windows it is smooth. Do you know of any apps that can tell me what is accessing the drive?

Even though you haven't solved my problem (yet), thanks for your very informative and quick reply. This is why I chose Computing.Net over other websites.

Thanks in advance for another possible solution,


Report •

January 12, 2009 at 09:26:00
"I've tried plugging it into all the available ports, but it still doesn't have any speed up."
See the referenced link in response 1 to nail down which USB ports are the best ones to use. Also, if you plug it into a hub of the type I mention, it MAY work fine when plugged in by itself into such a hub, but it may NOT when something else is plugged into the same hub.

If the subject external drive's speed is compared when it is plugged into the same USB port that is one in which it works properly in the different operating systems, then there must something else that is different.

- whatever operating system you load, you must load the driver files for and/or information about the mboard's hardware (main chipset chips, etc.) so that the operating system can operate the mboard as it was intended to run.
For Windows, that's straight forward - my standard spiel...
"Whenever you load Windows from a regular Windows CD (or DVD) from scratch, after Setup is finished you must load the drivers for the mboard, particularly the main chipset drivers, in order for Windows to have the proper drivers for and information about your mboard hardware, including it's AGP or PCI-E, ACPI, and hard drive controller support. If you have a generic system and have the CD that came with the mboard, all the necessary drivers are on it. If you load drivers from the web, brand name system builders and mboard makers often DO NOT have the main chipset drivers listed in the downloads for your model - in that case you must go to the maker of the main chipset's web site, get the drivers, and load them."

I know very little about MAC operating systems.
For a MAC operating system, what you need to load may also be on the CD that came with the mboard too, or you may need to go to the web site of the mboard maker and get MAC drivers for the model, etc., and load them and/or you may need to go to the web site of the main chipset maker and get MAC drivers, etc., and load them.

- all the hard and optical drives will often have a slower sustained and maximum data transfer speed if the operating system does not have the proper info about the drive controllers on the mboard.
- USB 2.0 has much faster max data transfer speeds than USB 1.x. All modern operating systems (since Win 95 OSR2 in Window's case) will automatically detect and support USB 1.1, but they may NOT detect USB 2.0 support automatically.
More recent mboards (since about 2002) have USB 2.0 controllers built in - they are backward compatible with USB 1.1 standards, so if your operating system recognizes the USB 2.0 controllers properly, it sees both USB 1.1 support and USB 2.0 support.
For Windows XP, it did not have support built in for USB 2.0 when it was first released - support for that was added when SP1 updates came out - but even if XP has SP1 or SP2 or SP3 built in, or added on after you run Setup, you MUST load the drivers and info (Windows main chipset "drivers" are often mostly *.inf files that tell Windows how to use the mboard hardware using support already built into Windows) for the mboard's main chipset, otherwise the operating system does NOT recognize the USB 2.0 controllers on the mboard and install support for them - the operating system sees only the USB 1.1 component of the USB 2.0 hardware on the mboard.
E.g. on a computer I have, mboard made about 2003, after the main chipset drivers and info for the mboard have been loaded, in Windows XP with SP2 updates, in Device Manager, under the heading "Universal Serial Bus Controllers", USB 2.0 controller support shows up as "Via USB Enhanced Host Controller"
The labelling varies according to the make of the main chipset on the mboard, but you get the gist,
The operating system must recognize the USB 2.0 controller(s) is(are) there and have the support for that installed in order for it to be able to support USB 2.0 data transfer speeds of USB devices that can use the enhanced USB 2.0 data speeds.

(the USB 1.1 controller support shows up there as four instances of "Via Rev 5 or later USB Universal Host Controller"

- you may be comparing apples to oranges regarding which programs you are using when you note how fast the data transfer speed is, and whether they are actually using the operating system or are booting into a different operating system in order to support the program. The support must be there to support the USB 2.0 capabiliities, otherwise the data transfer speeds will be that for USB 1.0 (the slowest standard) or USB 1.1 (slow).

"Do you know of any apps that can tell me what is accessing the drive?"

For a MAC operating system - NO. I know very little about MAC operating systems.

In Windows, there are third party programs you can use (e.g. Process Explorer, available on the Microsoft web site), and there are some things built into Windows you can use or look at. E.g. problems with a device MAY be flagged in Device Manager with a yellow ? (question mark) or with a red circle with a white X in it, and in System Information, there MAY be something on the left side under Components - Problem Devices

I don't know of anything that would affect the max data transfer speed of one external hard drive and not another external hard drive, if they are both plugged into USB ports they should work properly in, when compared in the same operating system using the same program, outside of one having a defective or inadequate USB cable.

Do you have other USB cables to try between the drive and the USB port? If one came with the drive, it should work fine, but if you had to buy it separately, it should be rated to support USB 2.0. A USB cable that is not rated to support USB 2.0 MAY work properly, but it MAY NOT - if it is rated to support USB 2.0 it will for sure.
It's not hard to damage USB cables, especially if you pull on the cord instead of the connector when you unplug them - try another USB cable if in doubt.

If the one external drive was always slower it could be the circuits inside the drive's enclosure are defective, or the USB cable is defective or inadequate, or the power adapter to the external case is not working properly, but since it appears it works fine in Windows, that's not your case.

Report •

Related Solutions

January 12, 2009 at 16:08:19
I've tried all of that, and there doesn't seem to be any improvement.

I don't think it's a driver problem as Apple makes sure that all its parts are integrated. Everything has appropriate drivers. Listed in system profiler is the USB ports, which are directly connected to the internal mboard, and they're listed as USB 2.0 (with appropriate speed when I use my other external HDD).

The way the HDD sounds when transferring data leads me to believe that the HDD is only achieving its maximum random write speed, as I hear it clicking a lot (therefore seeking a lot) when transferring data in Mac OS X. When transferring it in WinXP, it is quite smooth, and is probably just doing a plain copy. As I was copying the Mac files while in Windows, and it was fast, I think it's the OS interfering with something. Since you're not too experienced with Mac's (though incredibly knowledgeable with PC's!) I might take this to the Apple support discussions.

Thanks for all your help!


Report •

January 13, 2009 at 12:58:05
You're not "getting" it.

If there's nothing wrong with the external drive or the way it's connected, obviously there is something not right in the MAC operating system software configuration.

An operating system usually installs drivers for and knows about most of the hardware on the mboard because of what's built into the operating system, but it can't be relied on to always install everything correctly or know about everything, unless the motherboard is older than when the operating system version was first released, because the mboard may have hardware the operating system cannot detect, or cannot detect correctly, with what's built into it.

That's why you need to install the drivers for the mboard, especially the main chipset drivers, so that you make sure the operating system has the right drivers for and information about the hardware on the mboard, especially if the mboard is, say , newer than one year older than when the operating system was first released.

In the case of XP, it was first released officially 21st of October 2001. It could NOT detect the full size of hard drives or hard drive partitions larger than 128gb (binary size as seen in the mboard bios and in Windows; 137gb manufacturer's size); or USB 2.0 controllers because they had not come on the market yet; etc. etc. Support for those and other things were added via SPx updates, but most of XP has not changed significantly since it was first released. E.g. The Plug and Play Monitor settings were desgned primarily for crt monitors and only a few LCD displays that were on laptops at the time and they have not changed since.

It sounds like the external drive is running in a reduced capability mode, rather than a UDMA mode (100 or 133 for IDE drives, or 150 or 300 for SATA drives, mb/sec, max). In Windows that's called PIO mode. When a drive is in that mode, it tends to be accessed by the operating system a lot more, you hear more "thrashing" from the drive, and the ram cache on the hard drive is not being used or not being fully used.
That may be because the USB 2.0 controllers on the mboard are not being detected properly, or by some other problem, or a combination of things.

I can only suggest what to do or what to check for regarding Windows. You may need to post on a Mac or Apple forum somewhere if what I have suggested doesn't solve your problem.

Report •

Ask Question