Solved Error 173 AMD Graphic Card Driver

April 3, 2017 at 19:43:29
Specs: windows 8.1, Intel Core i5-6500 CPU 3.20GHz / 8.00 GM RAM
Hi i installed windows 8.1 recently and wanted to install the Graphic Card Driver but i was unable to do so because of the error that i got.it says

Error 173 - AMD Installer cannot continue Since AMD graphics hardware was not found.


See More: Error 173 AMD Graphic Card Driver

Report •

✔ Best Answer
April 4, 2017 at 11:18:03
Clean the edge connectors with a soft pencil eraser - there might be some near invisible oxide on them.

Always pop back and let us know the outcome - thanks



#1
April 4, 2017 at 01:19:08
It's possible you tried to install the wrong driver.

Please post your full system specs, including make/model of graphics card if not using the on-board GPU.


Report •

#2
April 4, 2017 at 01:45:32
Card is correct
Its a r9 380x , windows 8.1

I installed the correct driver


Report •

#3
April 4, 2017 at 02:22:19
Then it's either a dead card, or it's not connected properly which would mean the system (and the AMD driver) can't detect it.

Have you ensured that the auxiliary PCIe power cables from the PSU are connected to it? (usually two of them required for the R9 380X I believe).

If that's not the problem, then try reseating the card in it's slot.

message edited by phil22


Report •

Related Solutions

#4
April 4, 2017 at 09:32:24
Make sure the card is fully seated in the slot & has both 6-pin PCIe plugs connected. Also make sure the monitor cable is connected to the card, not the motherboard port. Check that the graphics setting in the BIOS is set to PCIe rather than onboard graphics. Here's your driver:

http://support.amd.com/en-us/downlo...

message edited by riider


Report •

#5
April 4, 2017 at 11:18:03
✔ Best Answer
Clean the edge connectors with a soft pencil eraser - there might be some near invisible oxide on them.

Always pop back and let us know the outcome - thanks


Report •

#6
April 4, 2017 at 14:31:55
"I installed the correct driver"

You may be trying to install the driver for your card but are you installing the correct bit version, IE. 32 bit vs. 64 bit.

Also, look at these articles, many issues like you're having, and some fixes -

https://www.google.com/search?sourc...

message edited by THX 1138


Report •

Ask Question