Solved Epson Tm-T88iib Centronics (parallel) port to USB

March 10, 2015 at 06:59:27
Specs: Windows XP
Hello Folks, my client has brought a new Thermal Printer but the port on it is different to the previous the new one has a centronics port where the previous printer had a 25 pin parallel.

the ports on the till are rj45 serial based com ports the previous printer had cables provided by the original till supplier that had cable the 25 pin plugged into the printer and a 9 pin on the other end plugged into another 9 pin which in turn had the rj45 serial on the other end. a thoroughly strange setup.

so at 1st i simply tried to buy a centronics port to a 9 pin to plug into the existing lead that connected to the rj45. no joy.

secondly i tried to use the lead provided with the printer along with a female to female 25 pin paralell gender changer
that look like this

<centronics port-----25 pin><gender changer><25 pin-------9pin><9pin-----rj45><till>

Suffice it to say that did not work.

so 3rd i purchased a centronics to usb lead and when i plugged this in the windows xp based prompted me to install usb based printing support from the XP Sp2 disc which i did.

I then installed the Advanced printer driver but the only drivers available were for the tm-t88iii and above.

the printer driver installed correctly but now the printer just says not available. when i tried to alter the port settings i got not avilable - offline. but when i switched the port settings back to thier orginal values i the printer/windows still reported offline.

please help im at my wits end.

this is a link to the till in question

message edited by Xallisto

See More: Epson Tm-T88iib Centronics (parallel) port to USB

Report •

March 10, 2015 at 17:43:10
✔ Best Answer
This "new" printer has a parallel port connection ; the previous printer had a 25 pin "serial" connection...

This is the manual:

I have rather vague memories of dealing with a similar situation to this about a year or so ago; but can't find my notes from then. However this link may be of interest?

Have you tried this approach using one of the three usb ports as print output?

The above example is for hp printers as listed; but I suspect it can be used as a model for your situation. In effect the process creates an "internal" network connection of sorts...?

Also have you seen/read this/:

And this approach may also provide a solution? It's one of/part of one of the replies I offered to a post here last year. It was with regard to a programme called Magic Box and printing problems thy were having. Those problems were not quite the same as yours; but there is common thread in the story nonetheless.

The way to get a programme designed to connect/print via a com port (and usually to a parallel port printer) is effectively to map the usb printer to a com port (typically Lpt1) and then use a command: "net use" which allows one to access that Lpt via a share option. The setup and syntax is simple and easy to follow.

Discussions not unsimilar to your previous and current situation:

Report •
Related Solutions

Ask Question