Epson LX 300+ prints gibberish

To be filled by o.e.m. / To be filled by o.e.m.
November 4, 2011 at 12:11:32
Specs: Windows 7, AMD Athlon X3 445/2GB
Hi, I have this weird problem with this printer, it was working fine on a PC with Windows 2000, after reformatting and installing Xp it only prints gibberish, I installed the Epson dirvers for it (even though winxp includes drivers) and the status monitor reports there is a connection error and that I should check the cable. I have tried reinstalling the printer, different cables and different drivers (epson's and windows') to no avail, any help would be appreciated...

See More: Epson LX 300+ prints gibberish

Report •

November 4, 2011 at 23:26:04
is it connected with usb or lpt1 port....the older style?

Report •

November 5, 2011 at 02:45:17
Hi pb600,

With a parallel connection, when one (or more) of the data wires are broken, wrong characters are printed. Did you disconnect/distrub the printer when installing wxp?

If yes, and printer is connected to the lpt1 port:-

a) I would first suspect one of the data wires in the cable.
However you say you have tried other cables.

b) To be on the safe side, prove the original cable is ok on another pc.

c) view the the connections (pins) with a torch, in the pc and printer sockets.
Possible one of the pins has become misplaced.


If the printer is connected via a com port, the settings (speed, data bits etc.) for that port should be checked, as they may have to be set to match the printers serial port settings.

Check same if connected using the LPT1 port.

Is the Epson emulating another printer? e.g. IBM Graphics.

Right clicking on printer/properties in control panel should show current os settings.

Please advise back on progress.

Good Luck - Keep us posted.

Report •

November 5, 2011 at 07:36:09
LX 300+ (home support page)

Parallel or serial connected (some models may not have the serial port).

User manual


"Q: Why does my printer print garbage from MS-DOS and Windows?

A: When a printer prints garbage, it usually indicates a faulty cable or a loose connection. Power OFF your printer and computer. Disconnect and reconnect the cable on the printer and computer. Once the cable has been reconnected, power the printer and computer back ON. Try printing from MS-DOS. If you are still getting garbage, change the cable. We recommend getting a fully shielded cable, preferably 6 feet or less in length. If you are still experiencing problems after changing your cable, you may have a computer or printer port issue. If you take the cable and printer to another computer and it works fine, have your computer's port checked by an authorized dealer. If it still gives you garbage from another computer, have the printer taken in to be serviced."

If you can try it with a different computer, try that.
If that computer has a built in printer port, check the parallel port mode in the bios (see the info below).If it has a PCI parallel port card, see the info below.
If the printer doesn't work properly with the other computer with the same parallel cable that worked fine previously, the parallel circuits in the printer are damaged.

If your model has the serial port too, try connecting the printer via that rather than the parallel connection. See the User manual.

If it's connected to a parallel port built into the mboard, the printer mode in the bios probably MUST be set to EPP, ECP, or EPP / ECP mode. Usually EPP mode works fine. ECP mode requires that there is a dma channel available - it may not be - you may be able to select one of more than one dma channel when you select ECP. The printer probably won't work properly if that's set to Standard or Bi-directional mode.

If it's connected to a PCI parallel port card,
- the card already supports one of those modes or both modes.
- don't install the card in the last PCI slot closest to the center of the mboard. That slot usually shares it's IRQ with the video and if so only PCI video cards are likely to not have problems when installed in that slot.

- the card may have a poor connection in it's slot
- make sure the card is all the way down in it's slot
- try removing the AC power to the case, removing the card, cleaning it's contacts with a tissue or soft cloth, installing it again.

You probably must use a parallel cable rated to support the IEEE1284 standards.
Use a cable that has IEEE1284 printed on the cable itself or on the end connectors. However, a cable that has individual wires that meet or exceed the minimum wire gauge for the IEEE1284 standard will work fine. The wire gauge is often printed on the cable, e.g. AWG xx - the lower the gauge number, the greater the diameter of the individual wires, the more likely it will work fine.

Parallel connections are NOT "hot pluggable". NEVER plug in or unplug the parallel cable when the computer is running.
Doing so can damage the circuits for the parallel port or the printer or both.

"after reformatting and installing Xp"

You MUST install the main chipset drivers for your mboard after XP's (or 2000's) Setup has finished. The main chipset drivers have *.inf files that tell the operating system the capabilities of the main chipset and if Windows does not have that info you're likely to have problems. If your mboard has USB 2.0 controllers the support for them and USB 2.0 devices is only built into Windows when it has SP1 or later Windows updates, and that built in support is NOT installed until AFTER the main chipset drivers have been installed.
(2000 must have SP4 or later Windows updates installed to have the built in support for USB 2.0 controllers and devices.)

" I installed the Epson dirvers for it (even though winxp includes drivers) ...."
" I have tried reinstalling the printer, different cables and different drivers "

You must un-install the Epson drivers in Add or Remove programs BEFORE you install them or other drivers again.

If you use the built into XP Epson LX 300 or 300+ drivers, you must manually select them. (If LX 300+ is not listed, the LX 300 ones will probably work fine, according to someone else who posted here who has a LX 300+.)

Whichever drivers you use, if you re-install the drivers, delete the printer model listing in Control Panel - Printers and Faxes BEFORE you re-install the drivers. (Un-installing the Epson supplied drivers may or may not do that automatically.)

Report •

Related Solutions

November 5, 2011 at 09:49:47
Hi! Thanks everyone for your replies when I reinstalled the OS on the pc I disconnected the printer and maybe something went wrong with the cable or something... I have tried different cables but the behaviour is the same... anyway I have two oldies to try on the computer: an epson T1000 and a canon BJC 250. So I will know if the connection is working correctly or not. I also have another desktop (AthlonX2 5000+) that is old enough to include the LPT1 port... I'll also try checking the coonfiguration as you suggested. Thanks again! I'll keep you posted

Report •

November 5, 2011 at 11:48:49
"a canon BJC 250"

The drivers for that are built into XP but you have to manually select them.
You have to do that for any parallel connected printer it has drivers for because they're not Plug-n-Play detectable.

The BJ-2xx and BJC-2xx and BJC-4xxx series are extremely reliable, although I stopped using the silly color / black cartridges for the color print head in my BJC-4400 long ago and use only the BC-20 black cartridge for it. I have refilled the black cartridges for the 2xx and 4xxx series many times, getting as many as 12 refills before the print head on them gave out.

The Canon drivers for them for ME / 98SE and 98 / 95 ? are better than the ones built into Windows but they can't be used in XP, and probably 2000.

Most of the models if not all of them can be set in their Properties to power on automatically for a print job and shut off after xx minutes of inactivity automatically. The BJ-2xx and BJC-2xx series at least could do that in Dos too.

I have rescued maybe a half dozen or more of them from being thrown out and gave them to mostly people who had not much money to spare. The only ones that have failed (3) since (the printer that is) were damaged by a power surge or voltage spike (1 ?) or by the user plugging in or unplugging the parallel cable while the computer was running (2 ? - the same guy twice for sure- duh ! ).

I also have the color scanner cartridge IS-22 for the BJC-4400 - 300 dpi, slow to use, but it works fine.
I bought the BJC-4400 on sale and the scanner cartridge in Dec. 1999 and it was my main printer and after I started using XP my only printer since then until recently. It came with a color print head / cartridges (tanks), the scanner cartridge was 1/2 off ($75). I got the black cartridge free by sending away a coupon that came with Canon paper that I bought separately at the same time.
I've refilled the color / black ink tanks for the color print head but gave up on that (I wasn't using that print head often enough - it clogged often), and have refilled all of the BC-20 black ones. I've only had to buy maybe 4 BC-20's.

I also have a Canon Pixma ip4200, about six years old, I've had it for a year and a half, it's one of the last ones Canon made that still had / has 98SE / ME drivers available for it.
I refill it's cartridges (5; tanks) and have a chip re-setter for them. I've done that since it was new, before I had it for a friend. In total, fewer than one set of new cartridges (ink tanks) have had to be bought (it came with a set of them).

My brother and sister used a BJ-2xx model for many years. My brother is still using a BJC-2xx that I rescued from being thrown away for his secondary printer (black cartridge only).

Report •

November 10, 2011 at 04:46:42
Hi, I have installed XP on another machine and te printer continues to print gibberish. So I guess It is not a computer issue. I also tried different cables and it is the same. Is there a chance that something is wrongly configured on the printer? Thanks

Report •

November 10, 2011 at 07:44:08
"Is there a chance that something is wrongly configured on the printer?"


Use the support info link in response 3..

Some dot matrix printers have switches that must be set correctly - look in the manual - but it you weren't fiddling with that the printer has probably been damaged by something you did or an external event.

Report •

November 11, 2011 at 01:46:18
Hi pb600, am I correct in:-

a) the LX300 prints gibberish, when used with different interface cables.
Same when connected to a different pc which also has WXP.

b) you have *NOT* advised what happens when you tried connecting a different printer(s) to the original pc on which you installed WXP.

c) Have you tried the LX300 on a pc that does not have wxp?

yes for (a)
for (b) the the other printers worked
for (c) the LX failed

this does suggest the fault is in the LX printer.

You advised you disconnected the LX (interface cable?).

a) if this was done when the power was *ON* at *EITHER* end, it could have damaged the printer circuitry, particularly around the parallel port area.

b) possible something inside the printer has moved that is causing the problem.
(staple, paper clip, paper chad (from tractor hole))
I would remove the top cover to check, and blow out any muck *CAREFULLY* using a hair dryer set to cold and maximum blast, using a long thin brush to assist.

Good Luck - Keep us posted.

Report •

November 11, 2011 at 09:56:31
Hi, look, I have tried the LX on two pc both with fresh installs of xp, I will try win 2000 and win 7 in the coming hours. I have discarded a pc or cable issue as an epson T1000 (much older but in perfect condition) worked ok.
More info:
This LX is very dirty so I'll clean it and see what happens
I didn't disconnect the cable with either the pinter or the pc on
The lx's self test ran OK
The printer not only printed gibeberish but It also did it continuously and beeped in the process. After some driver reinstallation and trying different fonts on it I has stopped beeping and prints one page and in the correct location, the problems is that the characters are wrong (nunbers and other rare characters)

If cleaning or other OS (I'll try Linux too) don't help I'l ditch it. Thanks for your help

Report •

November 11, 2011 at 12:38:17
Your symptoms are very similar to those for the three malfunctioning Canon printers I mentioned in response 5.

Report •

November 12, 2011 at 06:05:10
Yes... I'll try a couple more things and If it doesn't improve...

Report •

Ask Question