Solved Epson 420 copies but does not print

February 6, 2017 at 16:52:42
Specs: Macintosh
This is my second epson 420 that I'm having this same problem with. It makes photocopies just fine. However, when a job is sent to print, it sends the paper through as if it is printing, but images are not printed out. I'm hoping there is a simple setting change that needs to be made. Ink cartridges do not need to be changed. Computer and printer has been turned off and back on. Printer attempts with multiple printers and devices.

See More: Epson 420 copies but does not print

Report •

#1
February 6, 2017 at 17:29:38
I assume you have installed the printer driver for this printer?
Drivers are here to download, just in case:
https://epson.com/Support/Printers/...

Report •

#2
February 6, 2017 at 21:00:49
Sometimes uninstalling the printer and reinstalling it using existing driver clears up weird problems.

You have to be a little bit crazy to keep you from going insane.


Report •

#3
February 7, 2017 at 03:05:01
✔ Best Answer
Yes, that's usually a driver issue, as the driver isn't required when using the printer purely as a photocopier (the photocopy function works internally without the computer), but the driver is required for printing via your computer.

As already mentioned above, the driver may be corrupted so a re-install of the Epson driver software should fix it.

I once had an Epson printer/scanner and I remember having to re-install the Epson driver software several times when it stopped responding, but photocopy function worked fine.

Must be an Epson thing 'cos my Canon all-in-one never gives me any problems.

message edited by phil22


Report •
Related Solutions


Ask Question