DX58SO won't post :(

Intel Dx58so desktop board
July 25, 2010 at 15:37:32
Specs: Windows 7
So i ran an auto tune on the latest bios and the latest version of IDCC (intel desktop control center) i decided to do a 4-8 hours auto tune while i was @ work i come back from work my pc is on with all fans running but no video output and with no power going to anything (mouse or keyboard) i restart and i get the samething , then i reset the power supply again samething, so then i try switching the bios to configure mode but still nothing, finally i set the bios to recovery mode and when it is in that mode i can get power to the mouse but nothing else.
PC stats
8 gigs of XM3 DDR3 @ 1600mhz
ATI 4870 2X
i7 980
1100 watt Tagan BZ PSU
Intel SSD 80gig
2 Velocirapters 300 gig hard drives raid 0

My mobo will do the 3 beeps with no memory
tried several different types of memory
Cleared Cmos multiple times
i have switched to different CPUs, different graphics cards
basically i have narrowed it down to just the PSU or the MOBO being bad
I am wondering which part is bad so i can repair my PC.

Also something strange sometimes after switching the PSU back on i can't get the computer to start by pushing the power button it just sits there then i mess with the PSU switch and power button and then it will start.
Any help would make my day because im so frustrated!!! Thanks

See More: DX58SO wont post :(

Report •

July 26, 2010 at 20:39:26
My guess, if it was updating the BIOS, is that it was interrupted while flashing the BIOS. This can be fixed by putting the BIOS jumper in recovery mode (which you did) and connecting a USB Flash drive containing the .BIO file for your motherboard. The recovery BIOS will automatically re-Flash the BIOS, and either shut off or tell you to turn it off (older ones will generally turn off). Afterwards, just replace the jumper and power back on.

General instructions:


Latest .BIO for your motherboard:


Report •

December 7, 2010 at 19:15:29
Were you able to resolve this issue? I had the exact same thing happen when I tried to run the IDCC Auto-tune. I have a DX58SO, i7-970 (tried my working 950 too), and an intel SSD. I've wasted my entire day on this, which is a bad deal during finals week.

Report •

January 8, 2011 at 18:28:50
Your board is dead. I've killed two boards doing the same thing. I7-970 with DX58SO. Everything worked fine till I started IDCC. It acted like it was going to work. It went to reboot and "poof". Dead board. I had a NIB DX58SO and replaced the one that fried. Got it put together with just 1 hdd and 1 HD4870. Fired it up and everything worked fine. Threw my other HD4870 in. Threw my 2 80g Intel SSD's raid 0 back in. My X-Fi Titanium back in and everything ran fine. Started IDCC a 2nd time and "poof"!! Dead board. I never had this problem when I had an I7-940 in there. Or an I-7 920 in there. They both overclocked just fine with IDCC. It only happened with the 970. I will not be using IDCC till this gets ironed out.

Report •
Related Solutions

Ask Question