DVD-Rom has no electrical power after it failed to read disk

Toshiba / Satellite l500
March 15, 2012 at 09:14:40
Specs: Windows 7, 2.2 GHz / 1912 MB
I recently encountered a problem with my DVD drive. It refused to read any dvds or cds. I kept trying to insert new disks and the green light would just flash and nothing would happen. I tried the "run" function and also tried to play it from the "computer" menu in windows 7. I checked if my driver was still ok, and it there is nothing wrong with it.

So I continuously tried to insert new disks - it refused to read ANYTHING. It eventually became totally dead with no electrical power (seemingly - light not flashing anymore, won't react when pressing on the eject button). So I pushed the manual override button with a paperclip (in the little hole) to remove my last dvd.

I did nothing that could damage the drive (except leaving disks in there - which is apparently not good). I have an excellent anti-virus program and I have SpeedMaxPc installed which fixes any other problems -not this one though.

Please tell me you know what's wrong and what to do to fix it! Thank you.

See More: DVD-Rom has no electrical power after it failed to read disk

Report •

March 15, 2012 at 09:35:55
In Canada, I reach into my wallet at the local computer chop shop and buy another one for $35, not sure where you are. What you describe sounds like a classic hardware failure. You can check to make sure the cable is plugged in good (turn it off first) and swap out the power connector with another one from the power supply to rule out a defective power supply, but me thinks it is more likely time to get another one. Nothing is made to last...Hard drives used to have 5 yr warranties....now going back to 1yr. Your issue is most likely the drive or the power supply, both are an inexpensive fix relatively speaking.

Report •

March 15, 2012 at 09:55:44
I am in South Africa. I'm not sure how to check if the cables are connected on a laptop? It is definitely not the power supply because I'm working on the very same computer on which the DVD-rom won't function, at this moment.

Report •

March 15, 2012 at 14:09:14
"I have an excellent anti-virus program"

Why didn't you mention it by name?

"and I have SpeedMaxPc"

I highly suggest you uninstall that piece of garbage as fast as you can. I hope you didn't pay for it? It's a ripoff & a scam.


Report •

Related Solutions

March 15, 2012 at 15:43:19
#2 so it is a laptop from the tags Toshiba Satellite l500

Remove the drive and re-insert it, if still no joy then either the dvive is faulty or the connector is faulty, the connector is directly soldered to mainboard, Laptop do not have a cable.

Googling is quicker than waiting for an answer....

Report •

May 2, 2012 at 00:40:50
SpeedMaxPC is definitely a ripoff! I paid $29.97 for a download with a 60 day 'satisfaction guarantee' refund policy -- WHAT A JOKE! This program deleted way too much stuff from my computer and I uninstalled it after 3 days and requested a refund. Twenty plus days later I'm still fighting for a refund! I finally filed a complaint with PayPal against this company.

BURN ME TWICE, SHAME ON ME! - I should have learned my lesson by now.

Report •

Ask Question