Solved DVD Drive Failure? Help Appreciated

October 11, 2013 at 15:18:57
Specs: Windows 8 64-bit, Intel i5 2.60GHz
Hi everybody,

I have not been active on this forum in a long while--I hope that you all are well.

I recently purchased a new laptop, Asus A55VD-NS51 (I've had it for about a week).
Things seemed to be working fine, I've installed my needed programs, and then I realized the CD/DVD drive is not present.
When going into Device Manager, the drive has a yield sign exclamation point and further information states the following:

"Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)"

The drive is TSSTCorp CDDVDW.

I thought this perhaps had to do with running the registry cleaner feature in CCleaner, so I restored the registry backup files made by the application. This did not resolve the problem. I then ran the Windows (8) Troubleshooter and attempted to resolve hardware problems. This did not resolve the problem.
Then I uninstalled and reinstalled the driver. This did not solve the problem, either. I also tried running system restore to a recent restore point, but this did not fix the problem either.
So, I rebooted into the system BIOS, to see if the drive showed up there. It did not (See attached image). Though, I did not have a disc in the drive.
I reset the BIOS settings to the factory defaults and rebooted back into the BIOS, this time with a disc in the drive. At this point it did recognize the SATI disc drive in the bay.
I'm not too familiar with UEFI and Windows 8, in general, it's all pretty new to me--so I'm wondering this: If I have no disc in the drive, will the BIOS not display any information about the disc drive, or does their need to be a disc in the drive to access the settings for said drive? The reason I ask, is that if the drive is failing or has a hardware problem, I should return it promptly.
I purchased this laptop from Newegg as an open-box item, and as such, it has a 30-day return policy. Perhaps this was a mistake, or an adventurous decision on my part.
Could the drive be failing or is this more than a likely a software-specific problem?
I'm not even certain exactly how I could boot into live USB Linux to see if things are working in that more familiar environment. I tried to do so first thing when I received the computer, but it wouldn't boot the flash drive, and I haven't had a chance to pursue the matter further.

So, do you think this laptop is toast?
What steps should I try next?

Any input is enormously appreciated.

See More: DVD Drive Failure? Help Appreciated

Report •

October 11, 2013 at 16:15:35
✔ Best Answer
Hi everybody,
After spending a great amount of time trying to resolve this problem, I think it may be solved.
It appears that this is a Windows error (Possibly from running Windows update?). They have a
patch tool for it, I will link it below, in case anybody else encounters the same problem and comes across
this thread.

Thanks for looking.

Report •
Related Solutions

Ask Question