Dropped 2TB external HD went from NTFS to RAW

February 27, 2011 at 13:18:43
Specs: Windows Vista, AMD Athlon X2 2.1 GHz
I have a 2 TB external HD partitioned to 1 TB and 862 GB. Dropped it and it went from NTFS to RAW for both partitions. I can still see it under my computer but under disk space its blank. If I go into Disk Management I can see it and its listed as RAW. I hav e poked around a little and found thatthis means the partition is corrupted or the boot record is corrupted. I have tried EASUS Data Recovery Wizard 5.0.1 but it doesn't see my files, takes too long(almost 48 hrs) and then seems like it finishes abruptly. Their company offered another program of theirs, EASUS Disk Copy 3.2 but when I copy the .iso file from this program to disk, I am still unable to boot from the disk so I can't use the program to troubleshoot it. I have windows vista home, 3 BG of RAM, an AMD Athlon X2 Dual Core QL 64 2.1 GHz, 32 bit on an ACer Aspire laptop. Thanks, Vic

See More: Dropped 2TB external HD went from NTFS to RAW

Report •

February 27, 2011 at 13:30:43
Try repairing the partitions using Testdisk.

If you can't repair them then use Recuva to copy the files to another location.

Get both at the links below. Be sure to read all the documentation for testdisk BEFORE attempting to use it for best results.



Report •

March 13, 2011 at 10:36:01
Finally had a chance to try Testdisk. it correctly saw my HD size, 2000 GB but i was a little confused about disk geometry. i ran it under the default size 512 i believe, and after scanning for a few hours, i goit this message:

Disk /dev/sdb - 2000 GB / 1863 GiB - CHS 243201 255 63
Partition Start End Size in sectors

Structure: Ok.

Keys A: add partition, L: load backup, Enter: to continue

Now I'm back to the beginning. did i do something wrong or do i need to chnage the disk geometry in the search somehow? Thanks, vic

Report •

March 13, 2011 at 10:47:02
Installed Recuva and selected the correct drive but I get an error message, "H:\ is not accessible.

The request could not be performed because of an I/O device error."

This is the same error message I get when I try to access it under My Computer. Any thoughts?

Report •

Related Solutions

March 13, 2011 at 13:34:47
I am not sure but I think you let testdisk recover as ONE partition. You still may be able to do something with it. The problem right now is that the partition may not be marked as active. That is necessary in order for Windows to access it.

Look in Windows Disk Management and see what shows there.

If you were able to get as far as you did may be a good sign.

Report •

March 13, 2011 at 15:05:09
Went to Windows Disk Management and right clicked H:/ and selected Mark Partition as Active. After a minute or so I get an error message "The drive cannot find the sector requested". Both drives are marked as Healthy (Primary Partition) but they come up as RAW drives. So I'm back at square 1.

Is it possible for me to get an image of the drive or will I get the same I/O error message? I even took apart the enclosure to see if there was something disconnected. Nothing obvious was disconnected. I don't want to open the actual HD, besides, theres a different kind of screw holding it together cuz I was thinking about it but I don't have the correct screwdriver.

Saw another similar situation where a guy used Knoppix to image his HD. Should I try it? Any thoughts? thanks for trying to help

Report •

March 13, 2011 at 19:48:48
You could try testdisk again. You need to read the tutorials better than you did the first time. You had two partitions initially, that is what you need to reconstruct if possible. Not sure if it is at this point.

In the meantime have you tried looking at the drive with recuva?

Report •

March 13, 2011 at 20:19:34
I'm sorry, I meant to say "partitions". Windows Disk Management sees both partitions (H:/ and I:/) that are on the external HD and it sees the correct sizes of both partitions. Both H:/ and I:/ still show up as RAW however.

I'll try Testdisk again but in the instructions it doesn't give good details about "disk geometry". As soon as I'm done running it , both H: and I: that were visible in My Computer previously, except for their respective sizes, now disappear completely after Testdisk completes its scan. If I shut off the external HD and start it up again, it reappears in My Computer. I'll try Testdisk again and try something different regarding gemotery I guess.

Would Knoppix be applicable to my problem? Thought I had read on another thread that another guy had ac similar problem and Knoppix worked for him.

Report •

March 13, 2011 at 20:35:02
Knoppix is strictly a recovery vehicle. Recuva will work much easier for that purpose though.

Try testdisk on ONLY one partition at a time if you can.

Have you tried using recuva. There is no harm in trying it. I think you will be overwhelmed by the shear number of files it finds. That is the problem with using it when large volumes of files are in play.

Look at the link below which is step by step instructions for testdisk.


Report •

Ask Question