Asus,acer,samsung,hp / [any]
June 26, 2015 at 03:13:06
Specs: Windows 8, [any]
Hello. I have this laptop (UEFI mode) that when turned on, shows blue screen with error: DRIVER_VIOLATION.

I suspected first that it is a software issue. I tried to load the windows setup from USB and boot to it, but when setup shows, it shutdowns unexpectedly with same error DRIVER_VIOLATION.

On BIOS settings i tried switching to Legacy BIOS mode. Tried to turn it on, (but since OS installed is for UEFI, it does not boot properly) and then switch it back to UEFI. The problem will be resolved and I can use my PC again.

But sadly, for the next few times I will turn it on, it will again and I have to switch it UEFI to LEGACY BIOS over and over.

This started to happen when I installed AVG and a recent Windows Update. What do you think is the problem? Should I blame AVG or Windows, or Acer?

SPECS: Acer Aspire v5-471, Intel core i3, Windows 8.1


Report •

June 26, 2015 at 03:17:03
Copy & Paste the dump (.dmp ) file onto your desktop & then upload it using ZippyShare. No account/registration needed. Post the link please.
Instructions on how to use ZippyShare.
Minidump file is located in C:\Windows\Minidump
How to see hidden files in Windows

Report •

June 26, 2015 at 03:24:08
Do a system restore to remove the update and avg in safe mode also repair your pc using F8 option!

Report •

June 26, 2015 at 04:02:06
Hello Johnw, It seems that C: \ Windows \ Minidump is empty.
The bluescreen only displays "DRIVER_VIOLATION" but does not dump it. It shuts down abruptly.
The way I did to see that details is taking a video using my phone, and pausing it during the bluescreen.

Report •

Related Solutions

June 26, 2015 at 04:37:55
"Hello Johnw, It seems that C: \ Windows \ Minidump is empty"

Please download Farbar Recovery Scan Tool and save it onto your Desktop. If your default download location is not the Desktop, drag it out of it's location onto the Desktop.
If we have to run Farbar more than once, refer this SS.
Note: You need to run the version compatible with your system. If you are not sure which version applies to your system download both of them and try to run them. Only one of them will run on your system, that will be the right version.
Double-click to run it. When the tool opens click Yes to disclaimer.
Press Scan button.
It will make a log (FRST.txt) on the Desktop.
The first time the tool is run, it makes also another log (Addition.txt).
The logs are large, upload them using Zippy ( No account/registration needed ) or upload to a site of your choosing. Give us the links please.
Instructions on how to use ZippyShare.

Report •

June 26, 2015 at 05:00:18
DRIVER_VIOLATION obviously has to do with a driver (or drivers). What driver have you recently installed or updated? To get your computer to boot, unplug the power, remove the battery, then push & hold the power button for at least 20 seconds. That will do a hard reset. You should then be able to boot into Windows. Once you get in, do a System Restore to a date before the problem started.

Report •

July 7, 2015 at 05:41:16
I think I can help here-as I covered a high level generation of this error through my autoexec.bat file immediately after call lockdrv.bat.[IF %%root.==echo. > nul] ina post yesterday.

You will need a boot disk with a 16 bit debugger-dont use a 32 bit debugger as it is system interrupts.The page fault 16 bit as the general protection violation is as well [286 flat model error] .If you fear pointers through 32 bit interface you will have to write your program in databytes

It actually ocurred as a keyboard interrupt via and adaptec.sys.

I debugged this last nite and found the errors by debugging the following interrupt INT 0C and INT 0D.On my system tehre are two errors with one extended error in INT OC [INT OA] .This is casued by a USB FOSSIL device . INT 14 will remove this but you have to decalre BX as well as DX and not just DX as Ralf Brown says.

mov ah,xx ;too disable Fossil Drive]
mov bx,0f0 ;to declare hardware interface
mov dx,2f8 ;to declare the port
int 14
int 21

I reexamined and the INT 0A error went away.The other two errors are INT 0C anf INT 0D.One is a page fault and the other is a general protection violation.I actually used the proceed and go to confirm the new vector as accurate through the old vector and so must revector.Since I was up all nit last nite-I did not have time this morning for this.I will be doing that tonite.
This will require revectoring to which is through int 21 once you get the proper addresses from a trace of the BIOS interrupts. Trace is better for aquiring addresses than proceed-as those vectors have to be removed before revectoraization.I am hoping that this will work-this is the page fault[stack fault at 0000-0040] and that the general protection violation fault is what I am unsure about.

Report •

July 8, 2015 at 06:37:12
I actually examined the system-it is an INT 90 call with a lock prior to which means that a word ptr is prevented via int 90-to which redirects keyboard and com 1 and irq 5.I filled this in with a nop and this all went away after debug reported a divide by zero error and to contact customer service if it continues.Well Microsoft is definitely not a dos system anymore but are into washing windows----however the triple IRQ conflict is still present.

message edited by Vilhjalmur

Report •

Ask Question