driver for trust scanner 19200

July 20, 2010 at 09:41:05
Specs: Windows XP
hello. my trust scanner is not able to send an image to the pc. It didnt connect at first but i downloaded the right driver for the scanner at trust website. the pc now regonzies the scanner but does bot see an image to scan.

it says no image application can be executed

does anyone know how i can get my scanner working again?

See More: driver for trust scanner 19200

Report •

July 20, 2010 at 13:41:11
If your scanner is a USB type, you'll have to uninstall the driver software, unplug the scanner from the computer and start over.

If you leave the scanner plugged in while loading/updating the drivers, they will install but the scanner won't work right.

After doing above, wait until the install asks for you to plug in the scanner, otherwise you may have problems.

Just be glad it's not an HP scanner. You'd have to go thru the Registry and delete entries before you could get the thing working again.

Chuck Norris was once asked why he doesn't use an iPhone, he responded, "Same reason I don't use tampons."

Report •

July 20, 2010 at 15:32:51
thanks for replying.

after ages trying to figure out how to delete the device driver i finally figured out
when i clicked on imaging device and go to uninstall the scanner driver it stops me and says failed to delete may be needed for rebooot of computer. i tried installing the drivers from the trust site again but to no avail.

Report •

July 20, 2010 at 15:43:58
Get the free version of this program and see if it can get rid of it. May have to be done in the Safe Mode and make sure there is nothing in the Startup tag under "msconfig" or you won't be able to delete all the parts of the driver.

Chuck Norris was once asked why he doesn't use an iPhone, he responded, "Same reason I don't use tampons."

Report •

Related Solutions

July 21, 2010 at 08:42:41
ok i tried the uninstaller and its great to clean up the junk from my pc aswell,so thanks.

I was about to say here that after hours of trying,installing ,uninstalling (theres two downloads on the trust site and you have to download them in a specific order,

i wasnt sure which so tried it both) and jumping from safe mode and back that im giving up ,when i press the scan symbol on the task bar i still get the message no image,but have just discovered pushing the button on the scanner and going through windows now works and i can import an image. Wahay! so at least it kinda half works.

thanks for the help guys.:)

Report •

Ask Question