D-Link DFE-690TXD PCMCIA problem

January 17, 2010 at 15:58:38
Specs: Microsoft Windows XP Professional, 2.393 GHz / 1021 MB
So I have this old Thinkpad 760ED (I think it's model is from 1996) and I want to get internet on it, so I buy a wired Fast Speed PCMCIA Ethernet card from The Source. I installed the drivers from the disc and re-booted. The link light is up and the cable's plugged in, but I can't get the internet to come up on IE. So I put in the addresses manually at the network properties, same problem occurs. I checked the IPconfig command on DOS and surprisingly it said all zero for the address numbers even if I put ones in manually. But the IPconfig only shows Ethernet 0. Is it only detecting the Dial-Up card built-in? One more thing, when I try a website, after it says the page could not be loaded, Internet Explorers Browser title says DNS error at the end of it. Could that be a problem also?

Thanks in Regards!


P.S. I made sure the card is COMPLETELY compatible with the slot and the Win98SE version. All my drivers are also up to date.

Computer=IBM Netvista
CPU=Pentium IV 2.4GHz

See More: D-Link DFE-690TXD PCMCIA problem

January 17, 2010 at 16:51:34
D-Link often has more than one revision of a particular ethernet card model - if more than one is listed, make sure you install the drivers for the proper revision.

If you weren't using the PCMCIA slot before, you must have all the main chipset drivers for the laptop chipset installed in order for the PCMCIA slot to work properly. Get them from the Lenovo web site in the downloads for your model if they're there (they may not be) , or from the Intel web site for your laptop chipset, and load them, even if you're not sure whether they have been loaded.

If you weren't using a PCMCIA ethernet card before, only dial-up or had no connection, you must run the Internet Connection wizard.
E.g. in IE, select the Tools button at top, Internet Options, or in Control panel, select Internet Options - Connections tab - click on Setup at the top, etc.

When you install the ethernet card drivers, 98SE should have copied network related files from the 98SE CD. If the CD isn't in a drive you are prompted to insert it. Sometimes that doesn't work properly, and you have to install the drivers again in order for 98SE to do that correctly. You may need to un-install any listings for the drivers in Add/Remove Prgrams, and Remove the card's entry in Device Manager before the driverswill install properly and load the required Windows files.
If you get a message Windows can't find a file on the CD, 98SE and previous "forgets" where the Windows files on the CD are sometimes - the default path is wrong in that case. Sometimes you need to point it to the proper folder on the CD \win98, and/or to the proper drive letter.

When you look in Control Panel - Network, there should be listings for the card model. If that isn't there, the network related windows files were not installed along with the drivers.

Report •

March 6, 2010 at 12:59:50
I found out what the problem is. The card didn't only say PCMCIA on it, but it said CardBus, apparently CardBus is a whole different type of works than PCMCIA although they look identical there is a difference. CardBus is 32-bit and PCMCIA is onlt 16, thus the slot cannot run 32-bit cards. Thanks for all the information though!

Computer=IBM Netvista
CPU=Pentium IV 2.4GHz

Report •

March 6, 2010 at 21:26:26
"thus the slot cannot run 32-bit cards"

You're mistaken.

The 690TXD requires a Cardbus Type II slot

DFE690TX support
Interface ? PCMCIA Type II 32-bit Cardbus

760ED was made from ~ 1996 to 1997
Your model supports 2 - Cardbus Type II cards, or one Cardbus Type III card.

If it supports Cardbus it's 32 bit.
Cardbus is merely a more advanced version of PCMCIA.

How can I tell if I have a CardBus card?
These CardBus cards can only be used with CardBus slots -- they are keyed to prevent insertion into 16-bit slots so that the card and the slot won't be damaged by differing voltage requirements. 16-bit cards work in either type of slot, but CardBus cards only work in CardBus slots.

The dfe690txd is a Cardbus card. If it can be plugged into the slot, the slot supports it !

760ED etc. Service manual
Page 254 of the pdf / 242 of the document - last entry
PCMCIA/Cardbus type II/ type III

The Lenovo site has very little info and no dowloads for Thinkpad models before 770.

However, when I searched the web for Thinkpad 760ED specs, that are lots of "hits".
2) Type II CardBus slots or (1) type III

Are you using this in Windows 98?
If so, which Windows 98 ?
The original 98, or 98SE ??

If you're not sure, RIGHT click on My Computer - Properties
Whether or not it's the Second Edition is shown on the right on the first page you see.


If you're using Win 98, use the Win 95 drivers

If you're using 98SE, use the 98 or ME drivers (they're identical)

The original version of Windows 98 and up have built in support for Cardbus, but you MAY also need to install the Win 95 PCMCIA (and Cardbus) drivers in the original version of Windows 98.

"Hi, my mom's friend recently gave her a IBM thinkpad 760ed (type: 9546-U9A) blank and formatted (almost no drivers and such). The IBM website had almost all the drivers I needed I just need the driver for the PCMCIA controller and I'll be set,..."

TP 760,765 - Windows 98 Installation Information

That mentions the Win 95 PCMCIA drivers are pctpgw95.exe

pctpgw95.exe is .....
PC Card Director (v4.08) for Windows 95: ThinkPad 345C, 345CS, 365X, 365XD, 560, 560E, 760C, 760CD, 760E, 760ED, 760EL, 760ELD, 760L, 760LD, 760XD, 760XL, 765D, 765L
(file not there)

Get pctpgw95.exe and pctpgw95.txt here:
Many appropriate 760....txt files there, too.

With all CardBus cards- check with the vendor of your card for information on operating systemsupport and drivers required. DOS, Windows 3.x, OS2, andWindows NT, do not have CardBus support built in. Only Windows 95 OSR/2 and later, (including Windows 98), natively support CardBus cards.

Table of Host Controllers

760E/ED/EL/ELD/X/XD TICardBus PCI 1130
Cardbus Controller
(Drivers Win 95)

Texas Instruments PCI-1130 Cardbus Controller


Therefore, whatever operating system you're usiing, it must be detecting a Texas Instruments PCI-1130 Cardbus Controller in Device Manager.

On the other hand, there may be some other reason the 690txd card won't work

Similar problems.
Some cards work, some don't.
A current limitation ?
(I don't think there's such a thing as a 16 bit wireless network card)

Oh and my older Thinkpad 760ED *will* see the USB 2.0 PCMCIA card
under W98Se and many memory devices connected through it. that's only
a 133MMX...
(I don't think there's such a thing as a 16 bit USB 2.0 controller card)

"I can't get the internet to come up on IE."

ME and previous don't know how you're connecting to the internet until you tell it.

You have to go to Control Panel - Internet Options (or open IE - Tools - Internet Options)
- Connections, and click on Setup

"But the IPconfig only shows Ethernet 0."

In ME and previous, Winipcfg is more useful.

Start - Run - type: winipcfg , click OK or press Enter. That shows you the names of the adapters - PPP is always
- click on the V beside the white box to see others. Click on More info, select the name of the adapter, to see if it's working properly.

See Response 1 starting at....
"When you install the ethernet card drivers, 98SE should have copied network related files from the 98SE CD. "

Same applies to Win 98 original.

Follow the directions for installing the software !
You may need to install the software BEFORE you plug in the card ! !

Unless the instructions for installing a device tell you otherwise.......
You DO NOT install drivers for a device while booting into Windows, if the software for the device has not been installed yet - when Windows detects a generic device while booting, you allow it to search for drivers, it doesn't find any, and it wants you to show it the location of the drivers - CANCEL that, continue on to the desktop, and install the software for the device using the proper installation from a CD or the proper installation file that you downloaded from the web.

If you DID install drivers that way, go to Control Panel - Classic View - Add/Remove Programs and Un-install the software you installed, reboot, DO NOT install drivers while booting, and install the software the right way !

Report •

Related Solutions

March 26, 2010 at 10:55:44
Wow! Thanks for the massive amounts of information! I tried some drivers updates and such and there was one that was the Thinkpad Configuration Utility, it allows me to switch to cardbus as long as I have an extra IRQ that I can use, I can get it to share with IRQ 4 since all 15 IRQ spaces are already crammed full. By the way, I run Win98SE. The internet works too! Thanks again for the information!

Computer=IBM Netvista
CPU=Pentium IV 2.4GHz

Report •

March 27, 2010 at 07:03:50
We're glad to hear you found a solution !

Older motherboards are limited to a max 15 legacy IRQs. Newer mboards have more than that available, but as far as I know, only Win 2000 and up can use them.
IRQ 4 is usually assigned to the Com 1 port - serial port 1 - even if you don't have anything plugged into a physical serial port - so if the IRQ is not being used by something plugged into a serial port, IRQ 4 can be assigned to some other devices. The same applies to IRQ 3 - usually assigned to the Com 2 port - but older laptops usually have no more than one physical serial port, and newer laptops usually have no physical serial port at all.
Usually at least one of Com / serial ports is enabled by default in the mboard's bios Setup - sometimes you need to disable that so a plug and play device can use the IRQ the Com port uses in the operating system - e.g. dial up modems can often use IRQ 3 or 4.
IRQ 4 can be for Com 1 or Com 3, IRQ 3 can be for Com 2 or Com 4, depending on which I/O address is used .

Report •

March 30, 2010 at 14:11:17
Thanks again! :)

Home PC
Model=IBM Netvista
CPU=Pentium IV 2.4GHz
Graphics=FX5500 (256MB)
Vintage Laptop
Model=Thinkpad 760ED
CPU=Pentium i 133MHz
Graphics=Trident Cyber9385 (2MB)

Report •

March 30, 2010 at 14:14:52
By the way, there was another problem that just occurred today.
Would you know why Win98SE will not detect any joysticks I plug in through the adapter on the laptop?

Home PC
Model=IBM Netvista
CPU=Pentium IV 2.4GHz
Graphics=FX5500 (256MB)
Vintage Laptop
Model=Thinkpad 760ED
CPU=Pentium i 133MHz
Graphics=Trident Cyber9385 (2MB)

Report •

March 30, 2010 at 14:55:10
If you're plugging in a legacy (older) joystick into a built in joystick port, or in any case, legacy joysticks are not plug and play devices.

When the joystick is plugged in, go to Control Panel - Add New Hardware - have it search for P&P devices, then have it search for non P&P devices - it should find the joystick.

The game or joystick port must be enabled in the bios Setup, if there is a setting for that.

You must have a Gameport Joystick ( = a Game or Joystick port ) listed under Sounds, video and game controllers in Device Manager, even before you plug in a joystick.

Game ports built into sound chipsets can be used for MIDI or for joysticks. I don't know if you can use it for joysticks when it's being used by the sound chipset for MIDI - I suspect not.

Report •

Ask Question