Disk not recognized in Windows7

August 3, 2010 at 15:51:11
Specs: Windows 7, Phenom X4-940 / 4GB
I bought a new disk, another HDS722020ALA330 which wouldn't spin up in HTPC. I took out my other HDS722020ALA330 in my desktop PC and tried the new disk there but same issue, wouldn't start. I took the new disk out and packed it for warranty/return and to my horror my old disk is now not recognized by win7??? Anyone know what could be the problem here? I haven't changed a thing in BIOS/win7, just unplugged and plugged in the disk and now win7 wants to format it because it sees it as RAW (and only 931GB instead of 2TB). It was working fine just before this the disk is only 2 months old.


See More: Disk not recognized in Windows7

Report •

August 3, 2010 at 16:00:08
Where are you getting the capacity numbers from? The POST screens? If so, that drive is probably defective.

Or do you have Windows 7 on a third drive and when booted into Windows 7 your 2TB is showing as 931GB and RAW?

Report •

August 3, 2010 at 16:08:53
Win7 is booting on a raid0-stripe from two other smaller disks.

Report •

August 3, 2010 at 16:18:50
ATX power supplies are always powering ATX mboards in some places even when the computer is NOT running, as long as the power supply is receiving live AC voltage.
Did you unplug the computer, or switch off the AC power to the computer, at ALL times when you were fiddling with connections inside the case?
If you didn't, you may have damaged the drive(s) or the data circuits on the mboard connected to it.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

Report •

Related Solutions

August 3, 2010 at 16:24:05
In addition to the above. SATA data cables are subject to failure if folded too tightly. Try a new cable.

If the old 2TB show up OK but is 931GB and RAW then try repairing it with testdisk. Be sure to read all the tutorial files before using testdisk. Get it at the link below.


Report •

August 3, 2010 at 16:31:18
Ok, thanks guys. I've tried changing cables but it seems another Samsung disk is working fine with same cable which is not working for the 2TB disk...hmm
Maybe I'll give that testdisk a shot.

Report •

August 3, 2010 at 16:54:56
If the drive is not being identified in the BIOS/ POST screens then testdisk isn't going to help.

Maybe I don't understand the current situation with that drive. Is it showing at all, or showing at 931GB?

Testdisk may be able to repair the partition/s.

If the drive was one large partition then part of the drive may be dead. a 2TB drive has multiple platters and heads.

You should probably download the drive fitness test from Hitachi and run it to see what is going on with the drive.

Report •

August 3, 2010 at 17:21:25
I tried testdisk and another program but both sees the disk as 931GB (RAW). When it was working it was one big 2TB-partition and now windows shows it as one 931GB primary partition (RAW) and yes it is posted ok in BIOS. Hmm know I remembered... when the new disk wouldn't spin up or post in BIOS I did change one thing... turned on S.M.A.R.T, can this have something to do with my problems?

Report •

August 3, 2010 at 19:09:41
As I said above, use the Hitachi fitness test to determine what is going on. That drive has 5 platters so there are lots of moving parts that can fail.

It is possible your BIOS is having trouble configuring the 2TB drive. When you first start your computer you see POST screens showing the BIOS configuring the hardware. Watch those screens to see if the drive is identified by both the model number and the full capacity.

Report •

August 4, 2010 at 09:30:08
Thanks for your help and responds.
A friend of mine installed a program called Eaesus or something and it could recover the lost partition and it seems to work. The program is now reading back my data to an USB disk =) I guess I'll have to scan/test the 2TB disk with Hitachi tools and reformat before reinstalling the disk in my PC.

Report •

August 4, 2010 at 10:35:39
2TB is too large a partition, IMO.

Report •

August 4, 2010 at 10:55:16
ok, do you that splitting it into two 1TB partitions will help me avoid these strange and sudden "lost partition" errors in the future? Maybe Windows7 is to be blamed a bit here too... never had these kind of problems when I was running on Linux.

Report •

August 4, 2010 at 12:25:48
We were assuming you were connecting the subject drives internally.
If any are external drives, that's a different subject.

In Vista and Windows 7, you can change the size of partitions Vista or Windows 7 made in Disk Management without losing the data that's already on the partition(s).
E.g. if you made the single partition on the 2 tb smaller, the rest of the drive would be unallocated, and you can then software partition and format that un-allocated space.

If you have more than one partition on a computer, you DO NOT have to install everything that did not come with Windows on C. For a program, if you do NOT choose the default Express or similar install and choose a Custom install or similar instead, or if you change the location of where something is installed - e.g. change just the drive letter to that of another partition at the beginning of the location - Windows will allow you to do that in most cases, and if it's a program, only a tiny part of it's data will be installed on C, the rest of the data will be installed on the other partition.

"I did change one thing... turned on S.M.A.R.T, can this have something to do with my problems? "


S.M.A.R.T is a bios feature supported by newer hard drives that tests the drive. It's "dumbed down" such that it won't generate messages unless it detects there's something serious wrong with the drive. It does most or all of it's tests during booting, so that adds a slight but insignificant amount of time to how long it takes to boot the drive(s). If you get a SMART message, the drive is definitely either failing or has a connection problem, or you're experiencing ram errors.

Hard drive manufacturers express the drive size as it's decimal size (powers of 10; e.g. 1kb = 1,000 bytes).
All operating systems and most mboard bioses express the drive size or partition size as it's binary size (powers of 2; e.g. 1kb = 1,024 bytes, 1,024kb = 1mb).

1 binary Terrabyte = 1,099,511,627,776 bytes
1 binary gb = 1,073,741,824 bytes
1,024 binary gb = 1 binary terrabyte

1 Manufacturer's terrabyte = 1,000,000,000,000 bytes = .909495 binary terrabyte = 931.322 binary gb

931.322 binary gb x 2 = 1,862.645 binary gb = 1.818,989 binary terrabytes

You should see that the total size of the physical 2 tb drive in Disk Management in Windows 7 is ~ 1.818 terrabytes, or ~ 1,862 gb.

That's the "raw" size of the entire physical drive.

Software partitioning (e.g. using the NTFS) and formatting use up a small percentage of the drive partition space that can't be used for data, so, e.g. if the 2 tb drive has one partition, the size of C in Windows in My Computer or Windows Explorer is a small percentage less than ~ 1.818 terrabytes, or ~ 1,862 gb.

" Win7 is booting on a raid0-stripe from two other smaller disks."

The only advantage of a RAID 0 array is a perceived halving of the drive access time.
It's number is 0 because it has no redundancy.
If something serious goes wrong with the data on one drive, or one drive fails, you have to load all the data on the two (good) drives from scratch.

Report •

August 4, 2010 at 12:51:29
Yes, it's a internal 2TB disk and it posts in BIOS the same as before (can't see any disksize in my BIOS) but S.M.A.R.T isn't giving any errors. In fact, the only difference from when it was working fine as one big 2TB partition in Win7 is that Win7 now thinks it's a 1TB disk (931GB) with RAW filesystem instead of one 2TB NTFS partition which is was just before I unplugged it and installed my new faulty drive (exactly same 2TB Hitachi disk, just newer one). I also tried updating my Nvidia mobo chipset drivers with the newest ones but still same problem. One weird thing, I tried another 1TB Samsung disk on the same SATA-port/cable and this disk came up ok at first but after a reboot this disk lost it's driveletter in win7 disk mgr/explorer. I added a new letter and it worked again... Could this perhaps refer to some problem with my SATA chipset and the boot disks (2x320GB Seagate in RAID0)? Maybe this built in RAID-function on my Gigabyte mobo is interfering with the standalone disks? Should i break the RAID0-stripe and run standalone disks all the way and partition the 2TB into 1TB's partiotions for a more stable system?

Report •

August 4, 2010 at 14:28:13
We were assuming you were connecting the subject drives internally.
If any are external drives, that's a different subject.

Is one 2 tb drive seen as ~931gb, the other one as twice that size in Disk Management ?
If yes, there is nothing wrong with your computer - the problem is with the drive that is seen as ~931gb.
If yes, your problem with the drive seen as ~931gb MIGHT be cured by you flashing it with the latest hard drive firmware version - look on the Hitachi web site to see if that's available, and if it is, look for instructions there for how to do that.

When a hard drive is new, or when it's used and all partitions have been deleted, it has no data on it, and it shows up in Disk Management as having a"raw" partition, and that "raw" partition is shown as "unallocated.

All drive letters shown in Windows are logical drive letters.

The hard drive's partition or partition(s) will NOT show up in My Computer or Windows Explorer as a drive letter until there is one or more software partitions on the drive that have been software partitioned (e.g. using the NTFS) and formatted using something the operating system recognizes (for Windows 2000 and up, that's the FAT, FAT32, or NTFS file systems).
Disk Management in Vista and XP assigns a drive letter by default to such a partition, but you can choose to NOT assign a drive letter, and in that case the partition(s) without a drive letter will NOT show up in Computer or Windows Explorer.

"I tried another 1TB Samsung disk on the same SATA-port/cable and this disk came up ok at first but after a reboot this disk lost it's driveletter in win7 disk mgr/explorer."

Did you connect that drive internally or externally ?

If internally, or externally via an eSATA connection, did you check the data cable, or try another one ?

Report •

August 4, 2010 at 17:01:42
All my tries have been internally on 2 different SATA-ports on the mobo with 3 different SATA cables and it's the same problem regardless of which cable/port i try. The Samsung 1TB disk though works fine on the same internal ports/cables. I've tried the bootable drive-fitness disk from Hitachi but that won't even recognize the disk, therefore i can't run the test... very strange, Windows7 at least find the correct disk according to the name HDS722020ALA330, but it only sees it as 931GB instead of 2TB. This is 2 out 2 disks from Hitachi that seems to have crashed in some way... very disappointing. The one that posts as 931GB is 2-3months old and the newest seems to have been dead on arrival...this really sucks =(

Is there anything more I could try or should I just pack this one for warranty/return too?
Maybe I'll do one last test on my other PC which has a completely different configuration... to see if it posts as 931GB there too.

Thanks guys for your time and efforts here, I think I'll avoid Hitachi-disks in the future...

Report •

August 4, 2010 at 18:47:47
Look in the BIOS settings to see if there is a setting to allow for more time to configure the drives. Usual time is up to 5 seconds.

Report •

August 4, 2010 at 20:36:05
It's extremely unlikely both drives would be defective.
It's a lot more likely your mboard is defective .

Try the drives in another computer.

Report •

August 5, 2010 at 15:27:49
Yes! The oldest one now works fine in my other PC, that one had nvidia sata raid chipset instead of AMD and this PC's BIOS posts the disk as 2TB and windows on this machine also sees it as 2TB and could partition it as two 1TB partitions. I guess the chipset driver for my first PC doesn't support this kind of disk. I've tried the latest mobo/chipset drivers from Gigabytes supportpage and 2 older drivers as well but no difference. I guess this disk will stay in the other PC where it works fine. I haven't flashed the Gigabyte BIOS though, I don't know if that would help.. it says nothing about SATA chipset support in the newest flashBIOS release notes.
The newest Hitachi disk is truly dead (DOA) and I now got OK from the reseller to return the disk (RMA). This disk won't even spin up in any of my PC's. When i turn the power on I can hear 3 faint spark sounds, like electricity trying to start the disk but then nothing happens and the disk remains quiet and cold.

Report •

August 5, 2010 at 18:33:38
The hard disk drivers are built into Windows. They can't limit the size of the hard drive or partition that's detected.

It's extremely unlikely there's anything wrong with the main chipset drivers.

There is no 1 tb drive size limit. I've never heard of a 1 tb size limit bios bug, or one in an operating system, ever. If the bios and the operating system supports recognizing drives > 137gb manufacturer's size = 128gb binary in Windows, it supports recognizing any size of hard drive currently available and in the foreseeable future. Vista and Windows 7 of any version, and XP with SP1 updates or higher installed, and 2000 with SP3 updates or higher installed, recognizes any size of hard drive or hard drive partition.

There is no valid reason for you to flash the bios if the present bios version previously recognized the size of the 2 tb drive fine.

Flashing the bios is NOT a fix-all - it's the riskiest thing you can do to a computer. The bios flash chip is a relatively old type of chip - it can only be flashed a small number of times, and it can physically fail the FIRST time you try to flash the bios. If it physically fails, your computer will not boot again until it has been replaced. In most cases these days, the flash chip is soldered into the mboard and can only be replaced by an expert with the right tools. Most people find it more convenient and not much different cost wise to replace the mboard locally with a new one rather than to have to send the mboard away and have the flash chip replaced then sent back.

However, if you have already flashed the bios yourself, whenever you flash the bios with a different version than it had , you MUST load bios Defaults in the bios Setup after you reboot after flashing, otherwise the contents of the Cmos may NOT match the bios version, and in that case the bios likely will NOT work correctly. In most cases, flashing the bios does NOT load the matching Cmos contents automatically.

If you have NOT flashed the bios yourself, the most likely thing is your mboard is damaged.

You could try repairing Windows 7 or loading it from scratch, but I very much doubt doing that will cure your problem.

Has your system been exposed to a power failure event since the drive was definately detected as ~1.8 tb ?

Is everything that connects to your computer plugged into something that protects against damage caused by power surges and spikes ? E.g. the computer, all devices that plug into the computer that plug into AC directly or via an AC to DC power adapter, AND the cable that connects you to the internet, if your computer is connected via a network cable to your router, AND the telephone cable, it that's connected to a dial up modem on the computer .

Has there been a lightning strike on the power grid near you, or near your location ?

Report •

August 5, 2010 at 19:49:45
What exact motherboard model do you have?

Did you check your BIOS settings for a drive seek delay setting?

Report •

August 6, 2010 at 01:21:13
GA-MA78GM-S2H (rev.1.1)

I haven't seen the drive seek dely setting...I'll look again

Report •

August 6, 2010 at 04:23:00
I didn't find any reference to that setting in your manual.

Are you using AHCI mode in the BIOS settings?

That only functions with the SATA 1-3 ports. Read 2.5 Integrated Peripherals. The default settings for SATA 1-3 is IDE mode. I suggest you try AHCI instead.

If still no go you could attempt manual configuration of the drive in the BIOS settings. You will need to read the data off the drive label and enter those values.

I don’t know if this will yield any additional settings but good to know anyway.

Q: In the BIOS Setup program, why are some BIOS options missing?
A: Some advanced options are hidden in the BIOS Setup program. Press <Delete> to enter BIOS Setup
during the POST. In the Main Menu, press <Ctrl>+<F1> to show the advanced options.

Report •

August 9, 2010 at 10:17:51
Ok, thanks. I'll try this advanced BIOS thing when I get the new disk back from RMA. For now I'll run this 2TB disk on the other PC where it seems to work.

Report •

Ask Question