disc read error

Emachines T2865 desktop
March 31, 2010 at 15:46:51
Specs: xp pro
We got this pc from a guy with no Hard drive. got a new hard drive and when i boot it up it gives me a disc read error. i can boot to the floppy and to the cd rom but not the HD. when i go to install windows it acts like it going to but when it goes to reboot it gives me the error. please can some one tell me whats going on with this pc!!??

See More: disc read error

Report •

March 31, 2010 at 16:28:10
Disk read error - possibly

New hard drives have no data on them.
You have to install an operating system on the drive in order for the bios to recognize the drive as bootable.

If you boot the computer with an XP CD, the hard drive will be bootable after Setup has finished.

You only need to press a key to boot from the XP CD the first time. Setup will automatically Restart the computer until Setup has finished. If you press the key to boot from the cd while booting after the first time while Setup is running, Setup will start from the beginning again.

If the hard drive is SATA, XP's Setup won't find the hard drive unless
- you set the SATA controller in the bios Setup to an IDE compatible mode instead of a SATA mode.
- you have a legacy floppy drive connected, and you press F6 near the beggining of loading files from the CD, then provide a floppy disk later in Setup that has theSATA controller drivers on it.

Disk read error

You may have a poor data cable connection to the hard drive.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

If you're sure the data cable connection is okay, if you still get Disk read error...

Check your hard drive with the manufacturer's diagnostics.
See the latter part of response 1 in this:

(thanks to Dan Penny for this link:)
Hard Drive Diagnostics Tools and Utilities

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibility, on another computer if you need to.

Report •

March 31, 2010 at 16:40:54
all the cables are new, I did rip the first cable...its an eide hard drive... and when windows disc starts it copies the files needed to start installing windows. (this is done in what i believe is DOS mode.) when it reboots to actually install windows i will get the disc read error. the hard drive was checked and no errrors were found.

Report •

March 31, 2010 at 17:41:54
You should get NO ERRORS AT ALL when reading files from the CD during Setup. If clicking on Retry or similar does not help...
If you DO / DID get errors, something was not right !
See Response 7 in in this,
starting at
"Errors reading from the CD can be caused by....."

Report •

Related Solutions

March 31, 2010 at 18:10:20
let me see if i can make this simple......i took the HD and put it in another pc and installed windows on it. now i put it back in the original tower and i still get the disk read error. all the cables are good and everything is connected correctly. but i still get the error!!

Report •

March 31, 2010 at 18:57:11
You haven't made it simple at all. You should have included the info in response 2 and 4 in the first post.

The second stage of Setup is when it detects the hardware. If Setup has problems with that, the time remaining will stall at the same time for a lot longer than it should, then the computer will black screen and reboot and start the second stage over again, in an endless loop, but I've never heard of anyone getting a disk read error in that stage, unless there was a problem reading from the CD or from the hard drive, for whatever reason .

Is there more than one hard drive on this computer?
If so, check the settings in the bios Setup. The bios is probably trying to boot from the wrong drive.
When you have more than one hard drive, there is usually a list of the hard drives in the bios near the Boot Order or similar settings - the drive you want to boot from must be listed first . If that's not there, then there is more than one hard drive in the Boot Order or similar list - the drive you want to boot from must be listed first .

Even if you don't have more than one hard drive, check the Boot Order or similar settings in the bios.

If that doesn't apply, exactly when do you get the disk read error ?

"i took the HD and put it in another pc and installed windows on it"

When you install XP (or 2000) on a hard drive when the drive is on one mboard, then transfer the drive to another mboard and boot from that same Windows installation, if the mboards are more than a little different, it's common for XP (or 2000) to NOT load Windows all the way. Typically, you see the first bit of Windows graphics, then a black screen, blinking bar cursor top left, and nothing further happens, but I've heard of other different symptoms as well.
You can fix that by booting the computer with the XP CD and running a Repair installation of Windows, without losing the data already on the partition Windows was installed on.


What size is the hard drive?
If it's > 137gb, the XP CD must have SP1 or later updates included on it.
If the XP CD DOES NOT have SP1 or later updates included on it, then you need to make yourself a "slipstreamed" CD that has the contents of your original CD with the SP3 updates integrated into it, or at least whatever SP updates the Windows installation already has, and use that to run the Repair installation.

Report •

March 31, 2010 at 21:09:33
ok sorry for the lack of info. the Hd is Western Digital 40 Gigs and has been checked for errors (none found). Its the only HD in the Tower. when you first put the windows disc in the drive it checks the config. of the system. then it formats the drive, then it copies files to the HD. this all happens in dos. after it copies the files it restarts the pc. now if the pc was to restart it goes to the graphics showing what stage windows is in for the installation. this is where it shows the timer on how long it will take to finish installing Windows. But it never gets that far it gives me the error. the windows disc i have has SP3 on it. the bios detects the HD no problem. the boot order is 1)floppy 2) cd-rom 3) HD. i have also reversed that order. also its an emachine T2865 with a 2.8 GHz cpu and 512Mb of ram.

Report •

April 1, 2010 at 08:07:09
emachines desktop systems have a reputation of using el-cheapo power supplies that tend to malfunction a lot more often than average. This is especially the case if the power supply brand is BESTEC, which is usually, if not always, the brand they have originally. Check the current voltage readings in the bios Setup for what is supposed to be +3.3v, +5v, and +12v - they must be within 10% of the nominal value - if any of those aren't, you must replace the power supply.

If it is failing, you can usually replace it with any decent standard sized standard ATX PS with the same capacity or greater.

Standard (PS/2) power supply size - 86mm high, 150mm wide, 140mm deep, or 3 3/8" h x 5 7/8" w x 5 1/2" d , or very close to that, though the depth can be more or less for some PSs.

Don't buy an el-cheapo PS.
See response 3 in this:

Your power supply must have at least the minumum capacity required to support a system with the graphics card you are using installed, or the max graphics card you might install in the future.
(Onboard video - video built into the mboard - IS NOT A CARD ! )
If that info is not in the ad for the video card, you can go to the video card maker's web site and look up the specs for the model - often under system requirements - the minimum PS wattage, and, more important, the minimum amperage the PS must supply at 12v is stated. If you don't find that, any card with the same video chipset including any letters after the model number has very similar minimum PS requirements. Some power supplies have two or more +12v ratings - in that case, add those ratings to determine the total +12v current capacity.

If you're a gamer...
In most if not all cases, the max capacity rating of the PS is an intermittent rating. It's recommended that you do not load your PS to any more that 80% of that rating if you are going to be using something that puts a constant load on it, such as playing a recent game for hours on end. In that case, you multiply the min capacity stated for the system with the particular video chipset on the card by 1.25 to find the min. capacity of the PS you should get.

Western Digital IDE (EIDE) drives often have two ways Master can be set - Master, single, or similar, for when the drive is by itself on a data cable, and Master, slave present, or similar, for when it is on a data cable with another drive set to Slave. That MUST be set correctly.

If the drive is set to cable select, it should be on the end connector of a three connector data cable if it is by itself on a data cable, not on the middle one which makes the drive seen by the bios as slave - newer bioses / mboards will often detect the drive anyway when it is on the middle connector, but you're likely to have problems in that situation because it's not on the proper connector.

It can be very hard to tell if a data cable is damaged, and you can have intermittent problems with it if it is. If you have another data cable, try using that.

80 wire data cables MUST have the proper end connector connected to the mboard - usually it's blue, but in any case, it's the one farther from the middle connector on a 3 connector data cable.

Are you seemingly getting the disk read error from the bios or from Windows ?
If that all it says?
Some error messages can only be generated by Windows / or whatever operating system.

The second stage of Setup is when it detects the hardware.
You may have a hardware problem that was preventing the second stage of Setup from even starting.
For both of running from the XP CD and for trying to boot from the installed Windows installation, you could try making sure all cards are all the way down in their slots, or if that doesn't help, removing all cards in slots not necessary for running Setup, or not necessary for the Windows installation to work.

Report •

April 1, 2010 at 12:31:44
well i looked into the power supply and its fine ( not a bestec). and the voltage is within 10 %.
It has on board video, and the jumpers on the HD is set to master.
one thing i did today was to remove the MOBO and look for any burnt spots or scratches on the front and back, in doing so someone put a piece of paper (8 1/2 x 11) behind the MOBO. i threw that away and replaced the MOBO. as for where the problem is at i think its a hardware issue, but i could be wrong. i have not tried to reinstall windows since removing and replacing the MOBO. I have built and repaired dozens of pc's and never had this much of a problem. now i will try to install windows.

Report •

April 1, 2010 at 14:08:27
It's unlikely your problem had anything to do with the previous mboard.

"...the jumpers on the HD is set to master."

Master, single, or Master, with slave, or similar? If there are two choices, if the drive is by itself on the data cable, it should be set to the former.

Report •

Ask Question