Dell won't load bios, hangs at splash screen

Dell Dimension 2400 desktop
December 9, 2009 at 23:04:33
Specs: Windows XP, AMD Athlon64x2
I've got a Dell Dimension 2400 that, when I turn it on, goes straight to the Dell splash screen, and no further. The bar underneath the Dell logo does not show any advance....about 1/10 appears to be loaded.

Cannot boot into bios, it doesn't even get to the point where you have that option. I've tried this with only the MB, RAM, CPU installed and I get the same thing, so I am ruling out the hard drive or any other drive problems.

I have tried removing the CMOS battery, resetting CMOS with the jumper, nothing is working. I tried different ram, different PSU, same results.

Is it safe to assume this motherboard is the problem? The Dell diagnostic lights on the back are showing A,B,C green, and D is yellow, indicating "another failure has occurred".

Unfortunately I only have AMD systems on hand, so I can't swap out parts to test the CPU. I've already spent a few hours searching online and cannot get a definite solution. Does anybody have a simple in, is the motherboard shot?

See More: Dell wont load bios, hangs at splash screen

Report •

December 10, 2009 at 05:51:49
If you press ESC as soon as you try to boot you may get past the splashscreen and see what part of the bootup is hanging.

Does your CPU fan spin up? If it has failed bootup will halt to protect the CPU from overheating. If you try to boot up without any RAM do you get any bios beep error?

Do you have onboard graphics or a plugin card?

Goin' Fishin' (Some day)

Report •

December 10, 2009 at 11:18:25
It doesn't even get far enough for the keyboard to work. It's apparently not loading the bios, not entering bootup at all.

This is a Dell 2400, so it has the wind tunnel to the fan at the rear of the case, not a fan right on top of the CPU heatsink. That fan and the power supply fan are both working. It does give me the error beeps if I try starting with no ram.

The graphics are onboard.

I've tried changing out the ram with other that is known good. I've tried resetting the bios with the jumpers and by removing the battery. I've tried 2 other power supplies. All with the same results.

More info:
The owner said this happened after the last Windows Update. When the computer restarted to finish installing the updates, it came up to this screen and stayed there. He tried leaving it on for hours and it never changed. I read that similar things were happening with certain graphic cards, but this one is the original onboard graphics, so I've ruled that out too. And since it won't proceed any further, it's impossible for me to uninstall the latest update anyway.

I'm assuming at this point it was just a coincidence that something went wrong with the motherboard at that moment. Surely the update couldn't have totally messed up the bios? Which by the way is showing as version A05 if that helps any. Thanks!

Report •

December 10, 2009 at 11:24:42
I think the splash screen is embedded in the BIOS on OEM machines. So seeing the Dell splash screen is not an indication that the OS has even started to load. Could be a dead or corrupt hard drive. Can you boot to a bootable CD if you disconnect the hard drive entirely?

Report •

Related Solutions

December 10, 2009 at 11:45:00
Othehill, that's correct. It's not even trying to load the OS because, as far as I can see, it's not loading the bios completely. It just hangs at the splash screen with the progress bar below the Dell logo frozen. It doesn't get far enough for the keyboard to be operable. It won't boot from a CD because again, it's not even getting to the point where it's trying to load anything.

I've tried disconnecting all drives, only using the motherboard, CPU, and ram (onboard video so no video card to worry about). I get the same results this way. See above for everything else I've tried. As far as I know, I'm down to the motherboard or CPU being the problem. And from what I've read it's very unlikely the CPU would be bad, but.......

By the way, I have visually inspected the board and don't see any bad caps. Sure wish I did, that would make it so much easier to just blame the board and move on!

Report •

December 10, 2009 at 11:56:37
Strip down to just the PSU, MBoard, CPU/HS/fan, 1 stick of RAM, graphics (on board if available), monitor and keyboard.
No drives, case to board wiring, etc. Start by temporarity shorting out the two power button pins.

Try POSTing that way. If no go, remove the RAM and try again. Should get memory error. If still no go then it is down to board or CPU. Remove the board to eliminate any possibility of it grounding to the case and run on cardboard outside the case.

All the above assumes you are using a known good, compatible PSU.

Report •

December 10, 2009 at 13:16:16
Update, and hopefully a good one! The only extra thing installed was the modem card, so I removed it. Also unplugged the front USB from the board. Left all the drives unhooked. This time it loaded and got to the error screen, no drive found. I hooked up the hard drive and still got the same error. Hooked up CD drive, same error, no drives found. Went into the bios and manually added the 2 drives. They still showed up as unknown, but after restarting, the computer finally booted up! It was extremely slow, with the blue "please wait....." screen at one point. I guess this was Windows completing the update?

I haven't yet tried plugging the USB back in, or the modem, to figure out which is the problem. I assume that is my next step. I've read about the latest Windows Update causing similar problems with certain video card drivers. I wonder if this is the same type of problem, but involving the modem card and/or USB? I'm going to try uninstalling the modem drivers completely and reinstalling now that the update is complete. Keeping my fingers crossed!

Report •

December 10, 2009 at 13:21:29
Boot into the BIOS (setup) and reset values as needed. Also, disable the Dell logo if you can so you can watch the boot screens to see what hardware is being configured.

Report •

Ask Question