Solved Dell N5110 Laptop No Boot Without F2/Escape

March 23, 2014 at 08:21:41
Specs: Windows 7 64 bit, i5-2410M/6052 Dimm(s)
Dell N5110 Laptop,
Seagate ST9640320AS 640 Gig SATA Hard Drive, 2048+4096 Dimm Modules, Win7 Home Premium 64 Bit

Turn on computer, get SATA controller message: no boot device
Reboot hit F2, under ‘hard drive’ : NONE
Reboot, hit F2, then Escape, boots into Windows, all is well

Boot with Dells windows disk, attempt reinstall, can see 3 partitions: 100 MB, 64 Gig, 540 Gig as partitions 1, 2, 3. Attempt to reinstall to part 3, get message: can’t install to this partition; hardware may not be able to boot from there.

After windows disk, can’t get to windows again without the following procedure: reboot win disk, decline auto repair of win, go to dos prompt, find boot directory on CD, do “bootsect/NT60 E: / mbr” then I’m back to the beginning, can boot with F2/ESC

Boot with Seatools on dos CD, Seagate can’t see drive

Sometimes boots into windows fine, but usually get no boot device message and have to F2/Escape to get into windows. Rarely get BSOD with page fault message; that was trying to do something on a webpage.

Upgraded bios from A03 to A11. After, computer automatically downloaded LOTS of drivers from windows update, including for SATA controller. Thought it was fixed for a few boots, then back to beginning problem again. DID load defaults. Sata listed as AHCI as it was before.

Almost seems like SATA controller takes a while to warm up and get working….

Tested components with Dell’s system health program, (F12 /diagnostics/ PSA). All tests passed. Tryed memtest 86 all tests passed.

Never was able to get factory reinstall partition to work…F11, ctrl+F11, F8, etc

Doubt hard drive is really the issue, it works fine once you get into windows. Huge drive barely has anything on it, and about 1000 run hours.

SeaTools for Win says SMART, short self, and generic short, tests passed.

Is the SATA controller dying, is there a second channel that can be used instead, is the controller part of the motherboard-so I need a motherboard?

Research on Dell website says all things I’ve tried are the problem. Not.


See More: Dell N5110 Laptop No Boot Without F2/Escape

Report •

March 23, 2014 at 14:49:24
✔ Best Answer
It's a hardware problem so attempting a reinstall or software fix isn't going to do anything.

Check in cmos/bios setup and make sure the sata configuration is correct. On older bios' there often was a 'hard disk pre delay' which you could set to allow more time for the hard drive to spin up be recognized. If you have that option set it for 5 seconds or so.

The drive may be going bad. If you can clone it to an external drive you should probably do that and then look for a new drive.

Report •
Related Solutions

Ask Question