Dell Latitude D820 turns itself off after an hour or so.

March 25, 2013 at 23:16:49
Specs: Windows 7, Core 2 Duo 2GB RAM
Okay, new main battery fitted about a year ago and the computer works fine, except for turning itself off after an hour or so. Also, a weather and battery gadget sometimes move from their set positions on screen. Running Windows 7 Ultimate.

Just removed a fair bit of dust from the fan vent beneath. Will see how that goes.

See More: Dell Latitude D820 turns itself off after an hour or so.

Report •

March 26, 2013 at 05:55:10
It certainly sounds like an overheating problem. Make sure you always use the laptop on a hard, flat surface to maintain an air-space underneath it. Do not use it directly on your lap on or on other soft surfaces without a hard, flat board under it as this will block the vent and cause overheating.

Some laptops have a large vent on one side instead to avoid the overheating problem when it's on your lap, but if the vent is underneath you have to make sure you place it on a hard, flat surface. Bad design.

Report •

March 26, 2013 at 06:12:37
If your D820 has the nVidia graphics chip then this could be sign of the chip failing. I have reflowed a lot of these boards

Report •

March 26, 2013 at 06:16:46
Hi Caleula,

Laptop batteries do not necessarily provide power for that long a time and much depends on the workload at the time. Maybe when new only 1 - 1.5 hours, which gradually reduces until replacement is required.

Does the problem occur if running when connected to the psu?

If not, when running *WITHOUT* the psu, monitor the amount of charge remaining. If there is very little charge left just before it powers down, there is your answer.

Please advise back on progress.

Good Luck - Keep us posted.

Report •

Related Solutions

March 26, 2013 at 06:53:29
Hi Mike,

The Laptop is running on mains power all the time. The diagnostic LEDs in the battery pack are showing full charge as is the battery gadget on the desktop and also in the BIOS.

I set the screen saver to 1 minute and blank screen to 2 minutes to speed up the diagnostics. It appears to be working currently since returning it to my wife's table where she works.

I also upgraded the BIOS from A04 to the latest A10.

Report •

March 26, 2013 at 06:56:59
Hi phil22,

After cleaning the dust off the underside vent, I put an ear close to the fan and it sounds to be running evenly.

Nothing blocked under or around the laptop and never used on my wife's lap.

Report •

March 26, 2013 at 07:05:30
Hi Gretti,

Thanks for the URL. Will check whether it has the nVidia graphics chip tomorrow, time permitting. Been soldering stuff, including minute channels in a digital watch kit once, for about 60 years so that is a good suggestion thanks. Have all the necessary gear for that with the addition of an 18 LED magnifying lamp to help my eyesight :(

Have observed that it is an ungraceful shutdown as it comes up "Didn't Shutdown Successfully" and hence the desktop gadgets moving on screen and one losing its data.

Report •

March 26, 2013 at 14:00:54
Hi again Gretti,

It's an NVidia Quadro NVS 110M video controller.

Maybe if I take the laptop apart to check for dust near the fan I shall reflow the solder around the NVidia chipset.

So far, working this morning. One desktop gadget moved slightly, but the troublesome one didn't. I figure the ungraceful shutdowns were clobbering the desktop gadgets. The screen awoke normally when I moved the mouse.

Report •

March 26, 2013 at 17:46:57
As clearing the vent helped maybe the CPU heat sink is chogged up too.

Always pop back and let us know the outcome - thanks

Report •

March 26, 2013 at 18:38:46
Hi Derek,

Most likely. Will probably have a look internally time permitting. Have the laptop, a mobile phone and a desktop all with various problems I'm troubleshooting currently.

Thanks and will post back if the problem and/or further investigation arises :)

Report •

March 28, 2013 at 00:40:04
Hi phil22 & Gretti,

Okay. We've been out most of today while our daughter has been working at home. Just noticed one icon flashing and should've put my specs on. A touch of the mouse or the <Enter> key yielded no response, but the lightest touch of the power button [I think maybe as I have an extremely light touch] rebooted the laptop.

So, maybe pull the beast apart and check for dust bunnies and solder lands condition around the video chipset?

OT, but does anyone have a clue as to Notifications "Registration Failed (13)" on a Samsung Galaxy S i9000 [maybe GT model in other countries - I'm in Australia]? Tried a Factory Data Reset last night and the error persists and subjectively has been more frequent prior to the reset at least as enough days haven't passed to comment otherwise.

Lastly, OT again [sorry Mods] but does anyone know whether "Tubes & Wires" posts here? I'm a friend of his from years back and his email account is always full. Would love to contact him if possible.

A Happy Easter to all :)

Report •

March 28, 2013 at 03:04:32
Okay. It's the battery status light blinking to indicate charge, but the laptop has apparently turned itself off abruptly, so overheating I suspect. Subjectively, boot time appears to be excessively longer than it used to be.

Report •

March 28, 2013 at 10:46:00
Tubesandwires has done a bunk - hasn't been around since July 2012.

You could send him a Private Message from your "MyComputing.Net" and see if he responds (an email is usually sent to say a PM has arrived). Makes sure type the name exactly as written above, including capital "T". I used to chat with him on PM's.

Always pop back and let us know the outcome - thanks

Report •

March 28, 2013 at 13:23:21
Thanks Derek, however, my emails always bounce. He and I go back to years ago when we used to reply to tech questions on an Australian forum, now defunct. He last emailed me 26th November, 2011 saying "My IN webmail mailbox was full again until I deleted some of the email in it a few days ago."

One day when he does delete some emails, I'll catch up with him again I guess. He did say that myself and one other friend were his only regular email correspondents these days.

Now to find where PM section is.

Report •

March 28, 2013 at 13:34:34
Hi again phil22 & Gretti,

A Dell OptiPlex 760 died last night with LEDs 1 & 3 flashing and no Power Switch LED, so another bit of troubleshooting to do. Luckily I have a PCI diagnostic card I bought a while back and, yes, have read about the LED indications to follow through on, given room on this overloaded desk. Have just given away most of 30 years worth of computer gear and 3 more computers to go. It goes to developing countries though.

I'll buy a new CMOS 3V cell for the Dell Latitude D820 so I can replace that when I get around to pulling it apart and checking for dust bunnies and the video chipset solder land condition.

My ISP has given me a URL for the Notifications "Registration Failed (13)" on the Samsung Galaxy S i9000 and I shall troubleshoot that once I buy a cheap pre-paid SIM to check whether I have SIM card errors or a faulty mobile [Cellphone] phone.

Thanks to all and will post back when I ever get around to attacking each of the 3 problems I now have.

Report •

March 28, 2013 at 14:04:10
Hi Derek,

A swift response to my email to Tubesandwires.

"Your message could not be delivered.

The recipient's account is temporarily over the maximum allowed mailbox size."

Looks like a PM is my only hope :(

Report •

March 28, 2013 at 15:15:59
Hi caleula,

On your D820, Don't try to reflow the grapics chip untill you do a lot more research on the procedure if you feel that you are up to it and you think that this is actually a GPU issue. It is more voodoo then anything. You may want to just clean out the dust, replace the thermal paste. If you are still having the issue, D820 motherboards are cheap, just check ebay.

On you Opti 760, there is a know issue with surface mount ceramic capacitors that tend to oxidize and fail, because they are mounted on the mainboard between the CPU fan and the heatsink. You may want to check those with a multimeter, they will show continuity if they are failed. You should also test the system with a test power supply as I think it is a power issue.

On your i9000 "Registration Failed" is if you are using an off-network sim card. So the phone was intended for a different cellular carrier than the one you are using.

Hope this helps.

Report •

March 28, 2013 at 16:13:58
Hi Gretti,

Are you a Dell rep?

Thanks re. the D820. I have ordered a CMOS battery as I might as well replace that once I'm inside the machine checking for dust. Will check eBay for a replacement M/B too thanks.

Just about to check the Opti 760 so thanks for your timely tips.

The i9000 doesn't have an "off-network SIM card" as it was in a sealed box, not tied to any carrier and hence, no crap firmware. I'll buy a cheap pre-paid SIM card first to see whether that's my problem - already on my second SIM card. and then have permission already to flash the ROM without voiding the 2 year warranty. Certainly happy with that deal! Only caveat is that I flash with the Korean i9000 firmware so off to look for that later, maybe on the XFA Developers site.

Report •

March 28, 2013 at 16:54:38
Hi Gretti,

Well -

1. 760 not switched on, LEDs 1 & 3 flash.
2. Hold front power switch in, only LED 3 flashes. Power switch LED doesn't light up.
3. No green LED on back of PSU, but ...
4. Hold button at back of PSU in and green LED comes on, and ...
5. Front power switch LED is steady amber, and ...
6. LED that is at the bottom of the diagnostic row looks like this

▀ ▀
and is steady. [The top square should be in the centre though and a horizontal line running between the top square and the two squares at the bottom] Couldn't get my drawing to stay together properly - sorry.
7. Amber LED on M/B is on too.

Report •

April 1, 2013 at 17:14:29
Hi Gretti,

Tried testing the power supply with a jumper between the green and black wires. It turned on okay. The motherboard had a note with it saying some CPU socket pins were bent, but that it passed all tests. Worked fine for quite a few months.

Report •

April 2, 2013 at 00:41:27
Can't pick a best answer yet mods. as the problem isn't yet resolved.

Report •

April 19, 2013 at 00:04:23
Okay. An update to anyone still reading this saga and willing to offer suggestions.

1. The Dell OptiPlex 760 SFF has been replaced with a Dell OptiPlex 755 Tower running Windows 8, but darned if I can get AHCI to run. Tried setting it in BIOS and it naturally kept rebooting. Then managed to change the controller setting in Device Manager to AHCI mode successfully. Still no go. Fiddled with the Registry to no avail. Now trying to find a valid set of AHCI drivers for the 755 to load to diskette and use F6 when installing Windows 8. Anybody know of any please?

2. The Dell Latitude D820 BIOS battery has arrived, but time constraints mean I haven't been able to pull the laptop apart yet to check for internal dust build up.

4. The Samsung Galaxy S seems to give the "Registration Failed (13)" error mainly after visiting the shops. Coverage problem maybe? Bought a $2 SIM card today to try and rule out the SIM card as being the cause. Have already used two SIM cards from my Provider.

Report •

April 19, 2013 at 00:45:09
Great. Set BIOS to AHCI and loaded Intel R165149 after expansion which is Intel(R) ICH9 SATA AHCI Controller using F6 (actually says 'Load drivers' I think) successfully, only to be greeted with " Windows can't be installed on this drive 0x80300001" error.

Found some Google references suggesting the need to 'Refresh' before proceeding, but no go. Tried substituting a Hard Disk for the SSD I'm using, but same error comes up.

Running out of ideas and really want to run AHCI.

Report •

April 19, 2013 at 05:05:40
Finally got AHCI install working, except after a few Restarts, BOOTMGR is missing.

Have since sorted boot order of drives in the BIOS and all seems okay.

Report •

April 30, 2013 at 19:27:12
To bring matters up to date.

1. The Dell OptiPlex 755 Tower to replace the Dell OptiPlex 760 SFF which died has been giving the dreaded 0xc000000e Boot Error when my main USB external drive is attached for imaging the 755. Also, F2 and F12 weren't functioning but solved that by downgrading the BIOS from A22 to A19. Strangely, an older USB external drive works fine.

2. The Samsung Galaxy S mobile phone still gets the "Registration failed (13)" error at times, but usually when away from home. No coverage perhaps? Love the phone though, so will probably live with the slight inconvenience.

3. Finally took my wife's Dell Latitude D820 laptop apart today. Fitted the new CMOS battery I had bought and removed a layer of dust covering most of the length of the internal fins behind the fan. The fan itself was barely dusty. Only time will tell whether this will fix the laptop switching itself off, however, I also added a Desktop Gadget to indicate the core temperatures and also a program to change the fan speed [mainly for testing] and sound an alarm if the CPU gets too hot.

Now to continue with my cleanout of 30 odd years of computer collecting.

Report •

May 1, 2013 at 07:34:28
Thanks for the valuable feedback.

Always pop back and let us know the outcome - thanks

Report •

May 22, 2013 at 22:30:31
Took the Samsung Galaxy S mobile phone with the "Registration failed (13)"errors into Samsung Technical Support and they warned me that if they attempted to flash the phone it might end up bricked.

It did. They gave me a replacement phone and the old one back to play with. Great support and so far no errors. Incidentally, the dimensions of the back of the two phones have about a 1/128" difference and hence one back is not transferable to the other phone. The inside circuitry, well the differences there are probably more marked.

Report •

May 23, 2013 at 07:03:57
Glad to hear the phone is sorted now - thx for info.

Report •

Ask Question