Dell Dimension 4300 won't boot correctly

June 10, 2009 at 07:17:24
Specs: Windows XP Home
I have a pretty old (>4 yrs) Dell Dimension 4300 which worked fine till a few days ago. All of a sudden, with no changes made to the hardware or software, it regularly (in about 50% of the cases) didn't boot anymore. It shows the Dell logo and then it says "Primary drive not found." before it should show the Windows splash acreen. I then have the option of hitting F1 to continue, or F2 to go to a configuration utility. If I hit F1 it sometimes does boot, sometimes not.

If I look in the BIOS (version A06, newest as far as I could find out) I usually see that primary drive 0 (and other drives too) is not configured (usually "OFF" or "Unknown Device"). If I set that back to "auto" (-detect) it sometimes reboots without any problems and sometimes it has exactly the same issue.

At one of the good boots I run an extensive chkdsk. No errors were found. I've deconnected and reconnected the IDE cables, no avail.

Anyone has any idea what might cause this?

See More: Dell Dimension 4300 wont boot correctly

Report •

June 10, 2009 at 08:22:41
Did you deconnect and reconnect the power cables, or try new cables ? Also, I would run the manufacturer's diagnostics on the hard drive.

Report •

June 10, 2009 at 08:28:51
You mean the power cables of the drive? No, didn't try that. Will do that tonight.

I cannot find the DELL diagnostics disk, so I cannot try it.

From the above I can tell that you suspect the drive after all. How can it pass a chkdsk then?

Report •

June 10, 2009 at 08:52:51
Yes, I meant the power cables of the drive. I meant the hard drive manufacturer's diagnostics, which you should be able to download.

Report •

Related Solutions

June 10, 2009 at 10:45:22
The hard drive initialization procedure seems to be sporadic. If it goes OK then everything is normal. If not, you get the errors.

When it boots OK I doubt any diagnostic program will detect a problem. If it doesn't boot then you can't run a diagnostic.

Check that the drive data cable is in good condition and firmly attached but the problem is almost certainly with the drive itself.

Report •

June 12, 2009 at 04:33:00
Thanks for all the answers.

In the meantime I tried to disconnect and reconnect all the cables to the drive (they seem to be in good shape, but how do I know for sure?). No change.

Also the percentage of good boots seems to be lessening and I even got a BSOD a couple of times when it had booted well at, what seems to be, random moments. I'm afraid it is my disk and I will try to buy a new one and see if that will work.

Report •

August 15, 2009 at 04:28:56
Well in the meantime I installed a new harddisk and all the problems were over. So I guess it was the disk after all that caused all the problems. Thanks for all your help!

Report •

August 15, 2009 at 09:58:10
Thanks for posting back. We're glad you got it fixed.

Report •

Ask Question